]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- rel 2; fix gnutls code
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.28.0
25 Release:        2
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  f8a9f99d9db71d8ce1d2c4ccea3c3850
30 Patch1:         %{name}-ac.patch
31 Patch2:         %{name}-pc.patch
32 Patch3:         %{name}-krb5flags.patch
33 Patch4:         %{name}-gnutls.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libidn-devel >= 0.4.1
40 %{?with_rtmp:BuildRequires:     librtmp-devel}
41 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
42 BuildRequires:  libtool
43 BuildRequires:  nettle-devel
44 %{?with_ldap:BuildRequires:     openldap-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpm >= 4.4.9-56
47 BuildRequires:  rpmbuild(macros) >= 1.453
48 %if %{with ssl}
49 %if %{with gnutls}
50 BuildRequires:  gnutls-devel
51 %else
52 BuildRequires:  openssl-devel >= 0.9.7d
53 %endif
54 %endif
55 BuildRequires:  tar >= 1:1.22
56 BuildRequires:  zlib-devel
57 Requires:       %{name}-libs = %{version}-%{release}
58 Requires:       libidn >= 0.4.1
59 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
60 Obsoletes:      libcurl2
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 cURL is a tool for getting files with URL syntax, supporting FTP,
65 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
66 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
67 cookies, user+password authentication and a busload of other useful
68 tricks. The main use for curl is when you want to get or send files
69 automatically to or from a site using one of the supported protocols.
70
71 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72 Dict servers, using any of the supported protocols. cURL is designed
73 to work without user interaction or any kind of interactivity. cURL
74 offers many useful capabilities, like proxy support, user
75 authentication, FTP upload, HTTP post, and file transfer resume.
76
77 %description -l pl.UTF-8
78 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
79 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
80 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
81 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
82 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
83 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
84 pliki z/na serwer używając jednego z dostępnych protokołów.
85 %{?with_ssl:Ten pakiet obsługuje także SSL.}
86
87 %description -l pt_BR.UTF-8
88 Curl é um cliente para baixar/enviar arquivos de/para servidores
89 usando um dos protocolos suportados. É projetado para funcionar sem a
90 interação do usuário.
91
92 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
93 continuar transferências interrompidas, e mais...
94
95 %description -l ru.UTF-8
96 curl - это клиент с множеством поддерживаемых протоколов для получения
97 файлов с серверов, спроектированный для работы как в неинтерактивном
98 режиме, так и с возможностью диалога с пользователем.
99
100 curl поддерживает много полезных возможностей, среди которых поддержка
101 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
102 POST, восстановление прерванной пересылки и многое другое.
103
104 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
105 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
106 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
107
108 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
109 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
110 в╕дновлення перервано╖ пересилки та багато ╕ншого.
111
112 %package libs
113 Summary:        curl library
114 Summary(pl.UTF-8):      Biblioteka curl
115 Group:          Libraries
116 %{?with_ares:Requires:  c-ares >= 1.7.0}
117 Suggests:       ca-certificates
118 Conflicts:      ca-certificates < 20080809-4
119
120 %description libs
121 curl library.
122
123 %description libs -l pl.UTF-8
124 Biblioteka curl.
125
126 %package devel
127 Summary:        Header files and development documentation for curl library
128 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
129 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
130 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
131 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
132 Group:          Development/Libraries
133 Requires:       %{name}-libs = %{version}-%{release}
134 %{?with_ares:Requires:  c-ares-devel}
135 %{?with_kerberos5:Requires:     heimdal-devel}
136 Requires:       libidn-devel >= 0.4.1
137 %{?with_rtmp:Requires:  librtmp-devel}
138 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
139 %{?with_ldap:Requires:  openldap-devel}
140 %if %{with ssl}
141 %if %{with gnutls}
142 Requires:       gnutls-devel
143 %else
144 Requires:       openssl-devel >= 0.9.7c
145 %endif
146 %endif
147 Requires:       zlib-devel
148 Obsoletes:      libcurl2-devel
149
150 %description devel
151 Header files and development documentation for curl library.
152
153 %description devel -l pl.UTF-8
154 Pliki nagłówkowe i dokumentacja do biblioteki curl.
155
156 %description devel -l pt_BR.UTF-8
157 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
158
159 %description devel -l ru.UTF-8
160 Этот пакет содержит файлы, необходимые для разработки программ с
161 использованием библиотеки curl.
162
163 %description devel -l uk.UTF-8
164 Цей пакет містить файли, необхідні для розробки програм з
165 використанням бібліотеки curl.
166
167 %package static
168 Summary:        Static version of curl library
169 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
170 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
171 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
172 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175
176 %description static
177 Static version of curl library.
178
179 %description static -l pl.UTF-8
180 Statyczna wersja biblioteki curl.
181
182 %description static -l pt_BR.UTF-8
183 Bibliotecas estáticas para desenvolvimento com o curl.
184
185 %description static -l ru.UTF-8
186 Этот пакет содержит статическую библиотеку для разработки программ с
187 использованием библиотеки curl.
188
189 %description static -l uk.UTF-8
190 Цей пакет містить статичну бібліотеку для розробки програм з
191 використанням бібліотеки curl.
192
193 %prep
194 %setup -q
195 %patch1 -p1
196 %patch2 -p1
197 %patch3 -p1
198 %patch4 -p1
199
200 %{__rm} -v m4/lt*.m4 m4/libtool.m4
201
202 %build
203 %{__libtoolize}
204 %{__aclocal} -I m4
205 %{__autoconf}
206 %{__autoheader}
207 %{__automake}
208 %configure \
209         ac_cv_header_gss_h=no \
210 %if %{with ssl}
211         --with-ca-bundle=/etc/certs/ca-certificates.crt \
212 %if %{with gnutls}
213         --with-gnutls --without-ssl \
214 %else
215         --with-ssl=%{_prefix} \
216 %endif
217 %endif
218         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
219         %{?with_rtmp:--with-librtmp} \
220         %{?with_ares:--enable-ares} \
221         %{?with_ldap:--enable-ldaps} \
222         %{!?with_ldap:--disable-ldap} \
223         --enable-ipv6
224
225 %{__make}
226
227 %install
228 rm -rf $RPM_BUILD_ROOT
229
230 %{__make} install \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 # no longer in upstream but a lot of apps tries to include it so we create fake one
234 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
235 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %post   libs -p /sbin/ldconfig
241 %postun libs -p /sbin/ldconfig
242
243 %files
244 %defattr(644,root,root,755)
245 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
246 %attr(755,root,root) %{_bindir}/curl
247 %{_mandir}/man1/curl.1*
248
249 %files libs
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
252 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
253
254 %files devel
255 %defattr(644,root,root,755)
256 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
257 %attr(755,root,root) %{_bindir}/curl-config
258 %attr(755,root,root) %{_libdir}/libcurl.so
259 %{_libdir}/libcurl.la
260 %{_includedir}/curl
261 %{_pkgconfigdir}/libcurl.pc
262 %{_mandir}/man1/curl-config.1*
263 %{_mandir}/man3/curl_*.3*
264 %{_mandir}/man3/libcurl*.3*
265
266 %files static
267 %defattr(644,root,root,755)
268 %{_libdir}/libcurl.a
This page took 0.051029 seconds and 4 git commands to generate.