]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.27.0
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.27.0
25 Release:        1
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  1b669875527ba4b943a0cdb5b255a02c
30 Patch1:         %{name}-ac.patch
31 Patch2:         %{name}-pc.patch
32 Patch3:         %{name}-krb5flags.patch
33 Patch4:         lib%{name}.fb-changes.diff
34 Patch5:         gnutls3.patch
35 Patch6:         %{name}-gtls.patch
36 URL:            http://curl.haxx.se/
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 BuildRequires:  libidn-devel >= 0.4.1
42 %{?with_rtmp:BuildRequires:     librtmp-devel}
43 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
44 BuildRequires:  libtool
45 BuildRequires:  nettle-devel
46 %{?with_ldap:BuildRequires:     openldap-devel}
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm >= 4.4.9-56
49 BuildRequires:  rpmbuild(macros) >= 1.453
50 %if %{with ssl}
51 %if %{with gnutls}
52 BuildRequires:  gnutls-devel
53 %else
54 BuildRequires:  openssl-devel >= 0.9.7d
55 %endif
56 %endif
57 BuildRequires:  tar >= 1:1.22
58 BuildRequires:  zlib-devel
59 Requires:       %{name}-libs = %{version}-%{release}
60 Requires:       libidn >= 0.4.1
61 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
62 Obsoletes:      libcurl2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 cURL is a tool for getting files with URL syntax, supporting FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69 cookies, user+password authentication and a busload of other useful
70 tricks. The main use for curl is when you want to get or send files
71 automatically to or from a site using one of the supported protocols.
72
73 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74 Dict servers, using any of the supported protocols. cURL is designed
75 to work without user interaction or any kind of interactivity. cURL
76 offers many useful capabilities, like proxy support, user
77 authentication, FTP upload, HTTP post, and file transfer resume.
78
79 %description -l pl.UTF-8
80 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
83 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
84 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86 pliki z/na serwer używając jednego z dostępnych protokołów.
87 %{?with_ssl:Ten pakiet obsługuje także SSL.}
88
89 %description -l pt_BR.UTF-8
90 Curl é um cliente para baixar/enviar arquivos de/para servidores
91 usando um dos protocolos suportados. É projetado para funcionar sem a
92 interação do usuário.
93
94 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95 continuar transferências interrompidas, e mais...
96
97 %description -l ru.UTF-8
98 curl - это клиент с множеством поддерживаемых протоколов для получения
99 файлов с серверов, спроектированный для работы как в неинтерактивном
100 режиме, так и с возможностью диалога с пользователем.
101
102 curl поддерживает много полезных возможностей, среди которых поддержка
103 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104 POST, восстановление прерванной пересылки и многое другое.
105
106 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
109
110 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112 в╕дновлення перервано╖ пересилки та багато ╕ншого.
113
114 %package libs
115 Summary:        curl library
116 Summary(pl.UTF-8):      Biblioteka curl
117 Group:          Libraries
118 %{?with_ares:Requires:  c-ares >= 1.7.0}
119 Suggests:       ca-certificates
120 Conflicts:      ca-certificates < 20080809-4
121
122 %description libs
123 curl library.
124
125 %description libs -l pl.UTF-8
126 Biblioteka curl.
127
128 %package devel
129 Summary:        Header files and development documentation for curl library
130 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
131 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
132 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
133 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
134 Group:          Development/Libraries
135 Requires:       %{name}-libs = %{version}-%{release}
136 %{?with_ares:Requires:  c-ares-devel}
137 %{?with_kerberos5:Requires:     heimdal-devel}
138 Requires:       libidn-devel >= 0.4.1
139 %{?with_rtmp:Requires:  librtmp-devel}
140 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
141 %{?with_ldap:Requires:  openldap-devel}
142 %if %{with ssl}
143 %if %{with gnutls}
144 Requires:       gnutls-devel
145 %else
146 Requires:       openssl-devel >= 0.9.7c
147 %endif
148 %endif
149 Requires:       zlib-devel
150 Obsoletes:      libcurl2-devel
151
152 %description devel
153 Header files and development documentation for curl library.
154
155 %description devel -l pl.UTF-8
156 Pliki nagłówkowe i dokumentacja do biblioteki curl.
157
158 %description devel -l pt_BR.UTF-8
159 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
160
161 %description devel -l ru.UTF-8
162 Этот пакет содержит файлы, необходимые для разработки программ с
163 использованием библиотеки curl.
164
165 %description devel -l uk.UTF-8
166 Цей пакет містить файли, необхідні для розробки програм з
167 використанням бібліотеки curl.
168
169 %package static
170 Summary:        Static version of curl library
171 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
172 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
173 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
174 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177
178 %description static
179 Static version of curl library.
180
181 %description static -l pl.UTF-8
182 Statyczna wersja biblioteki curl.
183
184 %description static -l pt_BR.UTF-8
185 Bibliotecas estáticas para desenvolvimento com o curl.
186
187 %description static -l ru.UTF-8
188 Этот пакет содержит статическую библиотеку для разработки программ с
189 использованием библиотеки curl.
190
191 %description static -l uk.UTF-8
192 Цей пакет містить статичну бібліотеку для розробки програм з
193 використанням бібліотеки curl.
194
195 %prep
196 %setup -q
197 %patch1 -p1
198 %patch2 -p1
199 %patch3 -p1
200 %patch4 -p1
201 %patch5 -p1
202 %patch6 -p1
203
204 %{__rm} -v m4/lt*.m4 m4/libtool.m4
205
206 %build
207 %{__libtoolize}
208 %{__aclocal} -I m4
209 %{__autoconf}
210 %{__autoheader}
211 %{__automake}
212 %configure \
213         ac_cv_header_gss_h=no \
214 %if %{with ssl}
215         --with-ca-bundle=/etc/certs/ca-certificates.crt \
216 %if %{with gnutls}
217         --with-gnutls --without-ssl \
218 %else
219         --with-ssl=%{_prefix} \
220 %endif
221 %endif
222         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
223         %{?with_rtmp:--with-librtmp} \
224         %{?with_ares:--enable-ares} \
225         %{?with_ldap:--enable-ldaps} \
226         %{!?with_ldap:--disable-ldap} \
227         --enable-ipv6
228
229 %{__make}
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233
234 %{__make} install \
235         DESTDIR=$RPM_BUILD_ROOT
236
237 # no longer in upstream but a lot of apps tries to include it so we create fake one
238 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
239 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %post   libs -p /sbin/ldconfig
245 %postun libs -p /sbin/ldconfig
246
247 %files
248 %defattr(644,root,root,755)
249 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
250 %attr(755,root,root) %{_bindir}/curl
251 %{_mandir}/man1/curl.1*
252
253 %files libs
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
256 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
257
258 %files devel
259 %defattr(644,root,root,755)
260 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
261 %attr(755,root,root) %{_bindir}/curl-config
262 %attr(755,root,root) %{_libdir}/libcurl.so
263 %{_libdir}/libcurl.la
264 %{_includedir}/curl
265 %{_pkgconfigdir}/libcurl.pc
266 %{_mandir}/man1/curl-config.1*
267 %{_mandir}/man3/curl_*.3*
268 %{_mandir}/man3/libcurl*.3*
269
270 %files static
271 %defattr(644,root,root,755)
272 %{_libdir}/libcurl.a
This page took 0.05003 seconds and 4 git commands to generate.