]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.77.0, solves:
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  gsasl           # SCRAM support with gsasl
8 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
9 %bcond_without  ldap            # LDAP support
10 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
11 %bcond_without  metalink        # metalink support
12 %if "%{pld_release}" != "ac"
13 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
14 %bcond_without  rtmp            # Real Time Media Protocol support
15 %else
16 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
17 %bcond_with     rtmp            # Real Time Media Protocol support
18 %endif
19
20 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
21 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
22 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
23 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
24 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
25 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
26 Name:           curl
27 Version:        7.77.0
28 Release:        1
29 License:        MIT-like
30 Group:          Applications/Networking
31 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
32 # Source0-md5:  3cf78c539cae019cf96ba38571706e06
33 Patch0:         %{name}-ac.patch
34 Patch1:         %{name}-krb5flags.patch
35 URL:            http://curl.haxx.se/
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
39 %{?with_gsasl:BuildRequires:    gsasl-devel}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 BuildRequires:  libbrotli-devel >= 1.0.0
42 BuildRequires:  libidn2-devel
43 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
44 BuildRequires:  libpsl-devel
45 %{?with_rtmp:BuildRequires:     librtmp-devel}
46 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
47 BuildRequires:  libtool
48 BuildRequires:  nettle-devel
49 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.12.0}
50 %{?with_ldap:BuildRequires:     openldap-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpm >= 4.4.9-56
53 BuildRequires:  rpm-build >= 4.6
54 BuildRequires:  rpmbuild(macros) >= 1.527
55 %if %{with ssl}
56 %if %{with gnutls}
57 BuildRequires:  gnutls-devel >= 3.1.10
58 %else
59 BuildRequires:  openssl-devel >= 1.0.1
60 %endif
61 %endif
62 BuildRequires:  tar >= 1:1.22
63 BuildRequires:  xz
64 BuildRequires:  zlib-devel
65 BuildRequires:  zstd-devel
66 Requires:       %{name}-libs = %{version}-%{release}
67 Obsoletes:      libcurl2
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 cURL is a tool for getting files with URL syntax, supporting FTP,
72 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
73 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
74 cookies, user+password authentication and a busload of other useful
75 tricks. The main use for curl is when you want to get or send files
76 automatically to or from a site using one of the supported protocols.
77
78 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
79 Dict servers, using any of the supported protocols. cURL is designed
80 to work without user interaction or any kind of interactivity. cURL
81 offers many useful capabilities, like proxy support, user
82 authentication, FTP upload, HTTP post, and file transfer resume.
83
84 %description -l pl.UTF-8
85 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
86 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
87 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
88 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
89 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
90 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
91 pliki z/na serwer używając jednego z dostępnych protokołów.
92 %{?with_ssl:Ten pakiet obsługuje także SSL.}
93
94 %description -l pt_BR.UTF-8
95 Curl é um cliente para baixar/enviar arquivos de/para servidores
96 usando um dos protocolos suportados. É projetado para funcionar sem a
97 interação do usuário.
98
99 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
100 continuar transferências interrompidas, e mais...
101
102 %description -l ru.UTF-8
103 curl - это клиент с множеством поддерживаемых протоколов для получения
104 файлов с серверов, спроектированный для работы как в неинтерактивном
105 режиме, так и с возможностью диалога с пользователем.
106
107 curl поддерживает много полезных возможностей, среди которых поддержка
108 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
109 POST, восстановление прерванной пересылки и многое другое.
110
111 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
112 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
113 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
114
115 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
116 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
117 в╕дновлення перервано╖ пересилки та багато ╕ншого.
118
119 %package libs
120 Summary:        curl library
121 Summary(pl.UTF-8):      Biblioteka curl
122 Group:          Libraries
123 %{?with_ares:Requires:  c-ares >= 1.7.0}
124 %{?with_gnutls:Requires:        gnutls-libs >= 3.1.10}
125 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
126 %{?with_http2:Requires: nghttp2-libs >= 1.12.0}
127 %if %{with ssl} && %{without gnutls}
128 Requires:       libbrotli >= 1.0.0
129 Requires:       openssl >= 1.0.1
130 %endif
131 Suggests:       ca-certificates
132 Conflicts:      ca-certificates < 20080809-4
133
134 %description libs
135 curl library.
136
137 %description libs -l pl.UTF-8
138 Biblioteka curl.
139
140 %package devel
141 Summary:        Header files and development documentation for curl library
142 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
143 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
144 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
145 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
146 Group:          Development/Libraries
147 Requires:       %{name}-libs = %{version}-%{release}
148 %{?with_ares:Requires:  c-ares-devel}
149 %{?with_gsasl:Requires: gsasl-devel}
150 %{?with_kerberos5:Requires:     heimdal-devel}
151 Requires:       libbrotli-devel >= 1.0.0
152 Requires:       libidn2-devel
153 Requires:       libpsl-devel
154 %{?with_rtmp:Requires:  librtmp-devel}
155 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
156 %{?with_http2:Requires: nghttp2-devel >= 1.12.0}
157 %{?with_ldap:Requires:  openldap-devel}
158 %if %{with ssl}
159 %if %{with gnutls}
160 Requires:       gnutls-devel >= 3.1.10
161 %else
162 Requires:       openssl-devel >= 0.9.7c
163 %endif
164 %endif
165 Requires:       zlib-devel
166 Requires:       zstd-devel
167 Obsoletes:      libcurl2-devel
168
169 %description devel
170 Header files and development documentation for curl library.
171
172 %description devel -l pl.UTF-8
173 Pliki nagłówkowe i dokumentacja do biblioteki curl.
174
175 %description devel -l pt_BR.UTF-8
176 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
177
178 %description devel -l ru.UTF-8
179 Этот пакет содержит файлы, необходимые для разработки программ с
180 использованием библиотеки curl.
181
182 %description devel -l uk.UTF-8
183 Цей пакет містить файли, необхідні для розробки програм з
184 використанням бібліотеки curl.
185
186 %package static
187 Summary:        Static version of curl library
188 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
189 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
190 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
191 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}-%{release}
194
195 %description static
196 Static version of curl library.
197
198 %description static -l pl.UTF-8
199 Statyczna wersja biblioteki curl.
200
201 %description static -l pt_BR.UTF-8
202 Bibliotecas estáticas para desenvolvimento com o curl.
203
204 %description static -l ru.UTF-8
205 Этот пакет содержит статическую библиотеку для разработки программ с
206 использованием библиотеки curl.
207
208 %description static -l uk.UTF-8
209 Цей пакет містить статичну бібліотеку для розробки програм з
210 використанням бібліотеки curl.
211
212 %package -n fish-completion-%{name}
213 Summary:        Fish completion for curl command
214 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
215 Group:          Applications/Shells
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       fish
218 BuildArch:      noarch
219
220 %description -n fish-completion-%{name}
221 Fish completion for curl command.
222
223 %description -n fish-completion-%{name} -l pl.UTF-8
224 Dopełnianie parametrów w fish dla polecenia curl.
225
226 %package -n zsh-completion-curl
227 Summary:        ZSH completion for curl command
228 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
229 Group:          Applications/Shells
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       zsh
232 BuildArch:      noarch
233
234 %description -n zsh-completion-curl
235 ZSH completion for curl command.
236
237 %description -n zsh-completion-curl -l pl.UTF-8
238 Dopełnianianie parametrów w ZSH dla polecenia curl.
239
240 %prep
241 %setup -q
242 %patch0 -p1
243 %patch1 -p1
244
245 %{__rm} m4/lt*.m4 m4/libtool.m4
246
247 %build
248 %{__libtoolize}
249 %{__aclocal} -I m4
250 %{__autoconf}
251 %{__autoheader}
252 %{__automake}
253 %configure \
254         ac_cv_header_gss_h=no \
255         %{__enable_disable ares} \
256         %{__enable_disable gsasl} \
257         --enable-ipv6 \
258         %{__enable_disable ldap} \
259         %{__enable_disable ldap ldaps} \
260         --disable-silent-rules \
261 %if %{with ssl}
262         --with-ca-bundle=/etc/certs/ca-certificates.crt \
263 %if %{with gnutls}
264         --with-gnutls --without-ssl \
265 %else
266         --with-ssl=%{_prefix} \
267 %endif
268 %else
269         --without-ssl --without-gnutls \
270 %endif
271         --with-fish-functions-dir=%{fish_compdir} \
272         %{__with_without kerberos5 gssapi %{_prefix}} \
273         %{__with_without metalink libmetalink} \
274         %{__with_without rtmp librtmp} \
275         %{__with_without http2 nghttp2} \
276         %{__with_without ssh libssh2}
277
278 %{__make}
279
280 %install
281 rm -rf $RPM_BUILD_ROOT
282
283 %{__make} install \
284         DESTDIR=$RPM_BUILD_ROOT
285
286 %{__make} -C scripts install \
287         DESTDIR=$RPM_BUILD_ROOT
288
289 # obsoleted by pkg-config
290 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
291
292 # no longer in upstream but a lot of apps tries to include it so we create fake one
293 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
294 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %post   libs -p /sbin/ldconfig
300 %postun libs -p /sbin/ldconfig
301
302 %files
303 %defattr(644,root,root,755)
304 %doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
305 %attr(755,root,root) %{_bindir}/curl
306 %{_mandir}/man1/curl.1*
307
308 %files libs
309 %defattr(644,root,root,755)
310 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
311 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
312
313 %files devel
314 %defattr(644,root,root,755)
315 %doc docs/{CONTRIBUTE.md,INTERNALS.md}
316 %attr(755,root,root) %{_bindir}/curl-config
317 %attr(755,root,root) %{_libdir}/libcurl.so
318 %{_includedir}/curl
319 %{_pkgconfigdir}/libcurl.pc
320 %{_aclocaldir}/libcurl.m4
321 %{_mandir}/man1/curl-config.1*
322 %{_mandir}/man3/curl_*.3*
323 %{_mandir}/man3/libcurl*.3*
324 %{_mandir}/man3/CURLINFO_*.3*
325 %{_mandir}/man3/CURLOPT_*.3*
326 %{_mandir}/man3/CURLMOPT_*.3*
327
328 %files static
329 %defattr(644,root,root,755)
330 %{_libdir}/libcurl.a
331
332 %files -n fish-completion-%{name}
333 %defattr(644,root,root,755)
334 %{fish_compdir}/curl.fish
335
336 %files -n zsh-completion-curl
337 %defattr(644,root,root,755)
338 %{_datadir}/zsh/site-functions/_curl
This page took 0.048515 seconds and 4 git commands to generate.