]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
up to 7.71.1
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
8 %bcond_without  ldap            # LDAP support
9 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
10 %bcond_without  metalink        # metalink support
11 %if "%{pld_release}" != "ac"
12 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
13 %bcond_without  rtmp            # Real Time Media Protocol support
14 %else
15 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
16 %bcond_with     rtmp            # Real Time Media Protocol support
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.71.1
27 Release:        1
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
31 # Source0-md5:  b54b386057846ce3edd3584b19741569
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libbrotli-devel >= 1.0.0
40 BuildRequires:  libidn2-devel
41 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42 BuildRequires:  libpsl-devel
43 %{?with_rtmp:BuildRequires:     librtmp-devel}
44 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
45 BuildRequires:  libtool
46 BuildRequires:  nettle-devel
47 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.12.0}
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.527
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel >= 3.1.10
55 %else
56 BuildRequires:  openssl-devel >= 1.0.1
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Obsoletes:      libcurl2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 cURL is a tool for getting files with URL syntax, supporting FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69 cookies, user+password authentication and a busload of other useful
70 tricks. The main use for curl is when you want to get or send files
71 automatically to or from a site using one of the supported protocols.
72
73 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74 Dict servers, using any of the supported protocols. cURL is designed
75 to work without user interaction or any kind of interactivity. cURL
76 offers many useful capabilities, like proxy support, user
77 authentication, FTP upload, HTTP post, and file transfer resume.
78
79 %description -l pl.UTF-8
80 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
83 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
84 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86 pliki z/na serwer używając jednego z dostępnych protokołów.
87 %{?with_ssl:Ten pakiet obsługuje także SSL.}
88
89 %description -l pt_BR.UTF-8
90 Curl é um cliente para baixar/enviar arquivos de/para servidores
91 usando um dos protocolos suportados. É projetado para funcionar sem a
92 interação do usuário.
93
94 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95 continuar transferências interrompidas, e mais...
96
97 %description -l ru.UTF-8
98 curl - это клиент с множеством поддерживаемых протоколов для получения
99 файлов с серверов, спроектированный для работы как в неинтерактивном
100 режиме, так и с возможностью диалога с пользователем.
101
102 curl поддерживает много полезных возможностей, среди которых поддержка
103 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104 POST, восстановление прерванной пересылки и многое другое.
105
106 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
109
110 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112 в╕дновлення перервано╖ пересилки та багато ╕ншого.
113
114 %package libs
115 Summary:        curl library
116 Summary(pl.UTF-8):      Biblioteka curl
117 Group:          Libraries
118 %{?with_ares:Requires:  c-ares >= 1.7.0}
119 %{?with_gnutls:Requires:        gnutls-libs >= 3.1.10}
120 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
121 %{?with_http2:Requires: nghttp2-libs >= 1.12.0}
122 %if %{with ssl} && %{without gnutls}
123 Requires:       libbrotli >= 1.0.0
124 Requires:       openssl >= 1.0.1
125 %endif
126 Suggests:       ca-certificates
127 Conflicts:      ca-certificates < 20080809-4
128
129 %description libs
130 curl library.
131
132 %description libs -l pl.UTF-8
133 Biblioteka curl.
134
135 %package devel
136 Summary:        Header files and development documentation for curl library
137 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
138 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
139 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
140 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
141 Group:          Development/Libraries
142 Requires:       %{name}-libs = %{version}-%{release}
143 %{?with_ares:Requires:  c-ares-devel}
144 %{?with_kerberos5:Requires:     heimdal-devel}
145 Requires:       libbrotli-devel >= 1.0.0
146 Requires:       libidn2-devel
147 Requires:       libpsl-devel
148 %{?with_rtmp:Requires:  librtmp-devel}
149 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
150 %{?with_http2:Requires: nghttp2-devel >= 1.12.0}
151 %{?with_ldap:Requires:  openldap-devel}
152 %if %{with ssl}
153 %if %{with gnutls}
154 Requires:       gnutls-devel >= 3.1.10
155 %else
156 Requires:       openssl-devel >= 0.9.7c
157 %endif
158 %endif
159 Requires:       zlib-devel
160 Obsoletes:      libcurl2-devel
161
162 %description devel
163 Header files and development documentation for curl library.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe i dokumentacja do biblioteki curl.
167
168 %description devel -l pt_BR.UTF-8
169 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
170
171 %description devel -l ru.UTF-8
172 Этот пакет содержит файлы, необходимые для разработки программ с
173 использованием библиотеки curl.
174
175 %description devel -l uk.UTF-8
176 Цей пакет містить файли, необхідні для розробки програм з
177 використанням бібліотеки curl.
178
179 %package static
180 Summary:        Static version of curl library
181 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
182 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
183 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
184 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}-%{release}
187
188 %description static
189 Static version of curl library.
190
191 %description static -l pl.UTF-8
192 Statyczna wersja biblioteki curl.
193
194 %description static -l pt_BR.UTF-8
195 Bibliotecas estáticas para desenvolvimento com o curl.
196
197 %description static -l ru.UTF-8
198 Этот пакет содержит статическую библиотеку для разработки программ с
199 использованием библиотеки curl.
200
201 %description static -l uk.UTF-8
202 Цей пакет містить статичну бібліотеку для розробки програм з
203 використанням бібліотеки curl.
204
205 %package -n fish-completion-%{name}
206 Summary:        Fish completion for curl command
207 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
208 Group:          Applications/Shells
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       fish
211
212 %description -n fish-completion-%{name}
213 Fish completion for curl command.
214
215 %description -n fish-completion-%{name} -l pl.UTF-8
216 Dopełnianie parametrów w fish dla polecenia curl.
217
218 %package -n zsh-completion-curl
219 Summary:        ZSH completion for curl command
220 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
221 Group:          Applications/Shells
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       zsh
224
225 %description -n zsh-completion-curl
226 ZSH completion for curl command.
227
228 %description -n zsh-completion-curl -l pl.UTF-8
229 Dopełnianianie parametrów w ZSH dla polecenia curl.
230
231 %prep
232 %setup -q
233 %patch0 -p1
234 %patch1 -p1
235
236 %{__rm} m4/lt*.m4 m4/libtool.m4
237
238 %build
239 %{__libtoolize}
240 %{__aclocal} -I m4
241 %{__autoconf}
242 %{__autoheader}
243 %{__automake}
244 %configure \
245         ac_cv_header_gss_h=no \
246         %{__enable_disable ares} \
247         --enable-ipv6 \
248         %{__enable_disable ldap} \
249         %{__enable_disable ldap ldaps} \
250         --disable-silent-rules \
251 %if %{with ssl}
252         --with-ca-bundle=/etc/certs/ca-certificates.crt \
253 %if %{with gnutls}
254         --with-gnutls --without-ssl \
255 %else
256         --with-ssl=%{_prefix} \
257 %endif
258 %else
259         --without-ssl --without-gnutls \
260 %endif
261         --with-fish-functions-dir=%{fish_compdir} \
262         %{__with_without kerberos5 gssapi %{_prefix}} \
263         %{__with_without metalink libmetalink} \
264         %{__with_without rtmp librtmp} \
265         %{__with_without http2 nghttp2} \
266         %{__with_without ssh libssh2}
267
268 %{__make}
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 %{__make} install \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 %{__make} -C scripts install \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 # no longer in upstream but a lot of apps tries to include it so we create fake one
279 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
280 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %post   libs -p /sbin/ldconfig
286 %postun libs -p /sbin/ldconfig
287
288 %files
289 %defattr(644,root,root,755)
290 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
291 %attr(755,root,root) %{_bindir}/curl
292 %{_mandir}/man1/curl.1*
293
294 %files libs
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
297 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
298
299 %files devel
300 %defattr(644,root,root,755)
301 %doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
302 %attr(755,root,root) %{_bindir}/curl-config
303 %attr(755,root,root) %{_libdir}/libcurl.so
304 %{_libdir}/libcurl.la
305 %{_includedir}/curl
306 %{_pkgconfigdir}/libcurl.pc
307 %{_aclocaldir}/libcurl.m4
308 %{_mandir}/man1/curl-config.1*
309 %{_mandir}/man3/curl_*.3*
310 %{_mandir}/man3/libcurl*.3*
311 %{_mandir}/man3/CURLINFO_*.3*
312 %{_mandir}/man3/CURLOPT_*.3*
313 %{_mandir}/man3/CURLMOPT_*.3*
314
315 %files static
316 %defattr(644,root,root,755)
317 %{_libdir}/libcurl.a
318
319 %files -n fish-completion-%{name}
320 %defattr(644,root,root,755)
321 %{fish_compdir}/%{name}.fish
322
323 %files -n zsh-completion-curl
324 %defattr(644,root,root,755)
325 %{_datadir}/zsh/site-functions/_curl
This page took 0.075606 seconds and 3 git commands to generate.