]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- devel R: openldap-devel
[packages/curl.git] / curl.spec
1 # TODO
2 # - VMware needs curl with ares
3 #
4 # Conditional build:
5 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library (c-ares may not work properly with ipv6)
6 %bcond_without  ssh             # without SSH support
7 %bcond_without  ssl             # without SSL support
8 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
9 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 #
12 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
13 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
14 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
15 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
16 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
17 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
18 Name:           curl
19 Version:        7.21.0
20 Release:        4
21 License:        MIT-like
22 Group:          Applications/Networking
23 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
24 # Source0-md5:  de2820f567c29f895a2b36fcfa2c1178
25 Patch0:         %{name}-no_strip.patch
26 Patch1:         %{name}-ac.patch
27 Patch2:         %{name}-pc.patch
28 Patch3:         %{name}-krb5flags.patch
29 Patch4:         libcurl.fb-changes.diff
30 URL:            http://curl.haxx.se/
31 BuildRequires:  autoconf >= 2.57
32 BuildRequires:  automake
33 %{?with_ares:BuildRequires:     c-ares-devel}
34 %{?with_kerberos5:BuildRequires:        heimdal-devel}
35 BuildRequires:  libidn-devel >= 0.4.1
36 %{?with_rtmp:BuildRequires:     librtmp-devel}
37 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
38 BuildRequires:  libtool
39 BuildRequires:  openldap-devel
40 %if %{with ssl}
41 %if %{with gnutls}
42 BuildRequires:  gnutls-devel
43 %else
44 BuildRequires:  openssl-devel >= 0.9.7d
45 %endif
46 %endif
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  zlib-devel
49 Requires:       %{name}-libs = %{version}-%{release}
50 Requires:       libidn >= 0.4.1
51 %{?with_ssh:Requires:   libssh2 >= 0.16}
52 Requires:       openssl-tools >= 0.9.7d
53 Obsoletes:      libcurl2
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 cURL is a tool for getting files with URL syntax, supporting FTP,
58 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
59 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
60 cookies, user+password authentication and a busload of other useful
61 tricks. The main use for curl is when you want to get or send files
62 automatically to or from a site using one of the supported protocols.
63
64 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
65 Dict servers, using any of the supported protocols. cURL is designed
66 to work without user interaction or any kind of interactivity. cURL
67 offers many useful capabilities, like proxy support, user
68 authentication, FTP upload, HTTP post, and file transfer resume.
69
70 %description -l pl.UTF-8
71 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
72 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
73 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
74 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
75 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
76 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
77 pliki z/na serwer używając jednego z dostępnych protokołów.
78 %{?with_ssl:Ten pakiet obsługuje także SSL.}
79
80 %description -l pt_BR.UTF-8
81 Curl é um cliente para baixar/enviar arquivos de/para servidores
82 usando um dos protocolos suportados. É projetado para funcionar sem a
83 interação do usuário.
84
85 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
86 continuar transferências interrompidas, e mais...
87
88 %description -l ru.UTF-8
89 curl - это клиент с множеством поддерживаемых протоколов для получения
90 файлов с серверов, спроектированный для работы как в неинтерактивном
91 режиме, так и с возможностью диалога с пользователем.
92
93 curl поддерживает много полезных возможностей, среди которых поддержка
94 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
95 POST, восстановление прерванной пересылки и многое другое.
96
97 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
98 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
99 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
100
101 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
102 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
103 в╕дновлення перервано╖ пересилки та багато ╕ншого.
104
105 %package libs
106 Summary:        curl library
107 Summary(pl.UTF-8):      Biblioteka curl
108 Group:          Libraries
109 Suggests:       ca-certificates
110 Conflicts:      ca-certificates < 20080809-4
111
112 %description libs
113 curl library.
114
115 %description libs -l pl.UTF-8
116 Biblioteka curl.
117
118 %package devel
119 Summary:        Header files and development documentation for curl library
120 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
121 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
122 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
123 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
124 Group:          Development/Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126 %{?with_ares:Requires:  c-ares-devel}
127 %{?with_kerberos5:Requires:     heimdal-devel}
128 Requires:       libidn-devel >= 0.4.1
129 %{?with_rtmp:Requires:  librtmp-devel}
130 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
131 Requires:       openldap-devel
132 %if %{with ssl}
133 %if %{with gnutls}
134 Requires:       gnutls-devel
135 %else
136 Requires:       openssl-devel >= 0.9.7c
137 %endif
138 %endif
139 Requires:       zlib-devel
140 Obsoletes:      libcurl2-devel
141
142 %description devel
143 Header files and development documentation for curl library.
144
145 %description devel -l pl.UTF-8
146 Pliki nagłówkowe i dokumentacja do biblioteki curl.
147
148 %description devel -l pt_BR.UTF-8
149 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
150
151 %description devel -l ru.UTF-8
152 Этот пакет содержит файлы, необходимые для разработки программ с
153 использованием библиотеки curl.
154
155 %description devel -l uk.UTF-8
156 Цей пакет містить файли, необхідні для розробки програм з
157 використанням бібліотеки curl.
158
159 %package static
160 Summary:        Static version of curl library
161 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
162 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
163 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
164 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167
168 %description static
169 Static version of curl library.
170
171 %description static -l pl.UTF-8
172 Statyczna wersja biblioteki curl.
173
174 %description static -l pt_BR.UTF-8
175 Bibliotecas estáticas para desenvolvimento com o curl.
176
177 %description static -l ru.UTF-8
178 Этот пакет содержит статическую библиотеку для разработки программ с
179 использованием библиотеки curl.
180
181 %description static -l uk.UTF-8
182 Цей пакет містить статичну бібліотеку для розробки програм з
183 використанням бібліотеки curl.
184
185 %prep
186 %setup -q
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p0
192
193 %build
194 %{__libtoolize}
195 %{__aclocal} -I m4
196 %{__autoconf}
197 %{__autoheader}
198 %{__automake}
199 %configure \
200         ac_cv_header_gss_h=no \
201 %if %{with ssl}
202         --with-ca-bundle=/etc/certs/ca-certificates.crt \
203 %if %{with gnutls}
204         --with-gnutls=%{_prefix} --without-ssl \
205 %else
206         --with-ssl=%{_prefix} \
207 %endif
208 %endif
209         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
210         %{?with_ares:--enable-ares=%{_prefix}} \
211         %{?with_rtmp:--with-librtmp=%{_prefix}} \
212         --enable-ldaps \
213         --enable-ipv6
214
215 %{__make}
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219
220 %{__make} install \
221         DESTDIR=$RPM_BUILD_ROOT
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 %post   libs -p /sbin/ldconfig
227 %postun libs -p /sbin/ldconfig
228
229 %files
230 %defattr(644,root,root,755)
231 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
232 %attr(755,root,root) %{_bindir}/curl
233 %{_mandir}/man1/curl.1*
234
235 %files libs
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
238 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
239
240 %files devel
241 %defattr(644,root,root,755)
242 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
243 %attr(755,root,root) %{_bindir}/curl-config
244 %attr(755,root,root) %{_libdir}/libcurl.so
245 %{_libdir}/libcurl.la
246 %{_includedir}/curl
247 %{_pkgconfigdir}/libcurl.pc
248 %{_mandir}/man1/curl-config.1*
249 %{_mandir}/man3/curl_*.3*
250 %{_mandir}/man3/libcurl*.3*
251
252 %files static
253 %defattr(644,root,root,755)
254 %{_libdir}/libcurl.a
This page took 0.070452 seconds and 3 git commands to generate.