]> git.pld-linux.org Git - packages/csync2.git/blob - csync2.spec
- install doc files only once during make install
[packages/csync2.git] / csync2.spec
1 Summary:        Cluster sync tool
2 Summary(pl.UTF-8):      Narzędzie do synchronizacji klastra
3 Name:           csync2
4 Version:        2.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Daemons
8 Source0:        http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
9 # Source0-md5:  4e189ff02af441e588ceaa7791732162
10 Source1:        %{name}.init
11 Source2:        %{name}.inet
12 Source3:        %{name}.sysconfig
13 Patch0:         %{name}-fix-sonames.patch
14 Patch1:         %{name}-docdata.patch
15 URL:            http://oss.linbit.com/csync2/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gnutls-devel
21 BuildRequires:  librsync-devel
22 BuildRequires:  mysql-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  postgresql-devel
25 BuildRequires:  sqlite3-devel
26 BuildRequires:  texlive-format-pdflatex
27 Requires:       setup > 2.4.10-4
28 Suggests:       mysql-libs
29 Suggests:       postgresql-libs
30 Suggests:       sqlite3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/%{name}
34
35 %description
36 Csync2 is a cluster synchronization tool. It can be used to keep files
37 on multiple hosts in a cluster in sync. Csync2 can handle complex
38 setups with much more than just 2 hosts, handle file deletions and can
39 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
40 and server farms.
41
42 %description -l pl.UTF-8
43 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
44 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
45 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
46 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
47 klastrów HA, HPC, COW oraz farm serwerów.
48
49 %package -n csync2-inetd
50 Summary:        Files necessary to run csync2 in inetd service mode
51 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie usługi inetd
52 Group:          Networking/Daemons
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       rc-inetd
55 Provides:       csyncd
56 Provides:       csyncd-inetd
57 Obsoletes:      csyncd
58 Obsoletes:      csync2-standalone
59 Obsoletes:      csyncd-standalone
60
61 %description -n csync2-inetd
62 Csync2 is a cluster synchronization tool. It can be used to keep files
63 on multiple hosts in a cluster in sync. Csync2 can handle complex
64 setups with much more than just 2 hosts, handle file deletions and can
65 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
66 and server farms.
67
68 %description -n csync2-inetd -l pl.UTF-8
69 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
70 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
71 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
72 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
73 klastrów HA, HPC, COW oraz farm serwerów.
74
75 %package -n csync2-standalone
76 Summary:        Files necessary to run csync2 in standalone daemon mode
77 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie samodzielnego serwera
78 Group:          Networking/Daemons
79 Requires(post,preun):   /sbin/chkconfig
80 Requires:       %{name} = %{version}-%{release}
81 Provides:       csyncd
82 Provides:       csyncd-standalone
83 Obsoletes:      csyncd
84 Obsoletes:      csync2-inetd
85 Obsoletes:      csyncd-inetd
86
87 %description -n csync2-standalone
88 Csync2 is a cluster synchronization tool. It can be used to keep files
89 on multiple hosts in a cluster in sync. Csync2 can handle complex
90 setups with much more than just 2 hosts, handle file deletions and can
91 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
92 and server farms.
93
94 %description -n csync2-standalone -l pl.UTF-8
95 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
96 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
97 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
98 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
99 klastrów HA, HPC, COW oraz farm serwerów.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p0
105
106 %build
107 %{__aclocal}
108 %{__automake}
109 %{__autoconf}
110 %configure \
111         --enable-gnutls \
112         --enable-mysql \
113         --enable-postgres \
114         --enable-sqlite3
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_var}/lib/csync2,/etc/{sysconfig/rc-inetd,rc.d/init.d}}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
125 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
126 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -n csync2-inetd
132 %service -q rc-inetd reload
133
134 %postun -n csync2-inetd
135 if [ "$1" = "0" ]; then
136         %service -q rc-inetd reload
137 fi
138
139 %post -n csync2-standalone
140 /sbin/chkconfig --add csync2
141 %service csync2 restart "csync2 server"
142
143 %preun -n csync2-standalone
144 if [ "$1" = "0" ]; then
145         %service csync2 stop
146         /sbin/chkconfig --del csync2
147 fi
148
149 %files
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog README csync2.xinetd doc/csync2_paper.pdf
152 %dir %{_sysconfdir}
153 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/csync2.cfg
154 %attr(755,root,root) %{_sbindir}/csync2
155 %attr(755,root,root) %{_sbindir}/csync2-compare
156 %dir %{_var}/lib/csync2
157 %{_mandir}/man1/*.1*
158
159 %files -n csync2-inetd
160 %defattr(644,root,root,755)
161 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/%{name}
162
163 %files -n csync2-standalone
164 %defattr(644,root,root,755)
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
166 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.050018 seconds and 3 git commands to generate.