]> git.pld-linux.org Git - packages/crossnacl-binutils.git/blob - crossnacl-binutils.spec
revert a710c0, e0648d3 is newer than f412ed5 in nacl-binutils repo
[packages/crossnacl-binutils.git] / crossnacl-binutils.spec
1 %define         gitver e0648d3
2 Summary:        Cross NaCL GNU binary utility development utilities - binutils
3 Name:           crossnacl-binutils
4 Version:        2.20.1
5 Release:        3.git%{gitver}.1
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        nacl-binutils-%{version}-git%{gitver}.tar.xz
9 # Source0-md5:  b49c25e5cb1bbfb5333aa82bcbda12df
10 Source1:        get-source.sh
11 URL:            http://git.chromium.org/gitweb/?p=native_client/nacl-binutils.git
12 BuildRequires:  bash
13 BuildRequires:  bison
14 BuildRequires:  flex
15 BuildRequires:  fslint
16 BuildRequires:  python-modules
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 ExclusiveArch:  %{ix86} %{x8664}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         target          x86_64-nacl
23 %define         arch            %{_prefix}/%{target}
24
25 %description
26 Binutils is a collection of binary utilities, including:
27 - ar - create, modify and extract from archives,
28 - nm - lists symbols from object files,
29 - objcopy - copy and translate object files,
30 - objdump - display information from object files,
31 - ranlib - generate an index for the contents of an archive,
32 - size - list the section sizes of an object or archive file,
33 - strings - list printable strings from files,
34 - strip - discard symbols,
35 - c++filt - a filter for demangling encoded C++ symbols,
36 - addr2line - convert addresses to file and line,
37 - nlmconv - convert object code into an NLM.
38
39 This package contains the cross version for NaCL.
40
41 %description -l pl.UTF-8
42 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
43 programów. Znajdują się tutaj między innymi assembler, konsolidator
44 (linker), a także inne narzędzia do manipulowania binarnymi plikami
45 programów i bibliotek.
46
47 Ten pakiet zawiera wersję skrośną generującą kod dla NaCl.
48
49 %prep
50 %setup -q -n nacl-binutils-%{version}-git%{gitver}
51
52 %build
53 # ldscripts won't be generated properly if SHELL is not bash...
54 CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
55 LDFLAGS="%{rpmldflags}" \
56 CONFIG_SHELL="/bin/bash" \
57 ./configure \
58         --build=%{_target_platform} \
59         --host=%{_target_platform} \
60         --target=%{target} \
61         --enable-targets=%{_host} \
62 %ifarch ia64
63         --enable-targets=i386-linux \
64 %endif
65 %ifarch ppc ppc64
66         --enable-targets=spu \
67 %endif
68 %ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh arm
69         --enable-64-bit-bfd \
70 %endif
71         --disable-shared \
72         --disable-nls \
73         --disable-werror \
74         --prefix=%{_prefix} \
75         --libdir=%{_libdir} \
76         --mandir=%{_mandir} \
77         --infodir=%{_infodir} \
78         --enable-plugins
79
80 %{__make} all \
81         tooldir=%{_prefix} \
82         EXEEXT=""
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_prefix}
87
88 %{__make} install \
89         prefix=$RPM_BUILD_ROOT%{_prefix} \
90         mandir=$RPM_BUILD_ROOT%{_mandir} \
91         infodir=$RPM_BUILD_ROOT%{_infodir} \
92         libdir=$RPM_BUILD_ROOT%{_libdir}
93
94 # fix copies to be hardlinks (maybe should symlink in the future)
95 findup -m $RPM_BUILD_ROOT
96
97 # remove these man pages unless we cross-build for win*/netware platforms.
98 # however, this should be done in Makefiles.
99 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
100
101 # don't want this here
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
103
104 # packaged in base binutils
105 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc README
113 %attr(755,root,root) %{_bindir}/%{target}-*
114 %dir %{arch}
115 %dir %{arch}/bin
116 %attr(755,root,root) %{arch}/bin/*
117 %dir %{arch}/lib
118 %dir %{arch}/lib/*
119 %{arch}/lib/ldscripts/*
120 %{_mandir}/man?/%{target}-*
This page took 0.102452 seconds and 3 git commands to generate.