]> git.pld-linux.org Git - packages/crossmingw32-runtime.git/blob - crossmingw32-runtime.spec
- cosmetics
[packages/crossmingw32-runtime.git] / crossmingw32-runtime.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - runtime libraries
2 Summary(pl):    Zestaw narzêdzi mingw32 - biblioteki uruchomieniowe
3 Name:           crossmingw32-runtime
4 Version:        3.5
5 #%%define       run_date        20010604
6 #%%define       runsrc          mingw-runtime-%{version}-%{run_date}
7 %define runver  %{version}
8 %define runsrc  mingw-runtime-%{runver}
9 Release:        1
10 Epoch:          1
11 License:        Free
12 Group:          Development/Libraries
13 Source0:        http://dl.sourceforge.net/mingw/%{runsrc}-src.tar.gz
14 # Source0-md5:  cfa1e37c0e6e3243f82044687c859caa
15 Patch0:         %{name}-stdinc.patch
16 Patch1:         %{name}-configure.patch
17 URL:            http://www.mingw.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  crossmingw32-binutils
21 BuildRequires:  crossmingw32-gcc
22 BuildRequires:  crossmingw32-w32api
23 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
24 Requires:       crossmingw32-w32api >= 3.1
25 Obsoletes:      crossmingw32-platform
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30 %define         _prefix                 /usr/%{target}
31 %define         _libdir                 %{_prefix}/lib
32
33 # strip fails on static COFF files
34 %define         no_install_post_strip 1
35
36 %description
37 crossmingw32 is a complete cross-compiling development system for
38 building stand-alone Microsoft Windows applications under Linux using
39 the Mingw32 build libraries. This includes a binutils, gcc with g++
40 and objc, and libstdc++, all cross targeted to i386-mingw32, along
41 with supporting Win32 libraries in 'coff' format from free sources.
42
43 This package contains MinGW32 runtime includes and libraries.
44
45 %description -l pl
46 crossmingw32 jest kompletnym systemem do kompilacji skro¶nej,
47 pozwalaj±cym budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c
48 bibliotek mingw32. System sk³ada siê z binutils, gcc z g++ i objc,
49 libstdc++ - wszystkie generuj±ce kod dla platformy i386-mingw32, oraz
50 z bibliotek w formacie COFF.
51
52 Ten pakiet zawiera pliki nag³ówkowe i biblioteki uruchomieniowe
53 MinGW32.
54
55 %prep
56 %setup -q -n %{runsrc}
57 %patch0 -p1 
58 %patch1 -p1
59
60 %build
61 cp /usr/share/automake/config.sub .
62 %{__autoconf}
63 cd mingwex
64 cp /usr/share/automake/config.sub .
65 %{__autoconf}
66 cd ../profile
67 cp /usr/share/automake/config.sub .
68 %{__autoconf}
69 cd ..
70 ./configure \
71         --prefix=%{_prefix} \
72         --host=%{target} \
73         --build=%{_target_platform}
74 %{__make} -C mingwex
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         prefix=$RPM_BUILD_ROOT%{_prefix}
82
83 %if %{!?debug:1}0
84 %{target}-strip $RPM_BUILD_ROOT%{_bindir}/*.dll
85 %{target}-strip -g $RPM_BUILD_ROOT%{_libdir}/*.a
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CONTRIBUTORS ChangeLog DISCLAIMER README TODO readme.txt
94 %{_bindir}/*
95 %{_includedir}/*
96 %{_libdir}/*
This page took 0.055932 seconds and 3 git commands to generate.