]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
6036a7450caa143de0a1102ca6df717b91240d2a
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.48.4
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        https://download.gnome.org/sources/pango/1.48/%{realname}-%{version}.tar.xz
10 # Source0-md5:  6c3cee28fc36118c1c8733160054c7ed
11 URL:            https://pango.gnome.org/
12 # cairo-ft cairo-pdf cairo-png cairo-ps cairo-win32
13 BuildRequires:  crossmingw32-cairo >= 1.12.10
14 BuildRequires:  crossmingw32-fontconfig >= 2.12.92
15 BuildRequires:  crossmingw32-freetype >= 2.1.7
16 BuildRequires:  crossmingw32-fribidi >= 0.19.7
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  crossmingw32-glib2 >= 2.62.0
19 BuildRequires:  crossmingw32-harfbuzz >= 2.6.0
20 BuildRequires:  crossmingw32-w32api >= 5.0.2-6
21 # glib-genmarshal, glib-mkenums
22 BuildRequires:  glib2-devel >= 1:2.62.0
23 BuildRequires:  meson >= 0.55.3
24 BuildRequires:  ninja >= 1.5
25 BuildRequires:  perl-base
26 BuildRequires:  pkgconfig >= 1:0.15
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       crossmingw32-cairo >= 1.12.10
31 Requires:       crossmingw32-fontconfig >= 2.12.92
32 Requires:       crossmingw32-freetype >= 2.1.7
33 Requires:       crossmingw32-fribidi >= 0.19.7
34 Requires:       crossmingw32-glib2 >= 2.62.0
35 Requires:       crossmingw32-harfbuzz >= 2.6.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         no_install_post_strip   1
39 %define         _enable_debug_packages  0
40
41 %define         target                  i386-mingw32
42 %define         target_platform         i386-pc-mingw32
43
44 %define         _sysprefix              /usr
45 %define         _prefix                 %{_sysprefix}/%{target}
46 %define         _libdir                 %{_prefix}/lib
47 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
48 %define         _dlldir                 /usr/share/wine/windows/system
49 %define         __pkgconfig_provides    %{nil}
50 %define         __pkgconfig_requires    %{nil}
51 # for meson 0.50+, keep __cc/__cxx as host compiler and pass %{target}-* in meson-cross.txt
52
53 %define         _ssp_cflags             %{nil}
54 %ifnarch %{ix86}
55 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
56 %define         optflags        -O2
57 %endif
58 # -z options are invalid for mingw linker, most of -f options are Linux-specific
59 %define         filterout_ld    -Wl,-z,.*
60 %define         filterout_c     -f[-a-z0-9=]*
61
62 %description
63 System for layout and rendering of internationalized text (cross
64 MinGW32 version).
65
66 %description -l pl.UTF-8
67 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
68 MinGW32).
69
70 %package static
71 Summary:        Static Pango libraries (cross MinGW32 version)
72 Summary(pl.UTF-8):      Statyczne biblioteki Pango (wersja skrośna MinGW32)
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description static
77 Static Pango libraries (cross MinGW32 version).
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki Pango (wersja skrośna MinGW32).
81
82 %package dll
83 Summary:        DLL pango libraries for Windows
84 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
85 Group:          Applications/Emulators
86 Requires:       crossmingw32-cairo-dll >= 1.12.10
87 Requires:       crossmingw32-fontconfig-dll >= 2.12.92
88 Requires:       crossmingw32-freetype-dll >= 2.1.7
89 Requires:       crossmingw32-fribidi-dll >= 0.19.7
90 Requires:       crossmingw32-glib2-dll >= 2.62.0
91 Requires:       crossmingw32-harfbuzz-dll >= 2.6.0
92 Requires:       wine
93
94 %description dll
95 DLL pango libraries for Windows.
96
97 %description dll -l pl.UTF-8
98 Biblioteki DLL pango dla Windows.
99
100 %prep
101 %setup -q -n %{realname}-%{version}
102
103 # disable unused gi-docgen subproject
104 %{__sed} -i -e '/fallback:.*gi-docgen/d' meson.build
105
106 cat > meson-cross.txt <<'EOF'
107 [host_machine]
108 system = 'windows'
109 cpu_family = 'x86'
110 cpu = 'i386'
111 endian='little'
112 [binaries]
113 c = '%{target}-gcc'
114 cpp = '%{target}-g++'
115 ar = '%{target}-ar'
116 windres = '%{target}-windres'
117 pkgconfig = 'pkg-config'
118 [properties]
119 c_args = ['%(echo %{rpmcflags} | sed -e "s/ \+/ /g;s/ /', '/g")', '-DWINVER=0x0600']
120 EOF
121
122 %build
123 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
124 %meson build \
125         --cross-file meson-cross.txt \
126         %{?debug:--debug} \
127         -Dgtk_doc=false \
128         -Dintrospection=disabled
129
130 %ninja_build -C build
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %ninja_install -C build
136
137 install -d $RPM_BUILD_ROOT%{_dlldir}
138 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
139
140 %if 0%{!?debug:1}
141 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
142 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
143 %endif
144
145 %{__rm} $RPM_BUILD_ROOT%{_bindir}/pango-{list,view}.exe
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %doc NEWS README.md README.win32 THANKS
153 %{_libdir}/libpango-1.0.dll.a
154 %{_libdir}/libpangocairo-1.0.dll.a
155 %{_libdir}/libpangoft2-1.0.dll.a
156 %{_libdir}/libpangowin32-1.0.dll.a
157 %{_includedir}/pango-1.0
158 %{_pkgconfigdir}/pango.pc
159 %{_pkgconfigdir}/pangocairo.pc
160 %{_pkgconfigdir}/pangofc.pc
161 %{_pkgconfigdir}/pangoft2.pc
162 %{_pkgconfigdir}/pangoot.pc
163 %{_pkgconfigdir}/pangowin32.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libpango-1.0.a
168 %{_libdir}/libpangocairo-1.0.a
169 %{_libdir}/libpangoft2-1.0.a
170 %{_libdir}/libpangowin32-1.0.a
171
172 %files dll
173 %defattr(644,root,root,755)
174 %{_dlldir}/libpango-1.0-0.dll
175 %{_dlldir}/libpangocairo-1.0-0.dll
176 %{_dlldir}/libpangoft2-1.0-0.dll
177 %{_dlldir}/libpangowin32-1.0-0.dll
This page took 0.111345 seconds and 2 git commands to generate.