]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.24.14; plain WINNT 4 API is no longer sufficient
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - MinGW32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla MinGW32
3 Name:           crossmingw32-gtk+2
4 Version:        2.24.14
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.24/gtk+-%{version}.tar.xz
9 # Source0-md5:  e2c16f119ed624893ecfc3775930ae4c
10 URL:            http://www.gtk.org/
11 BuildRequires:  autoconf >= 2.62
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  crossmingw32-atk >= 1.30.0
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-gdk-pixbuf2 >= 2.22.0
16 BuildRequires:  crossmingw32-glib2 >= 2.28.0
17 BuildRequires:  crossmingw32-pango >= 1.28.0
18 BuildRequires:  gtk-doc >= 1.17
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-atk >= 1.30.0
24 Requires:       crossmingw32-gdk-pixbuf2 >= 2.22.0
25 Requires:       crossmingw32-glib2 >= 2.28.0
26 Requires:       crossmingw32-pango >= 1.28.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         abivers 2.10.0
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43
44 %ifnarch %{ix86}
45 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46 %define         optflags        -O2
47 %endif
48 # -z options are invalid for mingw linker, most of -f options are Linux-specific
49 %define         filterout_ld    -Wl,-z,.*
50 %define         filterout_c     -f[-a-z0-9=]*
51
52 %description
53 GTK+, which stands for the GIMP ToolKit, is a library for creating
54 graphical user interfaces for the X Window System. It is designed to
55 be small, efficient, and flexible. GTK+ is written in C with a very
56 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
57 which provides a thin layer over Xlib to help automate things like
58 dealing with different color depths, and GTK is a widget set for
59 creating user interfaces.
60
61 This package contains the cross version for Win32.
62
63 %description -l pl.UTF-8
64 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
65 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
66 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
67 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
68 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
69 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
70 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
71 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
72
73 Ten pakiet zawiera wersję skrośną dla Win32.
74
75 %package dll
76 Summary:        DLL GTK+ libraries for Windows
77 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-atk-dll >= 1.30.0
80 Requires:       crossmingw32-gdk-pixbuf2-dll >= 2.22.0
81 Requires:       crossmingw32-glib2-dll >= 2.28.0
82 Requires:       crossmingw32-pango-dll >= 1.28.0
83 Requires:       wine
84
85 %description dll
86 DLL GTK+ libraries for Windows.
87
88 %description dll -l pl.UTF-8
89 Biblioteki DLL GTK+ dla Windows.
90
91 %prep
92 %setup -q -n gtk+-%{version}
93
94 %build
95 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
96 %{__gtkdocize}
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 # starting with 2.24.14 gtk+ uses Windows 5.0 features
103 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0500"
104 %configure \
105         --target=%{target} \
106         --host=%{target} \
107         --disable-cups \
108         --disable-gtk-doc \
109         --disable-man \
110         --disable-xkb \
111         --with-gdktarget=win32 \
112         --without-x \
113         --without-xinput
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 # .def installation is not parallel-compliant
121 %{__make} -j1 install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT%{_dlldir}
125 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
126
127 %if 0%{!?debug:1}
128 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
129 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
130 %endif
131
132 # remove unsupported locale scheme
133 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,man,themes}
134 # shut up check-files (static modules and *.la for modules)
135 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
136 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %{_libdir}/libgailutil.dll.a
144 %{_libdir}/libgdk-win32-2.0.dll.a
145 %{_libdir}/libgtk-win32-2.0.dll.a
146 %{_libdir}/libgailutil.la
147 %{_libdir}/libgdk-win32-2.0.la
148 %{_libdir}/libgtk-win32-2.0.la
149 %{_libdir}/gailutil.def
150 %{_libdir}/gdk-win32-2.0.def
151 %{_libdir}/gtk-win32-2.0.def
152 %dir %{_libdir}/gtk-2.0
153 %{_libdir}/gtk-2.0/include
154 %{_includedir}/gail-1.0
155 %{_includedir}/gtk-2.0
156 %{_pkgconfigdir}/gail.pc
157 %{_pkgconfigdir}/gdk-2.0.pc
158 %{_pkgconfigdir}/gdk-win32-2.0.pc
159 %{_pkgconfigdir}/gtk+-2.0.pc
160 %{_pkgconfigdir}/gtk+-win32-2.0.pc
161
162 %files dll
163 %defattr(644,root,root,755)
164 %{_dlldir}/libgailutil-*.dll
165 %{_dlldir}/libgdk-win32-2.0-*.dll
166 %{_dlldir}/libgtk-win32-2.0-*.dll
167 %dir %{_libdir}/gtk-2.0
168 %dir %{_libdir}/gtk-2.0/2.10.0
169 %dir %{_libdir}/gtk-2.0/2.10.0/engines
170 %{_libdir}/gtk-2.0/2.10.0/engines/libpixmap.dll
171 %{_libdir}/gtk-2.0/2.10.0/engines/libwimp.dll
172 %dir %{_libdir}/gtk-2.0/2.10.0/immodules
173 %{_libdir}/gtk-2.0/2.10.0/immodules/im-*.dll
174 %dir %{_libdir}/gtk-2.0/modules
175 %{_libdir}/gtk-2.0/modules/libgail.dll
This page took 0.05148 seconds and 4 git commands to generate.