]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.18.9
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - Ming32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla Ming32
3 Name:           crossmingw32-gtk+2
4 Version:        2.18.9
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.18/gtk+-%{version}.tar.bz2
9 # Source0-md5:  f680d38c973635365acababacb1730ec
10 URL:            http://www.gtk.org/
11 BuildRequires:  crossmingw32-atk >= 1.26.0
12 BuildRequires:  crossmingw32-gcc
13 BuildRequires:  crossmingw32-glib2 >= 2.22.0
14 BuildRequires:  crossmingw32-jasper
15 BuildRequires:  crossmingw32-libpng
16 BuildRequires:  crossmingw32-pango >= 1.24.0
17 BuildRequires:  gtk-doc >= 1.11
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  sed >= 4.0
20 Requires:       crossmingw32-atk >= 1.26.0
21 Requires:       crossmingw32-glib2 >= 2.22.0
22 Requires:       crossmingw32-pango >= 1.24.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         abivers 2.10.0
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 #define         filterout_ld            (-Wl,)?-as-needed.*
41
42 %ifnarch %{ix86}
43 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
44 %define         optflags        -O2
45 %endif
46 # -z options are invalid for mingw linker
47 %define         filterout_ld    -Wl,-z,.*
48
49 %description
50 GTK+, which stands for the GIMP ToolKit, is a library for creating
51 graphical user interfaces for the X Window System. It is designed to
52 be small, efficient, and flexible. GTK+ is written in C with a very
53 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
54 which provides a thin layer over Xlib to help automate things like
55 dealing with different color depths, and GTK is a widget set for
56 creating user interfaces.
57
58 This package contains the cross version for Win32.
59
60 %description -l pl.UTF-8
61 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
62 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
63 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
64 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
65 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
66 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
67 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
68 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
69
70 Ten pakiet zawiera wersję skrośną dla Win32.
71
72 %package dll
73 Summary:        DLL GTK+ libraries for Windows
74 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
75 Group:          Applications/Emulators
76 Requires:       crossmingw32-atk-dll >= 1.26.0
77 Requires:       crossmingw32-glib2-dll >= 2.22.0
78 Requires:       crossmingw32-pango-dll >= 1.24.0
79 Requires:       wine
80
81 %description dll
82 DLL GTK+ libraries for Windows.
83
84 %description dll -l pl.UTF-8
85 Biblioteki DLL GTK+ dla Windows.
86
87 %prep
88 %setup -q -n gtk+-%{version}
89
90 sed -i -e 's#libpng12#libpng#g' configure.in
91
92 %build
93 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
94 %{__gtkdocize}
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoheader}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         ac_cv_path_CUPS_CONFIG=no \
102         --target=%{target} \
103         --host=%{target} \
104         --disable-gtk-doc \
105         --disable-man \
106         --disable-xkb \
107         --with-gdktarget=win32 \
108         --with-libjasper \
109         --without-x \
110         --without-xinput
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install -d $RPM_BUILD_ROOT%{_dlldir}
121 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
122
123 %if 0%{!?debug:1}
124 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
125 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
126 %endif
127
128 # remove unsupported locale scheme
129 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,man,themes}
130 # shut up check-files (static modules and *.la for modules)
131 rm -rf $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
132 rm -rf $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %{_libdir}/libgailutil.dll.a
140 %{_libdir}/libgdk-win32-2.0.dll.a
141 %{_libdir}/libgdk_pixbuf-2.0.dll.a
142 %{_libdir}/libgtk-win32-2.0.dll.a
143 %{_libdir}/libgailutil.la
144 %{_libdir}/libgdk-win32-2.0.la
145 %{_libdir}/libgdk_pixbuf-2.0.la
146 %{_libdir}/libgtk-win32-2.0.la
147 %{_libdir}/gdk-win32-2.0.def
148 %{_libdir}/gdk_pixbuf-2.0.def
149 %{_libdir}/gtk-win32-2.0.def
150 %dir %{_libdir}/gtk-2.0
151 %{_libdir}/gtk-2.0/include
152 %{_includedir}/gail-1.0
153 %{_includedir}/gtk-2.0
154 %{_includedir}/gtk-unix-print-2.0
155 %{_pkgconfigdir}/gail.pc
156 %{_pkgconfigdir}/gdk-2.0.pc
157 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
158 %{_pkgconfigdir}/gdk-win32-2.0.pc
159 %{_pkgconfigdir}/gtk+-2.0.pc
160 %{_pkgconfigdir}/gtk+-win32-2.0.pc
161
162 %files dll
163 %defattr(644,root,root,755)
164 %{_dlldir}/libgailutil-*.dll
165 %{_dlldir}/libgdk-win32-2.0-*.dll
166 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
167 %{_dlldir}/libgtk-win32-2.0-*.dll
This page took 0.095663 seconds and 4 git commands to generate.