]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.24.23
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - MinGW32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla MinGW32
3 Name:           crossmingw32-gtk+2
4 Version:        2.24.23
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.24/gtk+-%{version}.tar.xz
9 # Source0-md5:  0be39fbed4ca125645175cd6e22f2548
10 Patch0:         gtk+2-format.patch
11 URL:            http://www.gtk.org/
12 BuildRequires:  autoconf >= 2.62
13 BuildRequires:  automake >= 1:1.7
14 BuildRequires:  crossmingw32-atk >= 1.30.0
15 BuildRequires:  crossmingw32-cairo >= 1.6
16 BuildRequires:  crossmingw32-gcc
17 BuildRequires:  crossmingw32-gdk-pixbuf2 >= 2.22.0
18 BuildRequires:  crossmingw32-glib2 >= 2.28.0
19 BuildRequires:  crossmingw32-pango >= 1.28.0
20 BuildRequires:  gtk-doc >= 1.17
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig >= 1:0.15
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       crossmingw32-atk >= 1.30.0
26 Requires:       crossmingw32-cairo >= 1.6
27 Requires:       crossmingw32-gdk-pixbuf2 >= 2.22.0
28 Requires:       crossmingw32-glib2 >= 2.28.0
29 Requires:       crossmingw32-pango >= 1.28.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         abivers 2.10.0
33
34 %define         no_install_post_strip   1
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46 %define         __pkgconfig_provides    %{nil}
47 %define         __pkgconfig_requires    %{nil}
48
49 %define         _ssp_cflags             %{nil}
50 %ifnarch %{ix86}
51 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
52 %define         optflags        -O2
53 %endif
54 # -z options are invalid for mingw linker, most of -f options are Linux-specific
55 %define         filterout_ld    -Wl,-z,.*
56 %define         filterout_c     -f[-a-z0-9=]*
57
58 %description
59 GTK+, which stands for the GIMP ToolKit, is a library for creating
60 graphical user interfaces for the X Window System. It is designed to
61 be small, efficient, and flexible. GTK+ is written in C with a very
62 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
63 which provides a thin layer over Xlib to help automate things like
64 dealing with different color depths, and GTK is a widget set for
65 creating user interfaces.
66
67 This package contains the cross version for Win32.
68
69 %description -l pl.UTF-8
70 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
71 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
72 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
73 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
74 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
75 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
76 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
77 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
78
79 Ten pakiet zawiera wersję skrośną dla Win32.
80
81 %package dll
82 Summary:        DLL GTK+ libraries for Windows
83 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
84 Group:          Applications/Emulators
85 Requires:       crossmingw32-atk-dll >= 1.30.0
86 Requires:       crossmingw32-cairo-dll >= 1.6
87 Requires:       crossmingw32-gdk-pixbuf2-dll >= 2.22.0
88 Requires:       crossmingw32-glib2-dll >= 2.28.0
89 Requires:       crossmingw32-pango-dll >= 1.28.0
90 Requires:       wine
91
92 %description dll
93 DLL GTK+ libraries for Windows.
94
95 %description dll -l pl.UTF-8
96 Biblioteki DLL GTK+ dla Windows.
97
98 %prep
99 %setup -q -n gtk+-%{version}
100 %patch0 -p1
101
102 %build
103 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 # starting with 2.24.14 gtk+ uses Windows 5.0 features
110 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0500"
111 %configure \
112         --target=%{target} \
113         --host=%{target} \
114         --disable-cups \
115         --disable-gtk-doc \
116         --disable-man \
117         --disable-xkb \
118         --with-gdktarget=win32 \
119         --without-x \
120         --without-xinput
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 # .def installation is not parallel-compliant
128 %{__make} -j1 install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install -d $RPM_BUILD_ROOT%{_dlldir}
132 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
133
134 %if 0%{!?debug:1}
135 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
136 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
137 %endif
138
139 # remove unsupported locale scheme
140 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,themes}
141 # shut up check-files (static modules and *.la for modules)
142 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
143 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %{_libdir}/libgailutil.dll.a
151 %{_libdir}/libgdk-win32-2.0.dll.a
152 %{_libdir}/libgtk-win32-2.0.dll.a
153 %{_libdir}/libgailutil.la
154 %{_libdir}/libgdk-win32-2.0.la
155 %{_libdir}/libgtk-win32-2.0.la
156 %{_libdir}/gailutil.def
157 %{_libdir}/gdk-win32-2.0.def
158 %{_libdir}/gtk-win32-2.0.def
159 %dir %{_libdir}/gtk-2.0
160 %{_libdir}/gtk-2.0/include
161 %{_includedir}/gail-1.0
162 %{_includedir}/gtk-2.0
163 %{_pkgconfigdir}/gail.pc
164 %{_pkgconfigdir}/gdk-2.0.pc
165 %{_pkgconfigdir}/gdk-win32-2.0.pc
166 %{_pkgconfigdir}/gtk+-2.0.pc
167 %{_pkgconfigdir}/gtk+-win32-2.0.pc
168
169 %files dll
170 %defattr(644,root,root,755)
171 %{_dlldir}/libgailutil-*.dll
172 %{_dlldir}/libgdk-win32-2.0-*.dll
173 %{_dlldir}/libgtk-win32-2.0-*.dll
174 %dir %{_libdir}/gtk-2.0
175 %dir %{_libdir}/gtk-2.0/2.10.0
176 %dir %{_libdir}/gtk-2.0/2.10.0/engines
177 %{_libdir}/gtk-2.0/2.10.0/engines/libpixmap.dll
178 %{_libdir}/gtk-2.0/2.10.0/engines/libwimp.dll
179 %dir %{_libdir}/gtk-2.0/2.10.0/immodules
180 %{_libdir}/gtk-2.0/2.10.0/immodules/im-*.dll
181 %dir %{_libdir}/gtk-2.0/modules
182 %{_libdir}/gtk-2.0/modules/libgail.dll
This page took 0.114091 seconds and 4 git commands to generate.