]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.16.0
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - Ming32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla Ming32
3 Name:           crossmingw32-gtk+2
4 Version:        2.16.0
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.16/gtk+-%{version}.tar.bz2
9 # Source0-md5:  139528802794287427fd4d18875b5cf5
10 URL:            http://www.gtk.org/
11 BuildRequires:  crossmingw32-atk >= 1.26.0
12 BuildRequires:  crossmingw32-gcc
13 BuildRequires:  crossmingw32-glib2 >= 2.20.0
14 BuildRequires:  crossmingw32-jasper
15 BuildRequires:  crossmingw32-libpng
16 BuildRequires:  crossmingw32-pango >= 1.24.0
17 BuildRequires:  pkgconfig >= 1:0.15
18 Requires:       crossmingw32-atk >= 1.26.0
19 Requires:       crossmingw32-glib2 >= 2.20.0
20 Requires:       crossmingw32-pango >= 1.24.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         abivers 2.10.0
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 #define         filterout_ld            (-Wl,)?-as-needed.*
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker
45 %define         filterout_ld    -Wl,-z,.*
46
47 %description
48 GTK+, which stands for the GIMP ToolKit, is a library for creating
49 graphical user interfaces for the X Window System. It is designed to
50 be small, efficient, and flexible. GTK+ is written in C with a very
51 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
52 which provides a thin layer over Xlib to help automate things like
53 dealing with different color depths, and GTK is a widget set for
54 creating user interfaces.
55
56 This package contains the cross version for Win32.
57
58 %description -l pl.UTF-8
59 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
60 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
61 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
62 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
63 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
64 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
65 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
66 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
67
68 Ten pakiet zawiera wersję skrośną dla Win32.
69
70 %package dll
71 Summary:        DLL GTK+ libraries for Windows
72 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
73 Group:          Applications/Emulators
74 Requires:       crossmingw32-atk-dll >= 1.26.0
75 Requires:       crossmingw32-glib2-dll >= 2.20.0
76 Requires:       crossmingw32-pango-dll >= 1.24.0
77 Requires:       wine
78
79 %description dll
80 DLL GTK+ libraries for Windows.
81
82 %description dll -l pl.UTF-8
83 Biblioteki DLL GTK+ dla Windows.
84
85 %prep
86 %setup -q -n gtk+-%{version}
87
88 %build
89 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoheader}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         ac_cv_path_CUPS_CONFIG=no \
97         --target=%{target} \
98         --host=%{target} \
99         --disable-gtk-doc \
100         --disable-man \
101         --disable-xkb \
102         --with-gdktarget=win32 \
103         --without-x \
104         --without-xinput
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT%{_dlldir}
115 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
116
117 %if 0%{!?debug:1}
118 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
119 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
120 %endif
121
122 # remove unsupported locale scheme
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,man,themes}
124 # shut up check-files (static modules and *.la for modules)
125 rm -rf $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
126 rm -rf $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %{_libdir}/libgailutil.dll.a
134 %{_libdir}/libgdk-win32-2.0.dll.a
135 %{_libdir}/libgdk_pixbuf-2.0.dll.a
136 %{_libdir}/libgtk-win32-2.0.dll.a
137 %{_libdir}/libgailutil.la
138 %{_libdir}/libgdk-win32-2.0.la
139 %{_libdir}/libgdk_pixbuf-2.0.la
140 %{_libdir}/libgtk-win32-2.0.la
141 %{_libdir}/gdk-win32-2.0.def
142 %{_libdir}/gdk_pixbuf-2.0.def
143 %{_libdir}/gtk-win32-2.0.def
144 %dir %{_libdir}/gtk-2.0
145 %{_libdir}/gtk-2.0/include
146 %{_includedir}/gail-1.0
147 %{_includedir}/gtk-2.0
148 %{_includedir}/gtk-unix-print-2.0
149 %{_pkgconfigdir}/gail.pc
150 %{_pkgconfigdir}/gdk-2.0.pc
151 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
152 %{_pkgconfigdir}/gdk-win32-2.0.pc
153 %{_pkgconfigdir}/gtk+-2.0.pc
154 %{_pkgconfigdir}/gtk+-win32-2.0.pc
155
156 %files dll
157 %defattr(644,root,root,755)
158 %{_dlldir}/libgailutil-*.dll
159 %{_dlldir}/libgdk-win32-2.0-*.dll
160 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
161 %{_dlldir}/libgtk-win32-2.0-*.dll
This page took 0.046666 seconds and 4 git commands to generate.