]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- fixed typo in -dll dependency
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - MinGW32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla MinGW32
3 Name:           crossmingw32-gtk+2
4 Version:        2.24.4
5 Release:        2
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.24/gtk+-%{version}.tar.bz2
9 # Source0-md5:  e05a700ba79c8813d56e83e80636ee21
10 URL:            http://www.gtk.org/
11 BuildRequires:  autoconf >= 2.62
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  crossmingw32-atk >= 1.30.0
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-gdk-pixbuf2 >= 2.22.0
16 BuildRequires:  crossmingw32-glib2 >= 2.28.0
17 BuildRequires:  crossmingw32-pango >= 1.28.0
18 BuildRequires:  gtk-doc >= 1.17
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig >= 1:0.15
21 Requires:       crossmingw32-atk >= 1.30.0
22 Requires:       crossmingw32-gdk-pixbuf2 >= 2.22.0
23 Requires:       crossmingw32-glib2 >= 2.28.0
24 Requires:       crossmingw32-pango >= 1.28.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         abivers 2.10.0
28
29 %define         no_install_post_strip   1
30
31 %define         target                  i386-mingw32
32 %define         target_platform         i386-pc-mingw32
33
34 %define         _sysprefix              /usr
35 %define         _prefix                 %{_sysprefix}/%{target}
36 %define         _libdir                 %{_prefix}/lib
37 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
38 %define         _dlldir                 /usr/share/wine/windows/system
39 %define         __cc                    %{target}-gcc
40 %define         __cxx                   %{target}-g++
41
42 #define         filterout_ld            (-Wl,)?-as-needed.*
43
44 %ifnarch %{ix86}
45 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46 %define         optflags        -O2
47 %endif
48 # -z options are invalid for mingw linker
49 %define         filterout_ld    -Wl,-z,.*
50
51 %description
52 GTK+, which stands for the GIMP ToolKit, is a library for creating
53 graphical user interfaces for the X Window System. It is designed to
54 be small, efficient, and flexible. GTK+ is written in C with a very
55 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
56 which provides a thin layer over Xlib to help automate things like
57 dealing with different color depths, and GTK is a widget set for
58 creating user interfaces.
59
60 This package contains the cross version for Win32.
61
62 %description -l pl.UTF-8
63 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
64 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
65 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
66 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
67 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
68 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
69 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
70 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
71
72 Ten pakiet zawiera wersję skrośną dla Win32.
73
74 %package dll
75 Summary:        DLL GTK+ libraries for Windows
76 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
77 Group:          Applications/Emulators
78 Requires:       crossmingw32-atk-dll >= 1.30.0
79 Requires:       crossmingw32-gdk-pixbuf2-dll >= 2.22.0
80 Requires:       crossmingw32-glib2-dll >= 2.28.0
81 Requires:       crossmingw32-pango-dll >= 1.28.0
82 Requires:       wine
83
84 %description dll
85 DLL GTK+ libraries for Windows.
86
87 %description dll -l pl.UTF-8
88 Biblioteki DLL GTK+ dla Windows.
89
90 %prep
91 %setup -q -n gtk+-%{version}
92
93 %build
94 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
95 %{__gtkdocize}
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         ac_cv_path_CUPS_CONFIG=no \
103         --target=%{target} \
104         --host=%{target} \
105         --disable-gtk-doc \
106         --disable-man \
107         --disable-xkb \
108         --with-gdktarget=win32 \
109         --without-x \
110         --without-xinput
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 # .def installation is not parallel-compliant
118 %{__make} -j1 install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT%{_dlldir}
122 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
123
124 %if 0%{!?debug:1}
125 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
126 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
127 %endif
128
129 # remove unsupported locale scheme
130 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,man,themes}
131 # shut up check-files (static modules and *.la for modules)
132 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
133 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %{_libdir}/libgailutil.dll.a
141 %{_libdir}/libgdk-win32-2.0.dll.a
142 %{_libdir}/libgtk-win32-2.0.dll.a
143 %{_libdir}/libgailutil.la
144 %{_libdir}/libgdk-win32-2.0.la
145 %{_libdir}/libgtk-win32-2.0.la
146 %{_libdir}/gailutil.def
147 %{_libdir}/gdk-win32-2.0.def
148 %{_libdir}/gtk-win32-2.0.def
149 %dir %{_libdir}/gtk-2.0
150 %{_libdir}/gtk-2.0/include
151 %{_includedir}/gail-1.0
152 %{_includedir}/gtk-2.0
153 %{_includedir}/gtk-unix-print-2.0
154 %{_pkgconfigdir}/gail.pc
155 %{_pkgconfigdir}/gdk-2.0.pc
156 %{_pkgconfigdir}/gdk-win32-2.0.pc
157 %{_pkgconfigdir}/gtk+-2.0.pc
158 %{_pkgconfigdir}/gtk+-win32-2.0.pc
159
160 %files dll
161 %defattr(644,root,root,755)
162 %{_dlldir}/libgailutil-*.dll
163 %{_dlldir}/libgdk-win32-2.0-*.dll
164 %{_dlldir}/libgtk-win32-2.0-*.dll
165 %dir %{_libdir}/gtk-2.0
166 %dir %{_libdir}/gtk-2.0/2.10.0
167 %dir %{_libdir}/gtk-2.0/2.10.0/engines
168 %{_libdir}/gtk-2.0/2.10.0/engines/libpixmap.dll
169 %{_libdir}/gtk-2.0/2.10.0/engines/libwimp.dll
170 %dir %{_libdir}/gtk-2.0/2.10.0/immodules
171 %{_libdir}/gtk-2.0/2.10.0/immodules/im-*.dll
172 %dir %{_libdir}/gtk-2.0/modules
173 %{_libdir}/gtk-2.0/modules/libgail.dll
This page took 0.095893 seconds and 4 git commands to generate.