]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- unified macros order
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The Gimp Toolkit - Ming32 cross version
2 Summary(pl.UTF-8):      Gimp Toolkit - wersja skrośna dla Ming32
3 Name:           crossmingw32-gtk+2
4 Version:        2.12.5
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.12/gtk+-%{version}.tar.bz2
9 # Source0-md5:  588c7fb3d9ebadf4f5a1ab4c534e4db5
10 URL:            http://www.gtk.org/
11 BuildRequires:  crossmingw32-atk >= 1.20.0
12 BuildRequires:  crossmingw32-gcc
13 BuildRequires:  crossmingw32-glib2 >= 2.14.2
14 BuildRequires:  crossmingw32-libjpeg
15 BuildRequires:  crossmingw32-libpng
16 BuildRequires:  crossmingw32-libtiff
17 BuildRequires:  crossmingw32-pango >= 1.18.3
18 BuildRequires:  pkgconfig >= 1:0.15
19 Requires:       crossmingw32-atk >= 1.20.0
20 Requires:       crossmingw32-glib2 >= 2.14.2
21 Requires:       crossmingw32-pango >= 1.18.3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         abivers 2.10.0
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38
39 %define         filterout_ld            (-Wl,)?-as-needed.*
40
41 %description
42 GTK+, which stands for the Gimp ToolKit, is a library for creating
43 graphical user interfaces for the X Window System. It is designed to
44 be small, efficient, and flexible. GTK+ is written in C with a very
45 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
46 which provides a thin layer over Xlib to help automate things like
47 dealing with different color depths, and GTK is a widget set for
48 creating user interfaces.
49
50 This package contains the cross version for Win32.
51
52 %description -l pl.UTF-8
53 GTK+, która to biblioteka stała się podstawą programu Gimp, zawiera
54 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
55 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
56 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
57 (część GTK+) jest warstwą pośrednią pomiędzy Xlib i resztą toolkitu
58 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
59 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
60 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
61
62 Ten pakiet zawiera wersję skrośną dla Win32.
63
64 %package dll
65 Summary:        DLL GTK+ libraries for Windows
66 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
67 Group:          Applications/Emulators
68 Requires:       crossmingw32-atk-dll >= 1.20.0
69 Requires:       crossmingw32-glib2-dll >= 2.14.2
70 Requires:       crossmingw32-pango-dll >= 1.18.3
71 Requires:       wine
72
73 %description dll
74 DLL GTK+ libraries for Windows.
75
76 %description dll -l pl.UTF-8
77 Biblioteki DLL GTK+ dla Windows.
78
79 %prep
80 %setup -q -n gtk+-%{version}
81
82 %build
83 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoheader}
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         ac_cv_path_CUPS_CONFIG=no \
91         --target=%{target} \
92         --host=%{target} \
93         --disable-gtk-doc \
94         --disable-man \
95         --disable-xkb \
96         --with-gdk-target=win32 \
97         --without-x \
98         --without-xinput
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 %if 0%{!?debug:1}
112 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
113 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
114 %endif
115
116 # remove unsupported locale scheme
117 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,man,themes}
118 # shut up check-files (static modules and *.la for modules)
119 rm -rf $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %{_libdir}/libgdk-win32-2.0.dll.a
127 %{_libdir}/libgdk_pixbuf-2.0.dll.a
128 %{_libdir}/libgtk-win32-2.0.dll.a
129 %{_libdir}/libgdk-win32-2.0.la
130 %{_libdir}/libgdk_pixbuf-2.0.la
131 %{_libdir}/libgtk-win32-2.0.la
132 %{_libdir}/gdk-win32-2.0.def
133 %{_libdir}/gdk_pixbuf-2.0.def
134 %{_libdir}/gtk-win32-2.0.def
135 %dir %{_libdir}/gtk-2.0
136 %{_libdir}/gtk-2.0/include
137 %{_includedir}/gtk-2.0
138 %{_includedir}/gtk-unix-print-2.0
139 %{_pkgconfigdir}/gdk-2.0.pc
140 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
141 %{_pkgconfigdir}/gdk-win32-2.0.pc
142 %{_pkgconfigdir}/gtk+-2.0.pc
143 %{_pkgconfigdir}/gtk+-win32-2.0.pc
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libgdk-win32-2.0-*.dll
148 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
149 %{_dlldir}/libgtk-win32-2.0-*.dll
This page took 0.067291 seconds and 4 git commands to generate.