]> git.pld-linux.org Git - packages/crossmingw32-glib2.git/blob - crossmingw32-glib2.spec
- cleanup, separated -dll
[packages/crossmingw32-glib2.git] / crossmingw32-glib2.spec
1 Summary:        Useful routines for 'C' programming - Ming32 cross version
2 Summary(cs.UTF-8):      Šikovná knihovna s funkcemi pro pomocné programy
3 Summary(da.UTF-8):      Nyttige biblioteksfunktioner
4 Summary(de.UTF-8):      Eine nützliche Library von Dienstprogramm-Funktionen
5 Summary(es.UTF-8):      Conjunto de funciones gráficas utilitarias
6 Summary(fi.UTF-8):      Kirjasto, jossa on työkalufunktioita
7 Summary(fr.UTF-8):      Bibliothèque de fonctions utilitaires
8 Summary(ja.UTF-8):      便利なユーティリティ関数のライブラリ
9 Summary(pl.UTF-8):      Biblioteka zawierająca wiele użytecznych funkcji C - wersja skrośna dla Ming32
10 Summary(pt_BR.UTF-8):   Conjunto de funções gráficas utilitárias
11 Summary(tr.UTF-8):      Yararlı ufak yordamlar kitaplığı
12 Summary(zh_CN.UTF-8):   实用工具函数库
13 %define         _realname   glib
14 Name:           crossmingw32-%{_realname}2
15 Version:        2.12.9
16 Release:        1
17 License:        LGPL
18 Group:          Development/Libraries
19 Source0:        ftp://ftp.gtk.org/pub/glib/2.12/%{_realname}-%{version}.tar.bz2
20 # Source0-md5:  b3f6a2a318610af6398b3445f1a2d6c6
21 Patch0:         %{name}-stacktest.patch
22 URL:            http://www.gtk.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  crossmingw32-gcc
26 BuildRequires:  crossmingw32-gettext
27 BuildRequires:  crossmingw32-libiconv
28 BuildRequires:  libtool
29 Requires:       crossmingw32-gettext
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         no_install_post_strip   1
33
34 %define         target                  i386-mingw32
35 %define         host                    %{target}
36 %define         target_platform         %{target}
37 %define         arch                    %{_prefix}/%{target}
38 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
39 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
40
41 %define         _sysprefix              /usr
42 %define         _prefix                 %{_sysprefix}/%{target}
43 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
44 %define         _dlldir                 /usr/share/wine/windows/system
45 %define         __cc                    %{target}-gcc
46 %define         __cxx                   %{target}-g++
47
48 %description
49 GLib, is a library which includes support routines for C such as
50 lists, trees, hashes, memory allocation, and many other things. GLIB
51 includes also generally useful data structures used by GIMP and many
52 other.
53
54 This package contains the cross version for Win32.
55
56 %description -l cs.UTF-8
57 Šikovná knihovna s funkcemi pro pomocné programy. Vývojové knihovny a
58 hlavičky jsou v balíčku glib-devel.
59
60 %description -l da.UTF-8
61 Nyttigt bibliotek med forskellige funktioner. Udviklings- biblioteker
62 og headerfiler er i glib-devel pakken.
63
64 %description -l de.UTF-8
65 Eine nützliche Library von Dienstprogramm-Funktionen.
66 Entwicklungs-Libraries und Header befinden sich in glib-devel.
67
68 %description -l es.UTF-8
69 Conjunto de funciones utilitarias. Bibliotecas de desarrollo y
70 archivos de inclusión están en glib-devel.
71
72 %description -l fi.UTF-8
73 Kirjasto, jossa on työkalufunktioita. Kehitysversiot ja
74 header-tiedostot ovat glib-devel-paketissa.
75
76 %description -l ja.UTF-8
77 GLibはユーティリティ関数を集めた便利なライブラリです。このC言語用ライブラリは、
78 いくつかの問題を解決するよう設計されており、多くのプログラムから要求される使いやすい
79 関数を提供します。
80
81 GLibはGDK,
82 GTK+他多くのアプリケーションで利用される。このライブラリに依存するアプリケーション
83 等のためにこのglibパッケージをインストールしてください。
84
85 %description -l pl.UTF-8
86 Glib jest zestawem bibliotek zawierających funkcje do obsługi list i
87 drzew, funkcje mieszające, funkcje do alokacji pamięci i dużo innych
88 podstawowych funkcji i różnych struktur danych używanych przez program
89 GIMP i wiele innych.
90
91 Ten pakiet zawiera wersję skrośną dla Win32.
92
93 %description -l pt_BR.UTF-8
94 Conjunto de funções utilitárias. Bibliotecas de desenvolvimento e
95 arquivos de inclusão estão em glib-devel.
96
97 %description -l tr.UTF-8
98 Yararlı yordamlar kitaplığı. Geliştirme kitaplıkları ve başlık
99 dosyaları glib-devel paketinde yer almaktadır.
100
101 %package dll
102 Summary:        DLL glib2 libraries for Windows
103 Summary(pl.UTF-8):      Biblioteki DLL glib2 dla Windows
104 Group:          Applications/Emulators
105 Requires:       crossmingw32-gettext-dll
106 Requires:       wine
107
108 %description dll
109 DLL glib2 libraries for Windows.
110
111 %description dll -l pl.UTF-8
112 Biblioteki DLL glib2 dla Windows.
113
114 %prep
115 %setup -q -n %{_realname}-%{version}
116 %patch0 -p1
117
118 %build
119 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
120 %{__libtoolize}
121 %{__aclocal}
122 %{__automake}
123 %{__autoconf}
124 %configure \
125         --target=%{target} \
126         --host=%{target} \
127         --disable-gtk-doc \
128         --enable-shared
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 install -d $RPM_BUILD_ROOT%{_dlldir}
139 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
140
141 rm -f $RPM_BUILD_ROOT%{_libdir}/charset.alias
142 # use system glib2-devel instead
143 rm -rf $RPM_BUILD_ROOT%{_datadir}/{aclocal,glib-2.0,gtk-doc,man}
144 # runtime
145 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %{_libdir}/libglib-2.0.dll.a
153 %{_libdir}/libgmodule-2.0.dll.a
154 %{_libdir}/libgobject-2.0.dll.a
155 %{_libdir}/libgthread-2.0.dll.a
156 %{_libdir}/libglib-2.0.la
157 %{_libdir}/libgmodule-2.0.la
158 %{_libdir}/libgobject-2.0.la
159 %{_libdir}/libgthread-2.0.la
160 %{_libdir}/glib-2.0.def
161 %{_libdir}/gmodule-2.0.def
162 %{_libdir}/gobject-2.0.def
163 %{_libdir}/gthread-2.0.def
164 %{_includedir}/glib-2.0
165 %dir %{_libdir}/glib-2.0
166 %dir %{_libdir}/glib-2.0/include
167 %{_libdir}/glib-2.0/include/glibconfig.h
168 %{_pkgconfigdir}/*.pc
169
170 %files dll
171 %defattr(644,root,root,755)
172 %{_dlldir}/libglib-2.0-*.dll
173 %{_dlldir}/libgmodule-2.0-*.dll
174 %{_dlldir}/libgobject-2.0-*.dll
175 %{_dlldir}/libgthread-2.0-*.dll
This page took 0.065774 seconds and 3 git commands to generate.