]> git.pld-linux.org Git - packages/crossmingw32-gdk-pixbuf2.git/blob - crossmingw32-gdk-pixbuf2.spec
- updated to 2.30.0
[packages/crossmingw32-gdk-pixbuf2.git] / crossmingw32-gdk-pixbuf2.spec
1 #
2 # Conditional build:
3 %bcond_without  gdiplus # use libjpeg and libtiff instead of system GDIPLUS
4 #
5 Summary:        An image loading and scaling library - cross MinGW32 version
6 Summary(pl.UTF-8):      Biblioteka ładująca i skalująca obrazki - wersja skrośna MinGW32
7 Name:           crossmingw32-gdk-pixbuf2
8 Version:        2.30.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          Development/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/2.30/gdk-pixbuf-%{version}.tar.xz
13 # Source0-md5:  d1e32c91597f8f2fa6ead4201216dd05
14 Patch0:         gdk-pixbuf2-png-nodep.patch
15 Patch1:         gdk-pixbuf2-gdip.patch
16 Patch2:         gdk-pixbuf2-win32.patch
17 URL:            http://developer.gnome.org/gdk-pixbuf/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  crossmingw32-gcc
21 BuildRequires:  crossmingw32-glib2 >= 2.37.2
22 BuildRequires:  crossmingw32-jasper
23 BuildRequires:  crossmingw32-libpng
24 BuildRequires:  gettext-devel >= 0.17
25 BuildRequires:  gtk-doc >= 1.11
26 BuildRequires:  libtool >= 2:2.2.6
27 BuildRequires:  pkgconfig >= 1:0.15
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 %if %{without gdiplus}
31 BuildRequires:  crossmingw32-libjpeg
32 BuildRequires:  crossmingw32-libtiff
33 %endif
34 Requires:       crossmingw32-glib2 >= 2.37.2
35 Conflicts:      crossmingw32-gtk+2 < 2.22.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         abiver  2.10.0
39
40 %define         no_install_post_strip   1
41
42 %define         target                  i386-mingw32
43 %define         target_platform         i386-pc-mingw32
44
45 %define         _sysprefix              /usr
46 %define         _prefix                 %{_sysprefix}/%{target}
47 %define         _libdir                 %{_prefix}/lib
48 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
49 %define         _dlldir                 /usr/share/wine/windows/system
50 %define         __cc                    %{target}-gcc
51 %define         __cxx                   %{target}-g++
52 %define         __pkgconfig_provides    %{nil}
53 %define         __pkgconfig_requires    %{nil}
54
55 #define         filterout_ld            (-Wl,)?-as-needed.*
56
57 %ifnarch %{ix86}
58 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
59 %define         optflags        -O2
60 %endif
61 # -z options are invalid for mingw linker, most of -f options are Linux-specific
62 %define         filterout_ld    -Wl,-z,.*
63 %define         filterout_c     -f[-a-z0-9=]*
64
65 %description
66 gdk-pixbuf is an image loading and scaling library that can be
67 extended by loadable modules for new image formats.
68
69 This package contains the cross version for Win32.
70
71 %description -l pl.UTF-8
72 gdk-pixbuf to biblioteka ładująca i skalująca obrazki, której
73 funkcjonalność może być rozszerzana o obsługę nowych formatów poprzez
74 ładowane moduły.
75
76 Ten pakiet zawiera wersję skrośną dla Win32.
77
78 %package dll
79 Summary:        DLL gdk-pixbuf libraries for Windows
80 Summary(pl.UTF-8):      Biblioteki DLL gdk-pixbuf dla Windows
81 Group:          Applications/Emulators
82 Requires:       crossmingw32-glib2-dll >= 2.37.2
83 Requires:       wine
84 Conflicts:      crossmingw32-gtk+2-dll < 2.22.0
85
86 %description dll
87 DLL gdk-pixbuf libraries for Windows.
88
89 %description dll -l pl.UTF-8
90 Biblioteki DLL gdk-pixbuf dla Windows.
91
92 %prep
93 %setup -q -n gdk-pixbuf-%{version}
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97
98 %build
99 %{__gettextize}
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
106 %configure \
107         --target=%{target} \
108         --host=%{target} \
109         --disable-gtk-doc \
110         --disable-man \
111         --disable-silent-rules \
112         --with-libjasper \
113         %{!?with_gdiplus:--without-gdiplus}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install -d $RPM_BUILD_ROOT%{_dlldir}
124 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
125
126 %if 0%{!?debug:1}
127 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll \
128         $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.dll
129 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
130 %endif
131
132 # shut up check-files
133 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,locale,man}
134 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.{la,dll.a}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %{_libdir}/libgdk_pixbuf-2.0.dll.a
142 %{_libdir}/libgdk_pixbuf-2.0.la
143 %{_libdir}/gdk_pixbuf-2.0.def
144 %{_includedir}/gdk-pixbuf-2.0
145 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
146
147 %files dll
148 %defattr(644,root,root,755)
149 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
150 %dir %{_libdir}/gdk-pixbuf-2.0
151 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}
152 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders
153 %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/libpixbufloader-*.dll
This page took 0.070857 seconds and 3 git commands to generate.