]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blob - crossmingw32-freetype.spec
- cleanup, separated -static,-dll
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
1 #
2 # Conditional build:
3 %bcond_without  bytecode        # without TT bytecode interpreter
4 #                (patents pending in USA, Japan etc., but now it includes
5 #                 also patent-free hinting workaround)
6 %bcond_without  lcd             # disable filters reducing color fringes when
7 #                 subpixel rendering for LCD (only used with a new 2.3.0 API;
8 #                 patents pending)
9 #
10 %define         _realname   freetype
11 Summary:        TrueType font rasterizer - Mingw32 cross version
12 Summary(pl.UTF-8):Rasteryzer fontów TrueType - wersja skrośna dla Mingw32
13 Name:           crossmingw32-%{_realname}
14 Version:        2.3.1
15 Release:        1
16 License:        GPL or FTL
17 Group:          Development/Libraries
18 Source0:        http://savannah.nongnu.org/download/freetype/%{_realname}-%{version}.tar.bz2
19 # Source0-md5:  11e1186ca5520c5a284fa0a03f652035
20 URL:            http://www.freetype.org/
21 BuildRequires:  crossmingw32-zlib
22 BuildRequires:  python
23 Requires:       crossmingw32-zlib
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         specflags_ia32  -fomit-frame-pointer
27 # see <freetype/internal/ftserv.h>, the real horror
28 %define         specflags       -fno-strict-aliasing
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34 %define         arch                    %{_prefix}/%{target}
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _pkgconfigdir           %{_libdir}/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %description
44 The FreeType engine is a free and portable TrueType font rendering
45 engine. It has been developed to provide TrueType support to a great
46 variety of platforms and environments.
47
48 Note that FreeType is a *library*. It is not a font server for your
49 favorite platform, even though it was designed to be used in many of
50 them. Note also that it is *not* a complete text-rendering library.
51 Its purpose is simply to open and manage font files, as well as load,
52 hint and render individual glyphs efficiently. You can also see it as
53 a "TrueType driver" for a higher-level library, though rendering text
54 with it is extremely easy, as demo-ed by the test programs.
55
56 This package contains the cross version for Win32.
57
58 %description -l pl.UTF-8
59 FreeType jest biblioteką służącą do rasteryzacji fontów
60 TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
61 została ona zaprojektowana do używania także w takich serwerach.
62 Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
63 celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
64 wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
65 glifów. Może być także uważana za "sterownik TrueType" dla
66 bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
67 do rasteryzacji jest bardzo proste, co można zobaczyć w programach
68 demonstracyjnych.
69
70 Ten pakiet zawiera wersję skrośną dla Win32.
71
72 %package static
73 Summary:        Static freetype library (cross mingw32 version)
74 Summary(pl.UTF-8):      Statyczna biblioteka freetype (wersja skrośna mingw32)
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description static
79 Static freetype library (cross mingw32 version).
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka freetype (wersja skrośna mingw32).
83
84 %package dll
85 Summary:        DLL freetype library for Windows
86 Summary(pl.UTF-8):      Biblioteka DLL freetype dla Windows
87 Group:          Applications/Emulators
88 Requires:       crossmingw32-zlib-dll
89 Requires:       wine
90
91 %description dll
92 DLL freetype library for Windows.
93
94 %description dll -l pl.UTF-8
95 Biblioteka DLL freetype dla Windows.
96
97 %prep
98 %setup -q -n %{_realname}-%{version}
99
100 %build
101 CFLAGS="%{rpmcflags} \
102 %{?with_bytecode:-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER} \
103 %{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING}" \
104 %configure \
105         --target=%{target} \
106         --build=i686-pc-linux-gnu \
107         --host=%{target} \
108         --enable-shared
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install -d $RPM_BUILD_ROOT%{_dlldir}
119 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
120
121 %if 0%{!?debug:1}
122 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
123 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
124 %endif
125
126 rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,PATENTS,TODO,formats.txt,raster.txt}
134 %{_libdir}/libfreetype.dll.a
135 %{_libdir}/libfreetype.la
136 %{_includedir}/freetype2
137 %{_includedir}/*.h
138 %{_pkgconfigdir}/*.pc
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libfreetype.a
143
144 %files dll
145 %defattr(644,root,root,755)
146 %{_dlldir}/libfreetype-*.dll
This page took 0.072685 seconds and 4 git commands to generate.