]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
- updated to 2.23.51.0.6
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.23.51.0.6
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.xz
13 # Source0-md5:  df3630fe49739312806c1d1c3e6ed17f
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gettext-devel
20 BuildRequires:  perl-tools-pod
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  texinfo >= 4.2
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         target          i386-mingw32
27 %define         arch            %{_prefix}/%{target}
28
29 %description
30 crossmingw32 is a complete cross-compiling development system for
31 building stand-alone Microsoft Windows applications under Linux using
32 the MinGW32 build libraries. This includes a binutils, gcc with g++
33 and objc, and libstdc++, all cross targeted to i386-mingw32, along
34 with supporting Win32 libraries in 'coff' format from free sources.
35
36 This package contains cross targeted binutils.
37
38 %description -l pl.UTF-8
39 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
40 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
41 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
42 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
43 COFF.
44
45 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
46
47 %prep
48 %setup -q -n binutils-%{version}
49
50 %build
51 cp /usr/share/automake/config.sub .
52
53 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
54 # lib<target>bfd.so*. To prevent confusion with native binutils, we
55 # forget about shared libraries right now, and do not install libbfd.a
56 # [the same applies to binutils 2.10.1.0.4]
57
58 # ldscripts won't be generated properly if SHELL is not bash...
59 CFLAGS="%{rpmcflags}" \
60 LDFLAGS="%{rpmldflags}" \
61 CONFIG_SHELL="/bin/bash" \
62 ./configure \
63         --disable-nls \
64         --disable-shared \
65         --prefix=%{_prefix} \
66         --libdir=%{_libdir} \
67         --mandir=%{_mandir} \
68         --infodir=%{_infodir} \
69         --host=%{_target_platform} \
70         --build=%{_target_platform} \
71         --target=%{target}
72
73 %{__make} all \
74         tooldir=%{_prefix}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         INSTALL='$$s/install-sh -c' \
81         prefix=$RPM_BUILD_ROOT%{_prefix} \
82         mandir=$RPM_BUILD_ROOT%{_mandir} \
83         infodir=$RPM_BUILD_ROOT%{_infodir} \
84         libdir=$RPM_BUILD_ROOT%{_libdir}
85
86 # remove this man page unless we cross-build for netware platform.
87 # however, this should be done in Makefiles.
88 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
89
90 # libiberty.a is ELF not PE
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
92
93 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
94 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README
102 # mingw32 directory tree
103 %dir %{arch}
104 %dir %{arch}/lib
105 %dir %{arch}/lib/pkgconfig
106 %dir %{arch}/bin
107 # binutils files
108 %attr(755,root,root) %{arch}/bin/ar
109 %attr(755,root,root) %{arch}/bin/as
110 %attr(755,root,root) %{arch}/bin/dlltool
111 %attr(755,root,root) %{arch}/bin/ld
112 %attr(755,root,root) %{arch}/bin/ld.bfd
113 %attr(755,root,root) %{arch}/bin/nm
114 %attr(755,root,root) %{arch}/bin/objcopy
115 %attr(755,root,root) %{arch}/bin/objdump
116 %attr(755,root,root) %{arch}/bin/ranlib
117 %attr(755,root,root) %{arch}/bin/strip
118 %{arch}/lib/ldscripts
119 %attr(755,root,root) %{_bindir}/%{target}-addr2line
120 %attr(755,root,root) %{_bindir}/%{target}-ar
121 %attr(755,root,root) %{_bindir}/%{target}-as
122 %attr(755,root,root) %{_bindir}/%{target}-c++filt
123 %attr(755,root,root) %{_bindir}/%{target}-dlltool
124 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
125 %attr(755,root,root) %{_bindir}/%{target}-elfedit
126 %attr(755,root,root) %{_bindir}/%{target}-gprof
127 %attr(755,root,root) %{_bindir}/%{target}-ld
128 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
129 %attr(755,root,root) %{_bindir}/%{target}-nm
130 %attr(755,root,root) %{_bindir}/%{target}-objcopy
131 %attr(755,root,root) %{_bindir}/%{target}-objdump
132 %attr(755,root,root) %{_bindir}/%{target}-ranlib
133 %attr(755,root,root) %{_bindir}/%{target}-readelf
134 %attr(755,root,root) %{_bindir}/%{target}-size
135 %attr(755,root,root) %{_bindir}/%{target}-strings
136 %attr(755,root,root) %{_bindir}/%{target}-strip
137 %attr(755,root,root) %{_bindir}/%{target}-windmc
138 %attr(755,root,root) %{_bindir}/%{target}-windres
139 %{_mandir}/man1/%{target}-addr2line.1*
140 %{_mandir}/man1/%{target}-ar.1*
141 %{_mandir}/man1/%{target}-as.1*
142 %{_mandir}/man1/%{target}-c++filt.1*
143 %{_mandir}/man1/%{target}-dlltool.1*
144 %{_mandir}/man1/%{target}-elfedit.1*
145 %{_mandir}/man1/%{target}-gprof.1*
146 %{_mandir}/man1/%{target}-ld.1*
147 %{_mandir}/man1/%{target}-nm.1*
148 %{_mandir}/man1/%{target}-objcopy.1*
149 %{_mandir}/man1/%{target}-objdump.1*
150 %{_mandir}/man1/%{target}-ranlib.1*
151 %{_mandir}/man1/%{target}-readelf.1*
152 %{_mandir}/man1/%{target}-size.1*
153 %{_mandir}/man1/%{target}-strings.1*
154 %{_mandir}/man1/%{target}-strip.1*
155 %{_mandir}/man1/%{target}-windmc.1*
156 %{_mandir}/man1/%{target}-windres.1*
This page took 0.117821 seconds and 3 git commands to generate.