]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blob - crossmingw32-atk.spec
- updated to 2.28.1
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
1 %define         realname   atk
2 Summary:        ATK - Accessibility Toolkit - cross MinGW32 version
3 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.28.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/2.28/%{realname}-%{version}.tar.xz
10 # Source0-md5:  dfb5e7474220afa3f4ca7e45af9f3a11
11 URL:            https://developer.gnome.org/atk/
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-glib2 >= 2.32.0
16 # glib-genmarshal, glib-mkenums
17 BuildRequires:  glib2-devel >= 1:2.32.0
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  perl-base
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  python >= 1:2.5
22 BuildRequires:  rpmbuild(macros) >= 1.197
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       crossmingw32-glib2 >= 2.32.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         no_install_post_strip   1
29
30 %define         target                  i386-mingw32
31 %define         target_platform         i386-pc-mingw32
32
33 %define         _sysprefix              /usr
34 %define         _prefix                 %{_sysprefix}/%{target}
35 %define         _libdir                 %{_prefix}/lib
36 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
37 %define         _dlldir                 /usr/share/wine/windows/system
38 %define         __cc                    %{target}-gcc
39 %define         __cxx                   %{target}-g++
40 %define         __pkgconfig_provides    %{nil}
41 %define         __pkgconfig_requires    %{nil}
42
43 %ifnarch %{ix86}
44 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
45 %define         optflags        -O2
46 %endif
47 # -z options are invalid for mingw linker, most of -f options are Linux-specific
48 %define         filterout_ld    -Wl,-z,.*
49 %define         filterout_c     -f[-a-z0-9=]*
50
51 %description
52 The ATK library provides a set of interfaces for adding accessibility
53 support to applications and graphical user interface toolkits. By
54 supporting the ATK interfaces, an application or toolkit can be used
55 as tools such as screen readers and magnifiers, and alternative input
56 devices.
57
58 This package contains the cross version for Win32.
59
60 %description -l pl.UTF-8
61 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
62 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
63 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
64 ATK, aplikacja lub element interfejsu może być używany z takimi
65 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
66 alternatywnymi urządzeniami wejściowymi.
67
68 Ten pakiet zawiera wersję skrośną dla Win32.
69
70 %package static
71 Summary:        Static atk library (cross MinGW32 version)
72 Summary(pl.UTF-8):      Statyczna biblioteka atk (wersja skrośna MinGW32)
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description static
77 Static atk library (cross MinGW32 version).
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka atk (wersja skrośna MinGW32).
81
82 %package dll
83 Summary:        DLL atk library for Windows
84 Summary(pl.UTF-8):      Biblioteka DLL atk dla Windows
85 Group:          Applications/Emulators
86 Requires:       crossmingw32-glib2-dll >= 2.32.0
87 Requires:       wine
88
89 %description dll
90 DLL atk library for Windows.
91
92 %description dll -l pl.UTF-8
93 Biblioteka DLL atk dla Windows.
94
95 %prep
96 %setup -q -n %{realname}-%{version}
97
98 %build
99 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --target=%{target} \
107         --host=%{target} \
108         --disable-gtk-doc \
109         --disable-silent-rules \
110         --enable-static
111
112 %{__make} \
113         GLIB_GENMARSHAL=/usr/bin/glib-genmarshal \
114         GLIB_MKENUMS=/usr/bin/glib-mkenums
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} -j1 install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install -d $RPM_BUILD_ROOT%{_dlldir}
123 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
124
125 %if 0%{!?debug:1}
126 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
127 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
128 %endif
129
130 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
131 # runtime
132 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS NEWS README
140 %{_libdir}/libatk-1.0.dll.a
141 %{_libdir}/libatk-1.0.la
142 %{_includedir}/atk-1.0
143 %{_pkgconfigdir}/atk.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libatk-1.0.a
148
149 %files dll
150 %defattr(644,root,root,755)
151 %{_dlldir}/libatk-1.0-*.dll
This page took 0.06283 seconds and 3 git commands to generate.