]> git.pld-linux.org Git - packages/crossarm-gcc.git/blob - crossarm-gcc.spec
cleanups and alignment with gcc.spec; rel 2
[packages/crossarm-gcc.git] / crossarm-gcc.spec
1 #
2 # MUST SEE:
3 #               - GCC ARM Improvement Project - http://www.inf.u-szeged.hu/gcc-arm/
4 #               - Developing StrongARM shellocde - http://phrack.org/show.php?p=58&a=10
5
6 Summary:        Cross ARM GNU binary utility development utilities - gcc
7 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - ARM gcc
8 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - ARM gcc
9 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla ARM - gcc
10 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - ARM gcc
11 Summary(tr.UTF-8):      GNU geliştirme araçları - ARM gcc
12 Name:           crossarm-gcc
13 Version:        11.2.0
14 Release:        2
15 Epoch:          1
16 License:        GPL
17 Group:          Development/Languages
18 Source0:        https://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.xz
19 # Source0-md5:  31c86f2ced76acac66992eeedce2fce2
20 URL:            http://gcc.gnu.org/
21 BuildRequires:  autoconf >= 2.64
22 BuildRequires:  automake >= 1:1.11.1
23 BuildRequires:  bison
24 BuildRequires:  crossarm-binutils >= 2.30
25 BuildRequires:  flex >= 2.5.4
26 BuildRequires:  gmp-devel >= 4.3.2
27 BuildRequires:  isl-devel >= 0.15
28 BuildRequires:  libmpc-devel >= 0.8.1
29 BuildRequires:  mpfr-devel >= 3.1.0
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRequires:  zlib-devel
33 BuildRequires:  zstd-devel
34 Requires:       crossarm-binutils >= 2.30
35 Requires:       gcc-dirs
36 Requires:       gmp >= 4.3.2
37 Requires:       isl >= 0.15
38 Requires:       libmpc >= 0.8.1
39 Requires:       mpfr >= 3.1.0
40 ExcludeArch:    %{arm}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         target          arm-linux-gnueabi
44 %define         arch            %{_prefix}/%{target}
45 %define         gccarch         %{_libdir}/gcc/%{target}
46 %define         gcclib          %{gccarch}/%{version}
47 %define         filterout       -Werror=format-security
48
49 %description
50 This package contains a cross-gcc which allows the creation of
51 binaries to be run on ARM Linux on other machines.
52
53 %description -l de.UTF-8
54 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
55 anderem Rechner Code für ARM Linux zu generieren.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera skrośny gcc pozwalający na robienie na innych
59 maszynach binariów do uruchamiania na Linuksie ARM.
60
61 %package c++
62 Summary:        C++ support for crossarm-gcc
63 Summary(pl.UTF-8):      Obsługa C++ dla crossarm-gcc
64 Group:          Development/Languages
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66
67 %description c++
68 This package adds C++ support to the GNU Compiler Collection for ARM.
69
70 %description c++ -l pl.UTF-8
71 Ten pakiet dodaje obsługę C++ do kompilatora gcc dla ARM.
72
73 %prep
74 %setup -q -n gcc-%{version}
75
76 %build
77 rm -rf obj-%{target}
78 install -d obj-%{target}
79 cd obj-%{target}
80
81 CFLAGS="%{rpmcflags}" \
82 CXXFLAGS="%{rpmcxxflags}" \
83 TEXCONFIG=false \
84 ../configure \
85         --prefix=%{_prefix} \
86         --infodir=%{_infodir} \
87         --mandir=%{_mandir} \
88         --bindir=%{_bindir} \
89         --libdir=%{_libdir} \
90         --libexecdir=%{_libdir} \
91         --disable-shared \
92         --disable-threads \
93         --enable-languages="c,c++" \
94         --enable-c99 \
95         --enable-long-long \
96         --disable-nls \
97         --with-gnu-as \
98         --with-gnu-ld \
99         --with-demangler-in-ld \
100         --with-system-zlib \
101         --enable-multilib \
102         --without-x \
103         --target=%{target} \
104         --host=%{_target_platform} \
105         --build=%{_target_platform}
106
107 %{__make} all-gcc
108 %{__make} all-target-libgcc
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113
114 %{__make} -C obj-%{target} install-gcc install-target-libgcc \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install obj-%{target}/gcc/specs $RPM_BUILD_ROOT%{gcclib}
118
119 # don't want this here
120 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
121
122 # include/ contains install-tools/include/* and headers that were fixed up
123 # by fixincludes, we don't want former
124 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
125 cp -p $gccdir/include-fixed/syslimits.h $gccdir/include
126 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
127 # but we don't want anything more from install-tools
128 rm -rf  $gccdir/install-tools
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/%{target}-cpp
136 %attr(755,root,root) %{_bindir}/%{target}-gcc
137 %attr(755,root,root) %{_bindir}/%{target}-gcc-%{version}
138 %attr(755,root,root) %{_bindir}/%{target}-gcc-ar
139 %attr(755,root,root) %{_bindir}/%{target}-gcc-nm
140 %attr(755,root,root) %{_bindir}/%{target}-gcc-ranlib
141 %attr(755,root,root) %{_bindir}/%{target}-gcov
142 %attr(755,root,root) %{_bindir}/%{target}-gcov-dump
143 %attr(755,root,root) %{_bindir}/%{target}-gcov-tool
144 %attr(755,root,root) %{_bindir}/%{target}-lto-dump
145 %dir %{gccarch}
146 %dir %{gcclib}
147 %attr(755,root,root) %{gcclib}/cc1
148 %attr(755,root,root) %{gcclib}/collect2
149 %attr(755,root,root) %{gcclib}/lto-wrapper
150 %attr(755,root,root) %{gcclib}/lto1
151 %attr(755,root,root) %{gcclib}/liblto_plugin.so*
152 %{gcclib}/*crt*.o
153 %{gcclib}/libgcc.a
154 %{gcclib}/libgcov.a
155 %{gcclib}/specs*
156 %dir %{gcclib}/include
157 %{gcclib}/include/*.h
158 %{_mandir}/man1/%{target}-cpp.1*
159 %{_mandir}/man1/%{target}-gcc.1*
160 %{_mandir}/man1/%{target}-gcov.1*
161 %{_mandir}/man1/%{target}-gcov-dump.1*
162 %{_mandir}/man1/%{target}-gcov-tool.1*
163 %{_mandir}/man1/%{target}-lto-dump.1*
164 %{_examplesdir}/%{name}-%{version}
165
166 %files c++
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/%{target}-c++
169 %attr(755,root,root) %{_bindir}/%{target}-g++
170 %attr(755,root,root) %{gcclib}/cc1plus
171 %{_mandir}/man1/%{target}-g++.1*
This page took 0.068682 seconds and 3 git commands to generate.