]> git.pld-linux.org Git - packages/criterion.git/blob - criterion.spec
4a118c53ea1494c243462687b9a497fa1c323f3f
[packages/criterion.git] / criterion.spec
1 # TODO:
2 # - system boxfort (when released): https://github.com/diacritic/BoxFort
3 # - system libcsptr (when some post-2017 release made): https://github.com/Snaipe/libcsptr
4 Summary:        A cross-platform C and C++ unit testing framework for the 21th century
5 Summary(pl.UTF-8):      Wieloplatformowy szkielet do testów jednostkowych dla C i C++ w XXI wieku
6 Name:           criterion
7 Version:        2.3.3
8 Release:        3
9 License:        LGPL v2.1+
10 Group:          Libraries
11 #Source0Download: https://github.com/Snaipe/Criterion/releases
12 Source0:        https://github.com/Snaipe/Criterion/releases/download/v%{version}/%{name}-v%{version}.tar.bz2
13 # Source0-md5:  0305dbb5e00f04fd65b22e9ad82ba952
14 Patch0:         %{name}-libdir.patch
15 URL:            https://github.com/Snaipe/Criterion
16 BuildRequires:  cmake >= 2.8.0
17 BuildRequires:  dyncall >= 1.0
18 BuildRequires:  nanomsg-devel >= 1.0.0
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 A dead-simple, yet extensible, C and C++ unit testing framework.
24
25 %description -l pl.UTF-8
26 Bardzo prosty, ale rozszerzalny szkielet testów jednostkowych dla C i
27 C++.
28
29 %package devel
30 Summary:        Header files for criterion library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki criterion
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35
36 %description devel
37 Header files for criterion library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki criterion.
41
42 %prep
43 %setup -q -n %{name}-v%{version}
44 %patch0 -p1
45
46 %build
47 install -d build
48 cd build
49 %cmake ..
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} -C build install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %find_lang Criterion
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66
67 %files -f Criterion.lang
68 %defattr(644,root,root,755)
69 %doc ChangeLog doc/*.txt
70 %attr(755,root,root) %{_libdir}/libcriterion.so.*.*.*
71 %attr(755,root,root) %ghost %{_libdir}/libcriterion.so.3
72
73 %files devel
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_libdir}/libcriterion.so
76 %{_includedir}/criterion
77 %{_pkgconfigdir}/criterion.pc
This page took 0.470057 seconds and 2 git commands to generate.