]> git.pld-linux.org Git - packages/courier-unicode.git/blob - courier-unicode.spec
- updated to 2.2.6
[packages/courier-unicode.git] / courier-unicode.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Courier Unicode library
6 Summary(pl.UTF-8):      Biblioteka Courier Unicode
7 Name:           courier-unicode
8 Version:        2.2.6
9 Release:        1
10 License:        GPL v3
11 Group:          Libraries
12 Source0:        https://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
13 # Source0-md5:  55ca273834da0eca2f99e2558af3a225
14 URL:            http://www.courier-mta.org/unicode/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRequires:  libtool >= 2:1.5
19 BuildRequires:  perl-base
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Courier Unicode library implements several algorithms related to
24 the Unicode Standard:
25 - Look up uppercase, lowercase, and titlecase equivalents of a unicode
26   character.
27 - Implementation of grapheme and word breaking rules.
28 - Implementation of line breaking rules.
29 - Several ancillary functions, like looking up the unicode character
30   that corresponds to some HTML 4.0 entity (such as "&", for
31   example), and determining the normal width or a double-width status of
32   a unicode character. Also, an adaptation of the iconv(3) API for this
33   unicode library.
34 - Look up the Unicode script property.
35 - Look up the category property.
36
37 This library also implements C++ bindings for these algorithms.
38
39 %description -l pl.UTF-8
40 Biblioteka Courier Unicode implementuje kilka algorytmów związanych ze
41 standardem Unicode:
42 - wyszukiwanie małych, wielkich i tytułowych odpowiedników znaków
43   unikodowych,
44 - implementację reguł łamania słów i grafemów,
45 - implementację reguł łamania wierszy tekstu,
46 - kilka funkcji pomocniczych, jak wyszukiwanie znaków unikodowych
47   odpowiadających encjom HTML 4.0 (np. "&") oraz określanie
48   szerokości (normalna lub podwójna) znaku unikodowego; dostępna jest
49   także adaptacja API iconv(3) dla tej biblioteki
50 - wyszukiwanie własności pisma,
51 - wyszukiwanie własności kategorii.
52
53 Biblioteka zawiera także wiązania C++ do tych algorytmów.
54
55 %package devel
56 Summary:        Development files for the Courier Unicode library
57 Summary(pl.UTF-8):      Pliki programistyczne dla biblioteki Courier Unicode
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       libstdc++-devel >= 6:4.7
61
62 %description devel
63 Development files for the Courier Unicode library.
64
65 %description devel -l pl.UTF-8
66 Pliki programistyczne dla biblioteki Courier Unicode.
67
68 %package static
69 Summary:        Static Courier Unicode library
70 Summary(pl.UTF-8):      Statyczna biblioteka Courier Unicode
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Courier Unicode library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka Courier Unicode.
79
80 %prep
81 %setup -q
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # no external dependencies (except libstdc++)
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcourier-unicode.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog README
112 %attr(755,root,root) %{_libdir}/libcourier-unicode.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libcourier-unicode.so.7
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libcourier-unicode.so
118 %{_includedir}/courier-unicode*.h
119 %{_aclocaldir}/courier-unicode*.m4
120 %{_mandir}/man3/unicode::*.3*
121 %{_mandir}/man3/unicode_*.3*
122 %{_mandir}/man7/courier-unicode.7*
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libcourier-unicode.a
128 %endif
This page took 0.069689 seconds and 3 git commands to generate.