]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- BR: gcc 3.2 for SELinux (selinux patch introduces C99 usage)
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        5.0
9 Release:        10
10 License:        GPL
11 Group:          Applications/System
12 # devel versions:
13 #Source0:       ftp://alpha.gnu.org/gnu/fetish/%{name}-%{version}.tar.bz2
14 # final versions:
15 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
16 # Source0-md5:  94e5558ee2a65723d4840bfde2d323f0
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
19 Source2:        DIR_COLORS
20 Source3:        fileutils.sh
21 Source4:        fileutils.csh
22 Source5:        su.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-pam.patch
25 Patch2:         %{name}-getgid.patch
26 Patch3:         %{name}-utmp.patch
27 Patch4:         %{name}-su-paths.patch
28 Patch5:         %{name}-uname-cpuinfo.patch
29 Patch6:         %{name}-date-man.patch
30 Patch7:         %{name}-mem.patch
31 Patch8:         %{name}-install-C.patch
32 Patch9:         %{name}-po.patch
33 Patch10:        %{name}-no-nb.patch
34 # based on http://acl.bestbits.at/current/diff/fileutils-4.1.8acl-0.8.25.diff.gz
35 Patch11:        %{name}-acl-0.8.25.patch
36 Patch12:        %{name}-lsw.patch
37 Patch13:        %{name}-nanosleep.patch
38 Patch14:        %{name}-selinux.patch
39 # allow obsolete head/tail syntax when compiled on POSIX2.200112-compliant glibc
40 # (only if POSIXLY_CORRECT is not set in environment)
41 Patch15:        %{name}-noposix2.patch
42 BuildRequires:  acl-devel
43 BuildRequires:  autoconf >= 2.56
44 BuildRequires:  automake >= 1.7
45 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
46 BuildRequires:  gettext-devel >= 0.11.5
47 BuildRequires:  help2man
48 BuildRequires:  pam-devel
49 BuildRequires:  texinfo >= 4.2
50 %{?with_selinux:BuildRequires:  libselinux-devel}
51 Requires:       pam >= 0.77.3
52 Provides:       fileutils
53 Provides:       sh-utils
54 Provides:       stat
55 Provides:       textutils
56 Obsoletes:      fileutils
57 Obsoletes:      sh-utils
58 Obsoletes:      stat
59 Obsoletes:      textutils
60 Conflicts:      shadow < 1:4.0.3-6
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 These are the GNU core utilities.  This package is the union of
65 the GNU fileutils, sh-utils, and textutils packages.
66
67 Most of these programs have significant advantages over their Unix
68 counterparts, such as greater speed, additional options, and fewer
69 arbitrary limits.
70
71 The programs that can be built with this package are:
72
73   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
74   df dir dircolors dirname du echo env expand expr factor false fmt fold
75   ginstall groups head hostid id join link ln logname ls md5sum mkdir
76   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
77   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
78   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
79   uniq unlink users vdir wc who whoami yes
80
81 %description -l pl
82 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
83 fileutils, sh-utils i textutils.
84
85 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
86 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
87 opcje i mniej ograniczeñ.
88
89 Programy zawarte w tym pakiecie to:
90
91   basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd
92   df dir dircolors dirname du echo env expand expr factor false fmt fold
93   ginstall groups head hostid id join link ln logname ls md5sum mkdir
94   mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
95   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
96   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
97   uniq unlink users vdir wc who whoami yes
98
99 %prep
100 %setup -q -a1
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %patch4 -p1
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109 %patch8 -p1
110 %patch9 -p1
111 %patch10 -p1
112 %patch11 -p1
113 %patch12 -p1
114 %patch13 -p1
115 %{?with_selinux:%patch14 -p1}
116 %patch15 -p1
117
118 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
119
120 # no_NO is just an alias for nb_NO in recent glibc
121 # no.po is outdated, nb.po is more fresh here (see also patch10)
122 rm -f po/no.*
123
124 %build
125 # jm's inttypes.m4 and inttypes.m4 from gettext are really different files
126 mv -f m4/{inttypes.m4,jm-inttypes.m4}
127 %{__gettextize}
128 %{__aclocal} -I m4
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         %{?with_selinux:--enable-selinux} \
134         --enable-pam
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/profile.d}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
146 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{uptime,hostname}.1*
147
148 ln -sf test $RPM_BUILD_ROOT%{_bindir}/[
149
150 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
151 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
152 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
153
154 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
155
156 # su is missed by "make install"
157 install src/su $RPM_BUILD_ROOT/bin
158
159 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
160 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
161 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
162
163 mv -f man/pt_BR man/pt
164 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
165         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
166         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
167 done
168 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
169
170 %find_lang %{name}
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post
176 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
177
178 %postun
179 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
184 %attr(755,root,root) /bin/[!s]*
185 %attr(755,root,root) /bin/s[!u]*
186 %attr(4755,root,root) /bin/su
187 %attr(755,root,root) %{_bindir}/*
188 %attr(755,root,root) %{_sbindir}/*
189 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/su
190 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/DIR_COLORS
191 %attr(755,root,root) /etc/profile.d/*
192 %{_mandir}/man1/*
193 %lang(cs) %{_mandir}/cs/man1/*
194 %lang(da) %{_mandir}/da/man1/*
195 %lang(de) %{_mandir}/de/man1/*
196 %lang(es) %{_mandir}/es/man1/*
197 %lang(fi) %{_mandir}/fi/man1/*
198 %lang(fr) %{_mandir}/fr/man1/*
199 %lang(hu) %{_mandir}/hu/man1/*
200 %lang(id) %{_mandir}/id/man1/*
201 %lang(it) %{_mandir}/it/man1/*
202 %lang(ja) %{_mandir}/ja/man1/*
203 %lang(ko) %{_mandir}/ko/man1/*
204 %lang(nl) %{_mandir}/nl/man1/*
205 %lang(pl) %{_mandir}/pl/man1/*
206 %lang(pt) %{_mandir}/pt/man1/*
207 %lang(ru) %{_mandir}/ru/man1/*
208 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
209 %{_infodir}/coreutils.info*
This page took 0.094604 seconds and 4 git commands to generate.