]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- rel 1
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Core-utils - basic command line utilities
6 Summary(pl):    GNU Core-utils - podstawowe narzêdzia dzia³aj±ce z linii poleceñ
7 Name:           coreutils
8 Version:        6.7
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.bz2
13 # Source0-md5:  a16465d0856cd011a1acc1c21040b7f4
14 Source1:        %{name}-non-english-man-pages.tar.bz2
15 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
16 Source2:        DIR_COLORS
17 Source3:        fileutils.sh
18 Source4:        fileutils.csh
19 Source5:        su.pamd
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-pl.po-update.patch
22 Patch2:         %{name}-pam.patch
23 Patch3:         %{name}-getgid.patch
24 Patch4:         %{name}-su-paths.patch
25 Patch5:         %{name}-uname-cpuinfo.patch
26 Patch6:         %{name}-date-man.patch
27 Patch7:         %{name}-mem.patch
28 Patch8:         %{name}-install-C.patch
29 Patch9:         %{name}-po.patch
30 Patch10:        %{name}-no-nb.patch
31 Patch11:        %{name}-selinux.patch
32 Patch12:        %{name}-system-openat.patch
33 URL:            http://www.gnu.org/software/coreutils/
34 BuildRequires:  acl-devel
35 BuildRequires:  autoconf >= 2.60
36 BuildRequires:  automake >= 1:1.9.6
37 %{?with_selinux:BuildRequires:  gcc >= 5:3.2}
38 BuildRequires:  gettext-devel >= 0.16-2
39 BuildRequires:  help2man
40 %{?with_selinux:BuildRequires:  libselinux-devel}
41 BuildRequires:  pam-devel
42 BuildRequires:  texinfo >= 4.2
43 Requires:       pam >= 0.77.3
44 Requires:       setup >= 2.4.6-2
45 Provides:       fileutils
46 Provides:       sh-utils
47 Provides:       stat
48 Provides:       textutils
49 Obsoletes:      fileutils
50 Obsoletes:      sh-utils
51 Obsoletes:      stat
52 Obsoletes:      textutils
53 Conflicts:      shadow < 1:4.0.3-6
54 Conflicts:      tetex < 1:2.0.2
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 These are the GNU core utilities. This package is the union of the GNU
59 fileutils, sh-utils, and textutils packages.
60
61 Most of these programs have significant advantages over their Unix
62 counterparts, such as greater speed, additional options, and fewer
63 arbitrary limits.
64
65 The programs that can be built with this package are:
66
67   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
68   dd df dir dircolors dirname du echo env expand expr factor false fmt
69   fold install groups head hostid id join link ln logname ls md5sum
70   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
71   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
72   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
73   uniq unlink users vdir wc who whoami yes
74
75 %description -l pl
76 Narzêdzia podstawowe (core utilities) GNU to po³±czone paczki GNU
77 fileutils, sh-utils i textutils.
78
79 Wiêkszo¶æ z zawartych programów jest znacznie ulepszona w porównaniu
80 z ich uniksowymi odpowiednikami, np. szybciej dzia³aj±, maj± dodatkowe
81 opcje i mniej ograniczeñ.
82
83 Programy zawarte w tym pakiecie to:
84
85   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
86   dd df dir dircolors dirname du echo env expand expr factor false fmt
87   fold ginstall groups head hostid id join link ln logname ls md5sum
88   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
89   printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
90   su sum sync tac tail tee test touch tr true tsort tty uname unexpand
91   uniq unlink users vdir wc who whoami yes
92
93 %prep
94 %setup -q -a1
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p1
99 %patch4 -p1
100 %patch5 -p1
101 %patch6 -p1
102 %patch7 -p1
103 %patch8 -p1
104 %patch9 -p1
105 %patch10 -p1
106 %{?with_selinux:%patch11 -p1}
107 %patch12 -p1
108
109 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
110
111 # no_NO is just an alias for nb_NO in recent glibc
112 # no.po is outdated, nb.po is more fresh here (see also patch10)
113 rm -f po/no.*
114 # allow rebuilding *.gmo
115 rm -f po/stamp-po
116
117 # missing, added to gettext.m4 by ./bootstrap
118 echo 'AC_DEFUN([gl_LOCK_EARLY],[])' > m4/gllock.m4
119
120 %build
121 %{__gettextize}
122 %{__aclocal} -I m4
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
128         DEFAULT_POSIX2_VERSION=199209 \
129         %{?with_selinux:--enable-selinux} \
130         --enable-pam
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 rm -f $RPM_BUILD_ROOT%{_bindir}/{hostname,kill,uptime}
142 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{hostname,kill,uptime}.1*
143
144 mv -f $RPM_BUILD_ROOT%{_bindir}/{basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
145 echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
146 sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
147
148 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
149
150 # su is missed by "make install"
151 install src/su $RPM_BUILD_ROOT/bin
152
153 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
154 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
155 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/su
156
157 cp -a man/pt_BR man/pt
158 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
159         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
160         install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
161 done
162 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
163
164 %find_lang %{name}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
171
172 %postun
173 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
174
175 %files -f %{name}.lang
176 %defattr(644,root,root,755)
177 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
178 %attr(755,root,root) /bin/[!s]*
179 %attr(755,root,root) /bin/s[!u]*
180 %attr(4755,root,root) /bin/su
181 %attr(755,root,root) %{_bindir}/*
182 %attr(755,root,root) %{_sbindir}/*
183 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
185 /etc/shrc.d/*
186 %{_mandir}/man1/*
187 %lang(cs) %{_mandir}/cs/man1/*
188 %lang(da) %{_mandir}/da/man1/*
189 %lang(de) %{_mandir}/de/man1/*
190 %lang(es) %{_mandir}/es/man1/*
191 %lang(fi) %{_mandir}/fi/man1/*
192 %lang(fr) %{_mandir}/fr/man1/*
193 %lang(hu) %{_mandir}/hu/man1/*
194 %lang(id) %{_mandir}/id/man1/*
195 %lang(it) %{_mandir}/it/man1/*
196 %lang(ja) %{_mandir}/ja/man1/*
197 %lang(ko) %{_mandir}/ko/man1/*
198 %lang(nl) %{_mandir}/nl/man1/*
199 %lang(pl) %{_mandir}/pl/man1/*
200 %lang(pt) %{_mandir}/pt/man1/*
201 %lang(ru) %{_mandir}/ru/man1/*
202 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
203 %{_infodir}/coreutils.info*
This page took 0.091742 seconds and 4 git commands to generate.