]> git.pld-linux.org Git - packages/coreutils.git/blob - coreutils.spec
- renamed fileutils.(c)sh to colorls.(c)sh to reflect the files meaning
[packages/coreutils.git] / coreutils.spec
1 #
2 # Conditional build:
3 %bcond_with     advcopy # progress bar in cp (orphaned patch)
4 %bcond_without  tests   # do not perform "make test check"
5 #
6 Summary:        GNU Core-utils - basic command line utilities
7 Summary(pl.UTF-8):      GNU Core-utils - podstawowe narzędzia działające z linii poleceń
8 Name:           coreutils
9 Version:        8.22
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/System
13 Source0:        http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
14 # Source0-md5:  8fb0ae2267aa6e728958adc38f8163a2
15 Source1:        %{name}-non-english-man-pages.tar.bz2
16 # Source1-md5:  f7c986ebc74ccb8d08ed70141063f14c
17 Source2:        DIR_COLORS
18 Source3:        colorls.sh
19 Source4:        colorls.csh
20 Source5:        mktemp.1.pl
21 Patch0:         %{name}-info.patch
22 Patch1:         %{name}-getgid.patch
23 Patch2:         %{name}-uname-cpuinfo.patch
24 Patch3:         %{name}-date-man.patch
25 Patch5:         %{name}-7.4-sttytcsadrain.patch
26 Patch6:         %{name}-fmt-wchars.patch
27 Patch7:         %{name}-sparc64.patch
28 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
29 Patch8:         %{name}-pl.po-update.patch
30 # from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
31 Patch9:         %{name}-advcopy.patch
32 Patch10:        tests.patch
33 URL:            http://www.gnu.org/software/coreutils/
34 BuildRequires:  acl-devel
35 BuildRequires:  attr-devel
36 BuildRequires:  autoconf >= 2.64
37 BuildRequires:  automake >= 1:1.11.2
38 BuildRequires:  gcc >= 5:3.2
39 BuildRequires:  gettext-devel >= 0.18.1
40 BuildRequires:  gmp-devel
41 BuildRequires:  help2man
42 BuildRequires:  libcap-devel
43 BuildRequires:  libselinux-devel
44 BuildRequires:  rpmbuild(find_lang) >= 1.24
45 BuildRequires:  tar >= 1:1.22
46 BuildRequires:  texinfo >= 4.2
47 BuildRequires:  xz
48 %if %{with tests}
49 BuildRequires:  strace
50 %endif
51 Requires:       setup >= 2.4.6-2
52 Provides:       fileutils
53 Provides:       mktemp = %{version}-%{release}
54 Provides:       sh-utils
55 Provides:       stat
56 Provides:       textutils
57 Obsoletes:      fileutils
58 Obsoletes:      mktemp
59 Obsoletes:      sh-utils
60 Obsoletes:      stat
61 Obsoletes:      textutils
62 Conflicts:      shadow < 1:4.0.3-6
63 Conflicts:      tetex < 1:2.0.2
64 # ensure util-linux has su included
65 Conflicts:      util-linux < 2.22
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 These are the GNU core utilities. This package is the union of the GNU
70 fileutils, sh-utils, and textutils packages.
71
72 Most of these programs have significant advantages over their Unix
73 counterparts, such as greater speed, additional options, and fewer
74 arbitrary limits.
75
76 The programs that can be built with this package are:
77
78   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
79   dd df dir dircolors dirname du echo env expand expr factor false fmt
80   fold install groups head hostid id join link ln logname ls md5sum
81   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
82   printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
83   stat stty sum sync tac tail tee test touch tr true tsort tty uname
84   unexpand uniq unlink users vdir wc who whoami yes
85
86 %description -l pl.UTF-8
87 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
88 fileutils, sh-utils i textutils.
89
90 Większość z zawartych programów jest znacznie ulepszona w porównaniu
91 z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
92 opcje i mniej ograniczeń.
93
94 Programy zawarte w tym pakiecie to:
95
96   [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
97   dd df dir dircolors dirname du echo env expand expr factor false fmt
98   fold ginstall groups head hostid id join link ln logname ls md5sum
99   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
100   printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
101   stat stty sum sync tac tail tee test touch tr true tsort tty uname
102   unexpand uniq unlink users vdir wc who whoami yes
103
104 %prep
105 %setup -q -a1
106 #patch8 -p1
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111 %patch5 -p1
112 %patch6 -p1
113 %ifarch sparc64
114 %patch7 -p1
115 %endif
116 %if %{with advcopy}
117 # progress-bar patch, -g,--progress-bar //if in doubt, comment it out
118 %patch9 -p1
119 %endif
120 %patch10 -p1
121
122 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
123
124 # allow rebuilding *.gmo
125 %{__rm} po/stamp-po
126
127 # 8-bit-pfx test fails under C locale:
128 # LC_ALL=C echo -e "ça\nçb\n"|LC_ALL=C fmt -p 'ç'
129 # fmt: memory exhausted
130 %{__sed} -i -e 25,27d tests/fmt/base.pl
131
132 # /etc/resolv.conf is blocked in pld builders, try some other file
133 %{__sed} -i -e 's,/etc/resolv.conf,/etc/hosts,' gnulib-tests/test-read-file.c
134
135 # getgid needs to be fixed:
136 # getgid: missing operand
137 # Try `getgid --help' for more information.
138 %{__rm} tests/misc/help-version.sh
139 %{__sed} -i -e '/misc\/help-version/d' tests/local.mk
140
141 # fails on some filesystems (like XFS), where readdir returns d_type=DT_UNKNOWN
142 %{__rm} tests/ls/stat-free-color.sh
143 %{__sed} -i -e '/ls\/stat-free-color/d' tests/local.mk
144
145 # filesystem layout dependant (fails on some xfs fs)
146 %{__rm} tests/dd/sparse.sh
147 %{__sed} -i -e '/dd\/sparse/d' tests/local.mk
148
149 # mksh is too smart for those, won't let programs fail on ulimit
150 # would need bash here
151 %{__rm} tests/misc/sort-merge-fdlimit.sh
152 %{__sed} -i -e '/misc\/sort-merge-fdlimit/d' tests/local.mk
153 %{__rm} tests/split/r-chunk.sh
154 %{__sed} -i -e '/split\/r-chunk/d' tests/local.mk
155
156 %build
157 build-aux/gen-lists-of-programs.sh --autoconf > m4/cu-progs.m4
158 build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
159 %{__gettextize}
160 %{__aclocal} -I m4
161 %{__autoconf}
162 %{__autoheader}
163 %{__automake}
164 %configure \
165         CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
166         DEFAULT_POSIX2_VERSION=199209 \
167         --disable-silent-rules \
168         --enable-install-program=arch \
169         --enable-no-install-program=hostname,kill,uptime
170
171 %{__make}
172
173 %if %{with tests}
174 sed -i -e 's#COLUMNS##g' tests/envvar-check
175 LC_ALL=C LANG=C %{__make} -j1 tests check
176 %endif
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180 install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
181
182 %{__make} install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
186 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
187 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
188
189 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
190
191 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
192 cp -p %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
193
194 cp -a man/pt_BR man/pt
195 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN; do
196         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
197         cp -p man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
198 done
199 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
200 # unwanted (-f left intentionally - some manuals could have no translations)
201 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
202 # always remove, never packaged but sometimes installed
203 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
204
205 %find_lang %{name}
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %post   -p /sbin/postshell
211 -/usr/sbin/fix-info-dir -c %{_infodir}
212
213 %postun -p /sbin/postshell
214 -/usr/sbin/fix-info-dir -c %{_infodir}
215
216 %files -f %{name}.lang
217 %defattr(644,root,root,755)
218 %doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
219 %attr(755,root,root) /bin/arch
220 %attr(755,root,root) /bin/basename
221 %attr(755,root,root) /bin/cat
222 %attr(755,root,root) /bin/chgrp
223 %attr(755,root,root) /bin/chmod
224 %attr(755,root,root) /bin/chown
225 %attr(755,root,root) /bin/cp
226 %attr(755,root,root) /bin/date
227 %attr(755,root,root) /bin/dd
228 %attr(755,root,root) /bin/df
229 %attr(755,root,root) /bin/echo
230 %attr(755,root,root) /bin/false
231 %attr(755,root,root) /bin/id
232 %attr(755,root,root) /bin/link
233 %attr(755,root,root) /bin/ln
234 %attr(755,root,root) /bin/ls
235 %attr(755,root,root) /bin/mkdir
236 %attr(755,root,root) /bin/mknod
237 %attr(755,root,root) /bin/mktemp
238 %attr(755,root,root) /bin/mv
239 %attr(755,root,root) /bin/nice
240 %attr(755,root,root) /bin/printf
241 %attr(755,root,root) /bin/pwd
242 %attr(755,root,root) /bin/readlink
243 %attr(755,root,root) /bin/rm
244 %attr(755,root,root) /bin/rmdir
245 %attr(755,root,root) /bin/sleep
246 %attr(755,root,root) /bin/sort
247 %attr(755,root,root) /bin/stat
248 %attr(755,root,root) /bin/stty
249 %attr(755,root,root) /bin/sync
250 %attr(755,root,root) /bin/touch
251 %attr(755,root,root) /bin/true
252 %attr(755,root,root) /bin/uname
253 %attr(755,root,root) /bin/unlink
254 %attr(755,root,root) %{_bindir}/[
255 %attr(755,root,root) %{_bindir}/base64
256 %attr(755,root,root) %{_bindir}/chcon
257 %attr(755,root,root) %{_bindir}/cksum
258 %attr(755,root,root) %{_bindir}/comm
259 %attr(755,root,root) %{_bindir}/csplit
260 %attr(755,root,root) %{_bindir}/cut
261 %attr(755,root,root) %{_bindir}/dir
262 %attr(755,root,root) %{_bindir}/dircolors
263 %attr(755,root,root) %{_bindir}/dirname
264 %attr(755,root,root) %{_bindir}/du
265 %attr(755,root,root) %{_bindir}/env
266 %attr(755,root,root) %{_bindir}/expand
267 %attr(755,root,root) %{_bindir}/expr
268 %attr(755,root,root) %{_bindir}/factor
269 %attr(755,root,root) %{_bindir}/fmt
270 %attr(755,root,root) %{_bindir}/fold
271 %attr(755,root,root) %{_bindir}/getgid
272 %attr(755,root,root) %{_bindir}/groups
273 %attr(755,root,root) %{_bindir}/head
274 %attr(755,root,root) %{_bindir}/hostid
275 %attr(755,root,root) %{_bindir}/install
276 %attr(755,root,root) %{_bindir}/join
277 %attr(755,root,root) %{_bindir}/logname
278 %attr(755,root,root) %{_bindir}/md5sum
279 %attr(755,root,root) %{_bindir}/mkfifo
280 %attr(755,root,root) %{_bindir}/nl
281 %attr(755,root,root) %{_bindir}/nohup
282 %attr(755,root,root) %{_bindir}/nproc
283 %attr(755,root,root) %{_bindir}/numfmt
284 %attr(755,root,root) %{_bindir}/od
285 %attr(755,root,root) %{_bindir}/paste
286 %attr(755,root,root) %{_bindir}/pathchk
287 %attr(755,root,root) %{_bindir}/pinky
288 %attr(755,root,root) %{_bindir}/pr
289 %attr(755,root,root) %{_bindir}/printenv
290 %attr(755,root,root) %{_bindir}/ptx
291 %attr(755,root,root) %{_bindir}/realpath
292 %attr(755,root,root) %{_bindir}/runcon
293 %attr(755,root,root) %{_bindir}/seq
294 %attr(755,root,root) %{_bindir}/sha1sum
295 %attr(755,root,root) %{_bindir}/sha224sum
296 %attr(755,root,root) %{_bindir}/sha256sum
297 %attr(755,root,root) %{_bindir}/sha384sum
298 %attr(755,root,root) %{_bindir}/sha512sum
299 %attr(755,root,root) %{_bindir}/shred
300 %attr(755,root,root) %{_bindir}/shuf
301 %attr(755,root,root) %{_bindir}/split
302 %attr(755,root,root) %{_bindir}/stdbuf
303 %attr(755,root,root) %{_bindir}/sum
304 %attr(755,root,root) %{_bindir}/tac
305 %attr(755,root,root) %{_bindir}/tail
306 %attr(755,root,root) %{_bindir}/tee
307 %attr(755,root,root) %{_bindir}/test
308 %attr(755,root,root) %{_bindir}/timeout
309 %attr(755,root,root) %{_bindir}/tr
310 %attr(755,root,root) %{_bindir}/truncate
311 %attr(755,root,root) %{_bindir}/tsort
312 %attr(755,root,root) %{_bindir}/tty
313 %attr(755,root,root) %{_bindir}/unexpand
314 %attr(755,root,root) %{_bindir}/uniq
315 %attr(755,root,root) %{_bindir}/users
316 %attr(755,root,root) %{_bindir}/vdir
317 %attr(755,root,root) %{_bindir}/wc
318 %attr(755,root,root) %{_bindir}/who
319 %attr(755,root,root) %{_bindir}/whoami
320 %attr(755,root,root) %{_bindir}/yes
321 %attr(755,root,root) %{_sbindir}/chroot
322 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
323 %config(noreplace) /etc/shrc.d/colorls.csh
324 %config(noreplace) /etc/shrc.d/colorls.sh
325 %dir %{_libdir}/coreutils
326 %attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
327 %{_mandir}/man1/arch.1*
328 %{_mandir}/man1/base64.1*
329 %{_mandir}/man1/basename.1*
330 %{_mandir}/man1/cat.1*
331 %{_mandir}/man1/chcon.1*
332 %{_mandir}/man1/chgrp.1*
333 %{_mandir}/man1/chmod.1*
334 %{_mandir}/man1/chown.1*
335 %{_mandir}/man1/chroot.1*
336 %{_mandir}/man1/cksum.1*
337 %{_mandir}/man1/comm.1*
338 %{_mandir}/man1/cp.1*
339 %{_mandir}/man1/csplit.1*
340 %{_mandir}/man1/cut.1*
341 %{_mandir}/man1/date.1*
342 %{_mandir}/man1/dd.1*
343 %{_mandir}/man1/df.1*
344 %{_mandir}/man1/dir.1*
345 %{_mandir}/man1/dircolors.1*
346 %{_mandir}/man1/dirname.1*
347 %{_mandir}/man1/du.1*
348 %{_mandir}/man1/echo.1*
349 %{_mandir}/man1/env.1*
350 %{_mandir}/man1/expand.1*
351 %{_mandir}/man1/expr.1*
352 %{_mandir}/man1/factor.1*
353 %{_mandir}/man1/false.1*
354 %{_mandir}/man1/fmt.1*
355 %{_mandir}/man1/fold.1*
356 %{_mandir}/man1/getgid.1*
357 %{_mandir}/man1/groups.1*
358 %{_mandir}/man1/head.1*
359 %{_mandir}/man1/hostid.1*
360 %{_mandir}/man1/id.1*
361 %{_mandir}/man1/install.1*
362 %{_mandir}/man1/join.1*
363 %{_mandir}/man1/link.1*
364 %{_mandir}/man1/ln.1*
365 %{_mandir}/man1/logname.1*
366 %{_mandir}/man1/ls.1*
367 %{_mandir}/man1/md5sum.1*
368 %{_mandir}/man1/mkdir.1*
369 %{_mandir}/man1/mkfifo.1*
370 %{_mandir}/man1/mknod.1*
371 %{_mandir}/man1/mktemp.1*
372 %{_mandir}/man1/mv.1*
373 %{_mandir}/man1/nice.1*
374 %{_mandir}/man1/nl.1*
375 %{_mandir}/man1/nohup.1*
376 %{_mandir}/man1/nproc.1*
377 %{_mandir}/man1/numfmt.1*
378 %{_mandir}/man1/od.1*
379 %{_mandir}/man1/paste.1*
380 %{_mandir}/man1/pathchk.1*
381 %{_mandir}/man1/pinky.1*
382 %{_mandir}/man1/pr.1*
383 %{_mandir}/man1/printenv.1*
384 %{_mandir}/man1/printf.1*
385 %{_mandir}/man1/ptx.1*
386 %{_mandir}/man1/pwd.1*
387 %{_mandir}/man1/readlink.1*
388 %{_mandir}/man1/realpath.1*
389 %{_mandir}/man1/rm.1*
390 %{_mandir}/man1/rmdir.1*
391 %{_mandir}/man1/runcon.1*
392 %{_mandir}/man1/seq.1*
393 %{_mandir}/man1/sha1sum.1*
394 %{_mandir}/man1/sha224sum.1*
395 %{_mandir}/man1/sha256sum.1*
396 %{_mandir}/man1/sha384sum.1*
397 %{_mandir}/man1/sha512sum.1*
398 %{_mandir}/man1/shred.1*
399 %{_mandir}/man1/shuf.1*
400 %{_mandir}/man1/sleep.1*
401 %{_mandir}/man1/sort.1*
402 %{_mandir}/man1/split.1*
403 %{_mandir}/man1/stat.1*
404 %{_mandir}/man1/stdbuf.1*
405 %{_mandir}/man1/stty.1*
406 %{_mandir}/man1/sum.1*
407 %{_mandir}/man1/sync.1*
408 %{_mandir}/man1/tac.1*
409 %{_mandir}/man1/tail.1*
410 %{_mandir}/man1/tee.1*
411 %{_mandir}/man1/test.1*
412 %{_mandir}/man1/timeout.1*
413 %{_mandir}/man1/touch.1*
414 %{_mandir}/man1/tr.1*
415 %{_mandir}/man1/true.1*
416 %{_mandir}/man1/truncate.1*
417 %{_mandir}/man1/tsort.1*
418 %{_mandir}/man1/tty.1*
419 %{_mandir}/man1/uname.1*
420 %{_mandir}/man1/unexpand.1*
421 %{_mandir}/man1/uniq.1*
422 %{_mandir}/man1/unlink.1*
423 %{_mandir}/man1/users.1*
424 %{_mandir}/man1/vdir.1*
425 %{_mandir}/man1/wc.1*
426 %{_mandir}/man1/who.1*
427 %{_mandir}/man1/whoami.1*
428 %{_mandir}/man1/yes.1*
429 %lang(cs) %{_mandir}/cs/man1/*
430 %lang(da) %{_mandir}/da/man1/*
431 %lang(de) %{_mandir}/de/man1/*
432 %lang(es) %{_mandir}/es/man1/*
433 %lang(fi) %{_mandir}/fi/man1/*
434 %lang(fr) %{_mandir}/fr/man1/*
435 %lang(hu) %{_mandir}/hu/man1/*
436 %lang(id) %{_mandir}/id/man1/*
437 %lang(it) %{_mandir}/it/man1/*
438 %lang(ja) %{_mandir}/ja/man1/*
439 %lang(ko) %{_mandir}/ko/man1/*
440 %lang(nl) %{_mandir}/nl/man1/*
441 %lang(pl) %{_mandir}/pl/man1/*
442 %lang(pt) %{_mandir}/pt/man1/*
443 %lang(ru) %{_mandir}/ru/man1/*
444 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
445 %{_infodir}/coreutils.info*
This page took 0.055864 seconds and 3 git commands to generate.