]> git.pld-linux.org Git - packages/codec2.git/blob - codec2.spec
- new
[packages/codec2.git] / codec2.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # unit tests
4 #
5 Summary:        Speech codec for 2400 bit/s and below
6 Summary(pl.UTF-8):      Kodek mowy do przesyłania danych 2400 bitów/s i poniżej
7 Name:           codec2
8 Version:        0.8.1
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        https://hobbes1069.fedorapeople.org/freetel/codec2/%{name}-%{version}.tar.xz
13 # Source0-md5:  db383dda2a84fe97d93de621cce49a06
14 URL:            http://rowetel.com/codec2.html
15 BuildRequires:  cmake >= 2.8
16 %if %{with tests}
17 BuildRequires:  libsamplerate-devel
18 BuildRequires:  speex-devel
19 BuildRequires:  speexdsp-devel
20 %endif
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Codec 2 is an open source (LGPL licensed) speech codec for 2400 bit/s
27 and below. This is the runtime library package.
28
29 %description -l pl.UTF-8
30 Codec 2 to mający otwarte źródła (na licencji LGPL) kodek mowy dla
31 szybkości przesyłania danych 2400 bit/s i niższych. Ten pakiet zawiera
32 bibliotekę uruchomieniową.
33
34 %package devel
35 Summary:        Header files for Codec 2 library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Codec 2
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for Codec 2 library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki Codec 2.
45
46 %package tools
47 Summary:        Tools for encoding and decoding in Codec 2 format
48 Summary(pl.UTF-8):      Narzędzia do kodowania i dekodowania w formacie Codec 2
49 Group:          Applications/Sound
50 Requires:       %{name} = %{version}-%{release}
51
52 %description tools
53 Tools for encoding and decoding in Codec 2 format.
54
55 %description tools -l pl.UTF-8
56 Narzędzia do kodowania i dekodowania w formacie Codec 2.
57
58 %prep
59 %setup -q
60
61 %build
62 install -d build
63 cd build
64 %cmake .. \
65         -DCMAKE_INSTALL_INCLUDEDIR=include \
66         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
67         %{!?with_tests:-DUNITTEST=OFF}
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README*
86 %attr(755,root,root) %{_libdir}/libcodec2.so.0.8
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libcodec2.so
91 %{_includedir}/codec2
92 %{_pkgconfigdir}/codec2.pc
93
94 %files tools
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_bindir}/c2dec
97 %attr(755,root,root) %{_bindir}/c2demo
98 %attr(755,root,root) %{_bindir}/c2enc
99 %attr(755,root,root) %{_bindir}/c2sim
100 %attr(755,root,root) %{_bindir}/drs232
101 %attr(755,root,root) %{_bindir}/drs232_ldpc
102 %attr(755,root,root) %{_bindir}/fdmdv_demod
103 %attr(755,root,root) %{_bindir}/fdmdv_get_test_bits
104 %attr(755,root,root) %{_bindir}/fdmdv_interleave
105 %attr(755,root,root) %{_bindir}/fdmdv_mod
106 %attr(755,root,root) %{_bindir}/fdmdv_put_test_bits
107 %attr(755,root,root) %{_bindir}/fec_dec
108 %attr(755,root,root) %{_bindir}/fec_enc
109 %attr(755,root,root) %{_bindir}/fm_demod
110 %attr(755,root,root) %{_bindir}/fsk_mod
111 %attr(755,root,root) %{_bindir}/insert_errors
This page took 0.452638 seconds and 3 git commands to generate.