]> git.pld-linux.org Git - packages/cobbler.git/blob - cobbler.spec
0baa24cccd39e2184dd018501d9d5fdad61e36f5
[packages/cobbler.git] / cobbler.spec
1 # TODO
2 # - webapps
3 # - ImportError: No module named rhpl.translate
4 Summary:        Boot server configurator
5 Name:           cobbler
6 Version:        0.6.4
7 Release:        0.3
8 Source0:        http://cobbler.et.redhat.com/download/%{name}-%{version}.tar.gz
9 # Source0-md5:  1f46e1860e10b2e250c73ebb2a3d8227
10 License:        GPL v2+
11 Group:          Applications/System
12 Requires:       apache-mod_python
13 Requires:       createrepo
14 Requires:       python >= 2.3
15 Requires:       python-cheetah
16 Requires:       python-devel
17 Requires:       python-rhpl
18 Requires:       tftpdaemon
19 Requires:       webapps
20 %ifarch %{ix86} %{x8664}
21 Requires:       syslinux
22 %endif
23 URL:            http://cobbler.et.redhat.com
24 BuildRequires:  python-cheetah
25 BuildRequires:  python-devel
26 #BuildRequires: redhat-rpm-config
27 Requires(post): /sbin/chkconfig
28 Requires(preun):        /sbin/chkconfig
29 BuildArch:      noarch
30 ExcludeArch:    ppc
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _appdir         /var/www/cobbler
34 %define         _cgibindir      /var/www/cgi-bin
35
36 #define         _appdir         %{_datadir}/%{name}
37 #define     _cgibindir  %{_prefix}/lib/cgi-bin/%{name}
38
39 %description
40 Cobbler is a network boot and update server. Cobbler supports PXE,
41 provisioning virtualized images, and reinstalling existing Linux
42 machines. The last two modes require a helper tool called 'koan' that
43 integrates with cobbler. Cobbler's advanced features include importing
44 distributions from DVDs and rsync mirrors, kickstart templating,
45 integrated yum mirroring, and built-in DHCP Management. Cobbler has a
46 Python API for integration with other GPL systems management
47 applications.
48
49 %prep
50 %setup -q
51
52 %build
53 %{__python} setup.py build
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
58 %{__python} setup.py install \
59         --optimize=1 \
60         --root=$RPM_BUILD_ROOT
61
62 %py_postclean
63
64 mv $RPM_BUILD_ROOT/etc/{init.d,rc.d/init.d}/cobblerd
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 cp /var/lib/cobbler/distros*  /var/lib/cobbler/backup 2>/dev/null
71 cp /var/lib/cobbler/profiles* /var/lib/cobbler/backup 2>/dev/null
72 cp /var/lib/cobbler/systems*  /var/lib/cobbler/backup 2>/dev/null
73 cp /var/lib/cobbler/repos*    /var/lib/cobbler/backup 2>/dev/null
74 %{_bindir}/cobbler reserialize
75 /sbin/chkconfig --add cobblerd
76 %service cobblerd restart
77
78 %preun
79 if [ $1 = 0 ]; then
80         %service cobblerd stop
81         /sbin/chkconfig --del cobblerd
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS CHANGELOG README
87 %defattr(755,http,http)
88 %dir %{_cgibindir}/cobbler
89 %{_cgibindir}/cobbler/findks.cgi
90 %{_cgibindir}/cobbler/nopxe.cgi
91 %{_cgibindir}/cobbler/webui.cgi
92 %defattr(660,http,http)
93 %config(noreplace) %{_cgibindir}/cobbler/.htaccess
94 %config(noreplace) %{_cgibindir}/cobbler/.htpasswd
95
96 %defattr(755,http,http)
97 %dir %{_datadir}/cobbler/webui_templates
98 %defattr(444,http,http)
99 %{_datadir}/cobbler/webui_templates/*.tmpl
100
101 %defattr(4755,http,http)
102 %dir /var/log/cobbler
103 %dir /var/log/cobbler/kicklog
104 %dir %{_appdir}
105 %dir %{_appdir}/localmirror
106 %dir %{_appdir}/kickstarts
107 %dir %{_appdir}/kickstarts_sys
108 %dir %{_appdir}/repo_mirror
109 %dir %{_appdir}/repos_profile
110 %dir %{_appdir}/repos_system
111 %dir %{_appdir}/ks_mirror
112 %dir %{_appdir}/ks_mirror/config
113 %dir %{_appdir}/images
114 %dir %{_appdir}/distros
115 %dir %{_appdir}/profiles
116 %dir %{_appdir}/systems
117 %dir %{_appdir}/links
118 %defattr(755,http,http)
119 %dir %{_appdir}/webui
120 %defattr(444,http,http)
121 %{_appdir}/webui/*.css
122 %{_appdir}/webui/*.js
123 %{_appdir}/webui/*.png
124 %{_appdir}/webui/*.html
125 %defattr(-,root,root)
126 %dir /tftpboot/pxelinux.cfg
127 %dir /tftpboot/images
128 %attr(755,root,root) %{_bindir}/cobbler
129 %attr(755,root,root) %{_bindir}/cobblerd
130 %dir %{_sysconfdir}/cobbler
131 %config(noreplace) %{_sysconfdir}/cobbler/default.ks
132 %config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc5.ks
133 %config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc6.ks
134 %config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc6_domU.ks
135 %config(noreplace) %{_sysconfdir}/cobbler/dhcp.template
136 %config(noreplace) %{_sysconfdir}/cobbler/dnsmasq.template
137 %config(noreplace) %{_sysconfdir}/cobbler/pxedefault.template
138 %config(noreplace) %{_sysconfdir}/cobbler/pxeprofile.template
139 %config(noreplace) %{_sysconfdir}/cobbler/pxesystem.template
140 %config(noreplace) %{_sysconfdir}/cobbler/pxesystem_ia64.template
141 %config(noreplace) %{_sysconfdir}/cobbler/rsync.exclude
142 %config(noreplace) /etc/logrotate.d/cobblerd_rotate
143 %config(noreplace) %{_sysconfdir}/cobbler/modules.conf
144 %config(noreplace) %{_sysconfdir}/cobbler/webui-cherrypy.cfg
145 %dir %{py_sitescriptdir}/cobbler
146 %dir %{py_sitescriptdir}/cobbler/yaml
147 %dir %{py_sitescriptdir}/cobbler/modules
148 %dir %{py_sitescriptdir}/cobbler/webui
149 %{py_sitescriptdir}/cobbler/*.py[co]
150 %{py_sitescriptdir}/cobbler/yaml/*.py[co]
151 %{py_sitescriptdir}/cobbler/modules/*.py[co]
152 %{py_sitescriptdir}/cobbler/webui/*.py[co]
153 %{_mandir}/man1/cobbler.1*
154 %attr(754,root,root) /etc/rc.d/init.d/cobblerd
155 %config(noreplace) %{_sysconfdir}/httpd/conf.d/cobbler.conf
156 %dir /var/log/cobbler/syslog
157
158 %defattr(755,root,root)
159 %dir /var/lib/cobbler
160 %dir /var/lib/cobbler/kickstarts/
161 %dir /var/lib/cobbler/backup/
162 %dir /var/lib/cobbler/triggers/add/distro/pre
163 %dir /var/lib/cobbler/triggers/add/distro/post
164 %dir /var/lib/cobbler/triggers/add/profile/pre
165 %dir /var/lib/cobbler/triggers/add/profile/post
166 %dir /var/lib/cobbler/triggers/add/system/pre
167 %dir /var/lib/cobbler/triggers/add/system/post
168 %dir /var/lib/cobbler/triggers/add/repo/pre
169 %dir /var/lib/cobbler/triggers/add/repo/post
170 %dir /var/lib/cobbler/triggers/delete/distro/pre
171 %dir /var/lib/cobbler/triggers/delete/distro/post
172 %dir /var/lib/cobbler/triggers/delete/profile/pre
173 %dir /var/lib/cobbler/triggers/delete/profile/post
174 %dir /var/lib/cobbler/triggers/delete/system/pre
175 %dir /var/lib/cobbler/triggers/delete/system/post
176 %dir /var/lib/cobbler/triggers/delete/repo/pre
177 %dir /var/lib/cobbler/triggers/delete/repo/post
178 %dir /var/lib/cobbler/triggers/sync/pre
179 %dir /var/lib/cobbler/triggers/sync/post
180 %dir /var/lib/cobbler/snippets/
181
182 %defattr(744,root,root)
183 %config(noreplace) /var/lib/cobbler/triggers/sync/post/restart-services.trigger
184
185 %defattr(664,root,root)
186 %config(noreplace) /var/lib/cobbler/settings
187 %config(noreplace) /var/lib/cobbler/snippets/partition_select
188 /var/lib/cobbler/elilo-3.6-ia64.efi
189 /var/lib/cobbler/menu.c32
190 %defattr(660,http,http)
191 %config(noreplace) %{_sysconfdir}/cobbler/auth.conf
192
193 %defattr(664,root,root)
194 %config(noreplace) /var/lib/cobbler/cobbler_hosts
This page took 0.478601 seconds and 2 git commands to generate.