]> git.pld-linux.org Git - packages/cmrt.git/blob - cmrt.spec
- new; jitter subpackage contains binary blob
[packages/cmrt.git] / cmrt.spec
1 #
2 # Conditional build:
3 %bcond_with     static_libs     # static library
4
5 %define libva_ver       1.2.0
6
7 Summary:        C for Media Runtime - Media GPU kernel manager for Intel G45 & HD Graphics family
8 Summary(pl.UTF-8):      C for Media Runtime - zarządca jądra multimedialnego GPU dla układów z rodzin Intel G45 i HD
9 Name:           cmrt
10 Version:        1.0.6
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 #Source0Download: https://github.com/intel/cmrt/releases
15 Source0:        https://github.com/intel/cmrt/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  91f5845c9354cce44a5133337f4e881c
17 URL:            https://github.com/intel/cmrt
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  libdrm-devel >= 2.4.23
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  libva-devel >= %{libva_ver}
24 BuildRequires:  pkgconfig
25 BuildRequires:  pkgconfig(libva) >= 0.34
26 Requires:       libdrm >= 2.4.23
27 Requires:       libva >= %{libva_ver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 C for Media Runtime - Media GPU kernel manager for Intel G45 & HD
32 Graphics family.
33
34 %description -l pl.UTF-8
35 C for Media Runtime - zarządca jądra multimedialnego GPU dla układów z
36 rodzin Intel G45 i HD.
37
38 %package jitter
39 Summary:        Online compiler to convert VirtualISA into Gen HW instructions
40 Summary(pl.UTF-8):      Kompilator w locie reprezentacji VirtualISA na instrukcje Gen HW
41 License:        distributable, non-free, closed source
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libstdc++ >= 6:4.8
44
45 %description jitter
46 Jitter (igfxcmjit32.so or igfxcmjit64.so) is an online compiler to
47 convert VirtualISA into Gen HW instruction, while VirtualISA is an
48 intermediate representation between CM source code and HW instruction.
49
50 %description jitter -l pl.UTF-8
51 Jitter (igfxcmjit32.so lub igfxcmjit64.so) to działający w locie
52 kompilator przekształcający reprezentację VirtualISA na instrukcje Gen
53 HW. VirtualISA to reprezentacja pośrednia między kodem źródłowym CM a
54 instrukcjami sprzętowymi.
55
56 %package devel
57 Summary:        Header files for CMRT library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMRT
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for CMRT library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki CMRT.
67
68 %package static
69 Summary:        Static CMRT library
70 Summary(pl.UTF-8):      Statyczna biblioteka CMRT
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static CMRT library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka CMRT.
79
80 %prep
81 %setup -q
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --disable-silent-rules \
91         %{?with_static_libs:--enable-static}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %ifarch %{ix86}
101 install jitter/igfxcmjit32.so $RPM_BUILD_ROOT%{_libdir}
102 %endif
103 %ifarch %{x8664}
104 install jitter/igfxcmjit64.so $RPM_BUILD_ROOT%{_libdir}
105 %endif
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcmrt.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING NEWS README
119 %attr(755,root,root) %{_libdir}/libcmrt.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libcmrt.so.1
121 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cmrt.conf
122
123 %ifarch %{ix86} %{x8664}
124 %files jitter
125 %defattr(644,root,root,755)
126 %doc jitter/{LICENSE,readme}.txt
127 %ifarch %{ix86}
128 %attr(755,root,root) %{_libdir}/igfxcmjit32.so
129 %endif
130 %ifarch %{x8664}
131 %attr(755,root,root) %{_libdir}/igfxcmjit64.so
132 %endif
133 %endif
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libcmrt.so
138 %{_includedir}/cm_rt*.h
139 %{_pkgconfigdir}/libcmrt.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libcmrt.a
145 %endif
This page took 0.115553 seconds and 3 git commands to generate.