]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
b4bdd2fd90b1cea356cc5ae9139b27d28ce428e4
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.12.1
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.18.2
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 Source0:        http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
14 # Source0-md5:  69116aa6cd5e73f6b688d871875e1292
15 Patch0:         cloog-missing.patch
16 URL:            http://www.cloog.org/
17 BuildRequires:  autoconf >= 2.13
18 BuildRequires:  automake
19 BuildRequires:  gmp-devel >= 5.0.2
20 BuildRequires:  gmp-c++-devel >= 5.0.2
21 BuildRequires:  isl-devel >= %{isl_ver}
22 BuildRequires:  libtool
23 %{?with_osl:BuildRequires:      osl-devel}
24 BuildRequires:  texinfo-texi2dvi
25 Requires:       %{name}-libs = %{version}-%{release}
26 Provides:       cloog = %{version}
27 Obsoletes:      cloog
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 CLooG is a software which generates loops for scanning Z-polyhedra.
32 That is, CLooG finds the code or pseudo-code where each integral point
33 of one or more parametrized polyhedron or parametrized polyhedra union
34 is reached. CLooG is designed to avoid control overhead and to produce
35 a very efficient code.
36
37 This version is based on isl.
38
39 %description -l pl.UTF-8
40 CLooG to oprogramowanie generujące pętle do przeszukiwania
41 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
42 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
43 sparametryzowanych wielościanów lub sum sparametryzowanych
44 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
45 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
46
47 Ta wersja jest oparta na bibliotece isl.
48
49 %package libs
50 Summary:        Chunky Loop Generator shared library - isl based version
51 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
52 Group:          Libraries
53 Requires:       isl >= %{isl_ver}
54
55 %description libs
56 Chunky Loop Generator shared library - isl based version.
57
58 %description libs -l pl.UTF-8
59 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
60 isl.
61
62 %package devel
63 Summary:        Header files for the isl based version of Chunky Loop Generator
64 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       gmp-devel >= 5.0.2
68 Requires:       gmp-c++-devel >= 5.0.2
69 Requires:       isl-devel >= %{isl_ver}
70 %{?with_osl:Requires:   osl-devel}
71 Provides:       cloog-devel = %{version}
72
73 %description devel
74 The header files for Chunky Loop Generator library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
78
79 %package static
80 Summary:        Static library of isl based version of Chunky Loop Generator
81 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static library of isl based version of Chunky Loop Generator.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
90
91 %prep
92 %setup -q -n cloog-%{version}
93 %patch0 -p1
94
95 %build
96 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
97 %configure \
98         --disable-silent-rules \
99         --with-gmp-exec-prefix \
100         --with-isl=system \
101         %{?with_osl:--with-osl=system}
102
103 %{__make}
104
105 %{__make} -C doc cloog.pdf
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   libs -p /sbin/ldconfig
117 %postun libs -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/cloog
122
123 %files libs
124 %defattr(644,root,root,755)
125 %doc ChangeLog README
126 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc doc/cloog.pdf
132 %attr(755,root,root) %{_libdir}/libcloog-isl.so
133 %{_libdir}/libcloog-isl.la
134 %dir %{_includedir}/cloog
135 %{_includedir}/cloog/*.h
136 %{_includedir}/cloog/isl
137 %{_includedir}/cloog/matrix
138 %dir %{_libdir}/cloog-isl
139 %{_libdir}/cloog-isl/cloog-isl-config.cmake
140 %dir %{_libdir}/isl
141 %{_libdir}/isl/isl-config.cmake
142 %{_pkgconfigdir}/cloog-isl.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libcloog-isl.a
This page took 0.029545 seconds and 2 git commands to generate.