]> git.pld-linux.org Git - packages/clinkc.git/blob - clinkc.spec
d3e1f7af0b2fa24fdff436b8d2f5ee0399245ba3
[packages/clinkc.git] / clinkc.spec
1 # note: for versions >= 3 (with changed library name) see mupnp.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 %bcond_with     libxml2         # libxml2 instead of expat
6 #
7 Summary:        CyberLink for C UPnP library
8 Summary(pl.UTF-8):      Biblioteka UPnP CyberLink dla C
9 Name:           clinkc
10 # keep 2.x here for libclinkc name
11 Version:        2.4.1
12 Release:        1
13 License:        BSD
14 Group:          Libraries
15 #Source0Download: https://github.com/cybergarage/mupnp/releases
16 Source0:        https://github.com/cybergarage/mupnp/archive/%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  622ba12704305091dbc5978d5a0a49df
18 Patch0:         %{name}-libtool.patch
19 Patch1:         %{name}-iconv.patch
20 Patch2:         %{name}-doc.patch
21 Patch3:         %{name}-version.patch
22 URL:            https://sourceforge.net/projects/clinkc/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  curl-devel >= 7.13.0
26 BuildRequires:  doxygen
27 %{!?with_libxml2:BuildRequires: expat-devel >= 1.95}
28 BuildRequires:  libtool
29 BuildRequires:  libuuid-devel
30 %{?with_libxml2:BuildRequires:  libxml2-devel >= 1:2.6.0}
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-build >= 4.6
33 %{?with_libxml2:Requires:       libxml2 >= 1:2.6.0}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 CyberLink for C is a toolkit for creating UPnP devices and control
38 points. 
39
40 %description -l pl.UTF-8
41 CyberLink dla C to biblioteka narzędziowa do tworzenia urządzeń i
42 punktów kontrolnych UPnP.
43
44 %package devel
45 Summary:        Header files for clinkc library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clinkc
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %{!?with_libxml2:Requires:      expat-devel >= 1.95}
50 Requires:       libuuid-devel
51 %{?with_libxml2:Requires:       libxml2-devel >= 1:2.6.0}
52
53 %description devel
54 Header files for clinkc library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki clinkc.
58
59 %package static
60 Summary:        Static clinkc library
61 Summary(pl.UTF-8):      Statyczna biblioteka clinkc
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static clinkc library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka clinkc.
70
71 %package apidocs
72 Summary:        API documentation for clinkc library
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki clinkc
74 Group:          Documentation
75 BuildArch:      noarch
76
77 %description apidocs
78 API documentation for clinkc library.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki clinkc.
82
83 %prep
84 %setup -q -n mupnp-%{version}
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?with_static_libs:--disable-static}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # obsoleted by pkg-config
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclinkc.la
108 # compiled binaries
109 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/clinkc-%{version}/samples
110 # packaged as %doc
111 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{clinkc-dev,clinkc0}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc COPYING ChangeLog
122 %attr(755,root,root) %{_libdir}/libclinkc.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libclinkc.so.0
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libclinkc.so
128 %{_includedir}/cybergarage
129 %{_pkgconfigdir}/clinkc.pc
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libclinkc.a
135 %endif
136
137 %if %{with apidocs}
138 %files apidocs
139 %defattr(644,root,root,755)
140 %doc doxygen/html/*.{css,html,js,png}
141 %endif
This page took 0.061837 seconds and 2 git commands to generate.