]> git.pld-linux.org Git - packages/clinkc.git/blob - clinkc.spec
- missing spec
[packages/clinkc.git] / clinkc.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     libxml2         # libxml2 instead of expat
5 #
6 Summary:        CyberLink for C UPnP library
7 Summary(pl.UTF-8):      Biblioteka UPnP CyberLink dla C
8 Name:           clinkc
9 Version:        2.4.0
10 %define fver    %(echo %{version} | tr -d .)
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 Source0:        https://downloads.sourceforge.net/clinkc/%{name}%{fver}.tar.gz
15 # Source0-md5:  d548ead428419b0e2e521f06cd7b2ddb
16 Patch0:         %{name}-libtool.patch
17 Patch1:         %{name}-iconv.patch
18 Patch2:         %{name}-doc.patch
19 URL:            https://sourceforge.net/projects/clinkc/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  curl-devel >= 7.13.0
23 BuildRequires:  doxygen
24 %{!?with_libxml2:BuildRequires: expat-devel >= 1.95}
25 BuildRequires:  libtool
26 BuildRequires:  libuuid-devel
27 %{?with_libxml2:BuildRequires:  libxml2-devel >= 1:2.6.0}
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-build >= 4.6
30 %{?with_libxml2:Requires:       libxml2 >= 1:2.6.0}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 CyberLink for C is a toolkit for creating UPnP devices and control
35 points. 
36
37 %description -l pl.UTF-8
38 CyberLink dla C to biblioteka narzędziowa do tworzenia urządzeń i
39 punktów kontrolnych UPnP.
40
41 %package devel
42 Summary:        Header files for clinkc library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clinkc
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 %{!?with_libxml2:Requires:      expat-devel >= 1.95}
47 Requires:       libuuid-devel
48 %{?with_libxml2:Requires:       libxml2-devel >= 1:2.6.0}
49
50 %description devel
51 Header files for clinkc library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki clinkc.
55
56 %package static
57 Summary:        Static clinkc library
58 Summary(pl.UTF-8):      Statyczna biblioteka clinkc
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static clinkc library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka clinkc.
67
68 %package apidocs
69 Summary:        API documentation for clinkc library
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki clinkc
71 Group:          Documentation
72 BuildArch:      noarch
73
74 %description apidocs
75 API documentation for clinkc library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki clinkc.
79
80 %prep
81 %setup -q -n %{name}
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85
86 %build
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         %{!?with_static_libs:--disable-static}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # obsoleted by pkg-config
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclinkc.la
104 # compiled binaries
105 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/clinkc-2.3
106 # packaged as %doc
107 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{clinkc-dev,clinkc0}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc COPYING ChangeLog
118 %attr(755,root,root) %{_libdir}/libclinkc.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libclinkc.so.0
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libclinkc.so
124 %{_includedir}/cybergarage
125 %{_pkgconfigdir}/clinkc.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libclinkc.a
131 %endif
132
133 %if %{with apidocs}
134 %files apidocs
135 %defattr(644,root,root,755)
136 %doc doxygen/html/*.{css,html,js,png}
137 %endif
This page took 0.050147 seconds and 3 git commands to generate.