]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- dash ("-") is not allowed in macro (including bcond) names
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - update patch0
3 # - add missing BRs
4 #
5 # Conditional build:
6 %bcond_without  engine_xine             # without xine engine
7 %bcond_without  engine_vlc              # without vlc engine
8 %bcond_without  engine_qt_phonon        # without qt-phonon engine
9 %bcond_without  engine_gstreamer        # without gstreamer engine
10 #
11 Summary:        A music player and library organiser
12 Name:           clementine
13 Version:        0.3
14 Release:        0.1
15 License:        GPL v3 and GPL v2+
16 Group:          Applications/Multimedia
17 URL:            http://code.google.com/p/clementine-player
18 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
19 # Source0-md5:  3aff98e41d9bf96717ecf97c780ef086
20 Patch0:         %{name}-dont-bundle-external-lib.patch
21 Patch1:         %{name}-static.patch
22 Patch2:         desktop-install.patch
23 BuildRequires:  QtCore-devel
24 BuildRequires:  QtDBus-devel
25 BuildRequires:  QtGui-devel
26 BuildRequires:  QtNetwork-devel
27 BuildRequires:  QtOpenGL-devel
28 BuildRequires:  QtSingleApplication-devel
29 BuildRequires:  QtSql-devel
30 BuildRequires:  QtTest-devel
31 BuildRequires:  boost-devel
32 BuildRequires:  cmake >= 2.6
33 BuildRequires:  desktop-file-utils
34 BuildRequires:  gettext-devel
35 BuildRequires:  gstreamer-devel
36 BuildRequires:  gtest-devel
37 BuildRequires:  liblastfm-devel
38 BuildRequires:  libnotify-devel
39 BuildRequires:  libqxt-devel
40 BuildRequires:  notification-daemon
41 BuildRequires:  phonon-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  qt4-build
44 BuildRequires:  qt4-linguist
45 BuildRequires:  qt4-qmake
46 BuildRequires:  rpmbuild(macros) >= 1.198
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite-devel
49 BuildRequires:  sqlite3-devel
50 BuildRequires:  taglib-devel
51 BuildRequires:  vlc-devel
52 BuildRequires:  xine-lib-devel
53 Requires(post,postun):  desktop-file-utils
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Clementine is a modern music player and library organiser. It is
58 largely a port of Amarok 1.4, with some features rewritten to take
59 advantage of Qt4.
60
61 %prep
62 %setup -q
63 #%patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 # We already don't use these but just to make sure
68 #rm -fr 3rdparty
69
70 # Don't build tests. They require gmock
71 sed -i -e '/tests/d' CMakeLists.txt
72
73 %build
74 install -d build
75 cd build
76 %cmake \
77         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
78         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
79         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
80         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
81         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
82         ..
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %update_desktop_database_post
95
96 %postun
97 %update_desktop_database_postun
98
99 %files
100 %defattr(644,root,root,755)
101 %doc Changelog TODO
102 %attr(755,root,root) %{_bindir}/clementine
103 %{_desktopdir}/clementine.desktop
104 %{_pixmapsdir}/clementine.png
This page took 0.085152 seconds and 4 git commands to generate.