]> git.pld-linux.org Git - packages/clearsilver.git/blob - clearsilver.spec
- rel 6
[packages/clearsilver.git] / clearsilver.spec
1 Summary:        ClearSilver HTML template system
2 Summary(pl.UTF-8):      ClearSilver - system szablonów HTML
3 Name:           clearsilver
4 Version:        0.10.5
5 Release:        6
6 License:        Apache License style
7 Group:          Development/Libraries
8 Source0:        http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  b8c0c7fbe0ef5e06e0c935f134304d44
10 Patch0:         %{name}-pic.patch
11 URL:            http://www.clearsilver.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  perl-ExtUtils-MakeMaker
15 BuildRequires:  perl-devel
16 BuildRequires:  python-devel
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 ClearSilver is a fast, powerful, and language-neutral HTML template
24 system. In both static content sites and dynamic HTML applications, it
25 provides a separation between presentation code and application logic
26 which makes working with your project easier.
27
28 %description -l pl.UTF-8
29 ClearSilver to szybki, potężny i niezależny od języka system szablonów
30 HTML. Zarówno w statycznych stronach HTML jak i dynamicznych
31 aplikacjach pomaga oddzielić kod prezentacyjny od logiki aplikacji, co
32 ułatwia pracę nad projektem.
33
34 %package devel
35 Summary:        ClearSilver development package
36 Summary(pl.UTF-8):      Pakiet programistyczny ClearSilver
37 Group:          Development/Libraries
38
39 %description devel
40 This package provides needed files to develop extension to
41 ClearSilver.
42
43 %description devel -l pl.UTF-8
44 Ten pakiet dostarcza pliki potrzebne do tworzenia rozszerzeń dla
45 ClearSilver.
46
47 %package -n python-clearsilver
48 Summary:        Neotonic ClearSilver Python Module
49 Summary(pl.UTF-8):      Moduł Pythona Neotonic ClearSilver
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n python-clearsilver
54 This package provides a Python interface to the ClearSilver CGI kit
55 and templating system.
56
57 %description -n python-clearsilver -l pl.UTF-8
58 Ten pakiet dostarcza interfejs Pythona do zestawu CGI i systemu
59 szablonów ClearSilver.
60
61 %package -n perl-ClearSilver
62 Summary:        Neotonic ClearSilver Perl Module
63 Summary(pl.UTF-8):      Moduł Perla Neotonic ClearSilver
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description -n perl-ClearSilver
68 This package provides a Perl interface to the ClearSilver templating
69 system.
70
71 %description -n perl-ClearSilver -l pl.UTF-8
72 Ten pakiet dostarcza interfejs Perla do systemu szablonów ClearSilver.
73
74 %package -n ruby-clearsilver
75 Summary:        Neotonic ClearSilver Ruby Module
76 Summary(pl.UTF-8):      Moduł Ruby'ego Neotonic ClearSilver
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n ruby-clearsilver
81 This package provides a ruby interface to the ClearSilver templating
82 system.
83
84 %description -n ruby-clearsilver -l pl.UTF-8
85 Ten pakiet dostarcza interfejs języka Ruby do systemu szablonów
86 ClearSilver.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g" 
93
94 %build
95 install /usr/share/automake/config.* .
96 %{__aclocal}
97 %{__autoconf}
98 %configure \
99         --disable-csharp \
100         --disable-java \
101         --disable-ruby \
102         --enable-apache \
103         --enable-perl \
104         --with-python=%{__python}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         INSTALLDIRS=vendor
114
115 %{__make} install -C python \
116         PYTHON_SITE=%{py_sitedir} \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__make} install -C perl \
120         DESTDIR=$RPM_BUILD_ROOT \
121         INSTALLDIRS=vendor
122
123 rm -rf $RPM_BUILD_ROOT%{perl_archlib} \
124         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
125
126 # what an ass putting it to lib32 dir
127 %if "%{_lib}" != "lib"
128 rm $RPM_BUILD_ROOT%{_prefix}/lib/python%{py_ver}/site-packages/neo_cgi.so
129 %endif
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
137 %attr(755,root,root) %{_bindir}/*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %{_libdir}/libneo_*.a
142 %{_includedir}/ClearSilver
143 %{_mandir}/man3/[!C]*.3*
144
145 %files -n python-clearsilver
146 %defattr(644,root,root,755)
147 %doc README.python
148 %attr(755,root,root) %{py_sitedir}/neo_cgi.so
149
150 %files -n perl-ClearSilver
151 %defattr(644,root,root,755)
152 %{perl_vendorarch}/ClearSilver.pm
153 %dir %{perl_vendorarch}/auto/ClearSilver
154 %{perl_vendorarch}/auto/ClearSilver/ClearSilver.bs
155 %attr(755,root,root) %{perl_vendorarch}/auto/ClearSilver/ClearSilver.so
156 %{_mandir}/man3/ClearSilver.3pm*
157
158 %if 0
159 %files -n ruby-clearsilver
160 %defattr(644,root,root,755)
161 %{ruby_sitepath}/%{ruby_version}/neo.rb
162 %attr(755,root,root) %{ruby_sitepath}/%{ruby_version}/%{ruby_arch}/hdf.so
163
164 %files -n apache-mod_ecs
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{apache_libexec}/mod_ecs.so
167 %endif
This page took 0.035848 seconds and 4 git commands to generate.