]> git.pld-linux.org Git - packages/cjson.git/blob - cjson.spec
530e4ea2b15ad890dacb12318a45146b1aefa76a
[packages/cjson.git] / cjson.spec
1 Summary:        Ultralightweight JSON parser in ANSI C
2 Summary(pl.UTF-8):      Ultralekki parser formatu JSON napisany w ANSI C
3 Name:           cjson
4 Version:        1.7.14
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/DaveGamble/cJSON/releases
9 Source0:        https://github.com/DaveGamble/cJSON/archive/v%{version}/cJSON-%{version}.tar.gz
10 # Source0-md5:  ff0557033e8374033107d40ca79bd52d
11 URL:            https://github.com/DaveGamble/cJSON
12 BuildRequires:  cmake >= 2.8.5
13 BuildRequires:  rpmbuild(macros) >= 1.605
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 cJSON aims to be the dumbest possible parser that you can get your job
18 done with. It's a single file of C, and a single header file.
19
20 %description -l pl.UTF-8
21 cJSON jest tworzony jako możliwie najprostszy parser wykonujący swoje
22 zadanie. Jest to pojedynczy plik w C i pojedynczy plik nagłówkowy.
23
24 %package devel
25 Summary:        Header files for cJSON library
26 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cJSON
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 Header files for cJSON library.
32
33 %description devel -l pl.UTF-8
34 Pliki nagłówkowe biblioteki cJSON.
35
36 %prep
37 %setup -q -n cJSON-%{version}
38
39 %build
40 install -d build
41 cd build
42 %cmake .. \
43         -DENABLE_CJSON_UTILS=ON
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} -C build install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post   -p /sbin/ldconfig
55 %postun -p /sbin/ldconfig
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGELOG.md CONTRIBUTORS.md LICENSE README.md
60 %attr(755,root,root) %{_libdir}/libcjson.so.*.*.*
61 %attr(755,root,root) %ghost %{_libdir}/libcjson.so.1
62 %attr(755,root,root) %{_libdir}/libcjson_utils.so.*.*.*
63 %attr(755,root,root) %ghost %{_libdir}/libcjson_utils.so.1
64
65 %files devel
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_libdir}/libcjson.so
68 %attr(755,root,root) %{_libdir}/libcjson_utils.so
69 %{_includedir}/cjson
70 %{_pkgconfigdir}/libcjson.pc
71 %{_pkgconfigdir}/libcjson_utils.pc
72 %{_libdir}/cmake/cJSON
This page took 0.199165 seconds and 2 git commands to generate.