]> git.pld-linux.org Git - packages/cinnamon-nemo-extensions.git/blob - cinnamon-nemo-extensions.spec
rebuild with python 3.10
[packages/cinnamon-nemo-extensions.git] / cinnamon-nemo-extensions.spec
1 # TODO: make gtkhash.spec with https://github.com/tristanheaven/gtkhash
2 %define         nemo_ver        4.8.0
3 %define         translations_version    4.8.3
4 Summary:        Extensions for Nemo file manager
5 Summary(pl.UTF-8):      Rozszerzenia zarządcy plików Nemo
6 Name:           cinnamon-nemo-extensions
7 Version:        4.8.0
8 Release:        3
9 License:        GPL v2+, GPL v3+, LGPL v2
10 Group:          X11/Applications
11 #Source0Download: https://github.com/linuxmint/nemo-extensions/releases
12 Source0:        https://github.com/linuxmint/nemo-extensions/archive/%{version}/nemo-extensions-%{version}.tar.gz
13 # Source0-md5:  06f3eff72b6d4eb667d3223a82d9b7a6
14 #Source1Download: https://github.com/linuxmint/cinnamon-translations/releases
15 Source1:        https://github.com/linuxmint/cinnamon-translations/archive/%{translations_version}/cinnamon-translations-%{translations_version}.tar.gz
16 # Source1-md5:  a68529f0f1a6c7f8b693a81095bece96
17 Patch0:         %{name}-pc.patch
18 Patch1:         %{name}-ac.patch
19 URL:            https://github.com/linuxmint/nemo-extensions
20 BuildRequires:  autoconf >= 2.63
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  cinnamon-desktop-devel >= 3.0.0
23 BuildRequires:  cinnamon-nemo-devel >= %{nemo_ver}
24 BuildRequires:  cjs-devel >= 4.6.0
25 BuildRequires:  clutter-devel >= 1.11.4
26 BuildRequires:  clutter-gst-devel >= 3.0
27 BuildRequires:  clutter-gtk-devel >= 1.0.1
28 BuildRequires:  dbus-glib-devel >= 0.78
29 BuildRequires:  freetype-devel >= 2
30 BuildRequires:  gcr-ui-devel >= 3.4.0
31 BuildRequires:  gdk-pixbuf2-devel >= 2.23.0
32 BuildRequires:  gettext-tools
33 BuildRequires:  glib2-devel >= 1:2.38
34 BuildRequires:  gnome-common
35 BuildRequires:  gobject-introspection-devel >= 0.9.2
36 BuildRequires:  gpgme-devel >= 1.2.0
37 BuildRequires:  gstreamer-devel >= 1.0
38 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
39 BuildRequires:  gtk+3-devel >= 3.6
40 BuildRequires:  gtk-doc
41 BuildRequires:  gtk-webkit4-devel
42 BuildRequires:  gtksourceview3-devel >= 3.0
43 BuildRequires:  intltool >= 0.40.6
44 BuildRequires:  libcryptui-devel
45 BuildRequires:  libgnome-keyring-devel
46 BuildRequires:  libmusicbrainz5-devel
47 BuildRequires:  libnotify-devel >= 0.7.0
48 BuildRequires:  libtool >= 2:2
49 BuildRequires:  linux-libc-headers >= 7:2.6.38
50 BuildRequires:  meson >= 0.42.0
51 BuildRequires:  ninja >= 1.5
52 BuildRequires:  perl-XML-Parser
53 BuildRequires:  pkgconfig >= 1:0.22
54 BuildRequires:  python-pygobject3-common-devel
55 BuildRequires:  python3-devel >= 1:3.2
56 BuildRequires:  python3-distutils-extra
57 BuildRequires:  python3-pygobject3-devel >= 3.0
58 BuildRequires:  python3-setuptools
59 BuildRequires:  rpm-build >= 4.6
60 BuildRequires:  rpmbuild(macros) >= 1.736
61 BuildRequires:  xreader-devel
62 BuildRequires:  zlib-devel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Extensions for Nemo file manager (used in Cinnamon desktop
67 environment).
68
69 %description -l pl.UTF-8
70 Rozszerzenia zarządcy plików Nemo (używanego w środowisku graficznym
71 Cinnamon).
72
73 %package common
74 Summary:        Common files for Nemo file manager extensions
75 Summary(pl.UTF-8):      Wspólne pliki rozszerzeń zarządcy plików Nemo
76 Group:          X11/Applications
77
78 %description common
79 Common files for Nemo file manager extensions.
80
81 %description common -l pl.UTF-8
82 Wspólne pliki rozszerzeń zarządcy plików Nemo.
83
84 %package -n cinnamon-nemo-python
85 Summary:        Python scripting extension for Nemo
86 Summary(pl.UTF-8):      Rozszerzenie Nemo o obsługę skryptów Pythona
87 License:        GPL v2+
88 Group:          X11/Libraries
89 Requires:       cinnamon-nemo >= %{nemo_ver}
90 Requires:       python3-pygobject3 >= 3
91
92 %description -n cinnamon-nemo-python
93 Python scripting extension for Nemo.
94
95 %description -n cinnamon-nemo-python -l pl.UTF-8
96 Rozszerzenie Nemo o obsługę skryptów Pythona.
97
98 %package -n cinnamon-nemo-python-devel
99 Summary:        Development files for Python scripting extension for Nemo
100 Summary(pl.UTF-8):      Pliki programistyczne dla rozszerzenia Nemo o obsługę skryptów w Pythonie
101 License:        GPL v2+
102 Group:          X11/Development/Libraries
103 Requires:       cinnamon-nemo-python = %{version}-%{release}
104 Requires:       pkgconfig
105
106 %description -n cinnamon-nemo-python-devel
107 Development files for Python scripting extension for Nemo.
108
109 %description -n cinnamon-nemo-python-devel -l pl.UTF-8
110 Pliki programistyczne dla rozszerzenia Nemo o obsługę skryptów w
111 Pythonie.
112
113 %package -n cinnamon-nemo-python-apidocs
114 Summary:        API documentation for Nemo Python scripting extension
115 Summary(pl.UTF-8):      Dokumentacja API rozszerzenia Nemo do obsługi skryptów Pythona
116 Group:          Documentation
117
118 %description -n cinnamon-nemo-python-apidocs
119 API documentation for Nemo Python scripting extension.
120
121 %description -n cinnamon-nemo-python-apidocs -l pl.UTF-8
122 Dokumentacja API rozszerzenia Nemo do obsługi skryptów Pythona.
123
124 %package -n cinnamon-nemo-extension-audio-tab
125 Summary:        Audio tag information extension for Nemo
126 Summary(pl.UTF-8):      Rozszerzenie Nemo z informacjami o znacznikach w plikach dźwiękowych
127 License:        GPL v3+
128 Group:          X11/Applications
129 Requires:       %{name}-common = %{version}-%{release}
130 Requires:       cinnamon-nemo-python = %{version}-%{release}
131 Requires:       python3-mutagen
132 Requires:       python3-pygobject3 >= 3.0
133 BuildArch:      noarch
134
135 %description -n cinnamon-nemo-extension-audio-tab
136 audio-tab is Nemo extension to view audio tag information from the
137 properties tab.
138
139 %description -n cinnamon-nemo-extension-audio-tab -l pl.UTF-8
140 audio-tab to rozszerzenie Nemo do oglądania informacji o znacznikach w
141 plikach dźwiękowych z poziomu zakładki właściwości.
142
143 %package -n cinnamon-nemo-extension-compare
144 Summary:        Context menu comparison extension for Nemo file manager
145 Summary(pl.UTF-8):      Rozszerzenie zarządcy plików Nemo o porównywanie z menu kontekstowego
146 License:        GPL v3+
147 Group:          X11/Applications
148 Requires:       %{name}-common = %{version}-%{release}
149 Requires:       cinnamon-nemo-python = %{version}-%{release}
150 Requires:       meld
151 Requires:       python3-pygobject3 >= 3.0
152 BuildArch:      noarch
153
154 %description -n cinnamon-nemo-extension-compare
155 Simple Nemo file manager extension, inspired by the discontinued
156 diff-ext extension. It extends context menu by providing "Compare ..."
157 actions. Compare tool for different situations (one-on-one, three-way,
158 multi-compare) can be chosen by configurator tool.
159
160 %description -n cinnamon-nemo-extension-compare -l pl.UTF-8
161 Proste rozszerzenie zarządcy plików Nemo, zainspirowane porzuconym już
162 rozszerzeniem diff-ext. Rozszerza menu kontekstowe udostępniając akcje
163 "Porównaj ...". Narzędzie do porównywania w różnych sytuacjach (jeden
164 do jednego, trzech wersji, wielokrotnego) można wybrać w
165 konfiguratorze.
166
167 %package -n cinnamon-nemo-extension-dropbox
168 Summary:        Dropbox extension for Nemo file manager
169 Summary(pl.UTF-8):      Rozszerzenie Dropbox do zarządcy plików Nemo
170 License:        GPL v3+
171 Group:          X11/Applications
172 Requires(post,postun):  gtk-update-icon-cache
173 Requires:       cinnamon-nemo >= %{nemo_ver}
174 Requires:       glib2 >= 1:2.38
175 Requires:       hicolor-icon-theme
176
177 %description -n cinnamon-nemo-extension-dropbox
178 Dropbox extension for Nemo file manager.
179
180 %description -n cinnamon-nemo-extension-dropbox -l pl.UTF-8
181 Rozszerzenie Dropbox do zarządcy plików Nemo.
182
183 %package -n cinnamon-nemo-extension-emblems
184 Summary:        Emblem support for Nemo
185 Summary(pl.UTF-8):      Obsługa emblematów dla Nemo
186 License:        GPL v3+
187 Group:          X11/Applications
188 Requires:       %{name}-common = %{version}-%{release}
189 Requires:       cinnamon-nemo-python = %{version}-%{release}
190 Requires:       python3-pygobject3 >= 3.0
191 BuildArch:      noarch
192
193 %description -n cinnamon-nemo-extension-emblems
194 Restores the emblems functionality that used to be in GNOME 2.
195
196 %description -n cinnamon-nemo-extension-emblems -l pl.UTF-8
197 To rozszerzenie przywraca funkcjonalność emblematów, obecną w GNOME 2.
198
199 %package -n cinnamon-nemo-extension-fileroller
200 Summary:        File Roller extension for Nemo
201 Summary(pl.UTF-8):      Rozszerzenie File Roller dla Nemo
202 License:        GPL v2+
203 Group:          X11/Applications
204 Requires:       %{name}-common = %{version}-%{release}
205 Requires:       cinnamon-nemo >= %{nemo_ver}
206 Requires:       file-roller
207
208 %description -n cinnamon-nemo-extension-fileroller
209 This extension adds entries to the context menu in Nemo, which allow
210 you to make use of the compress and extract functions of the File
211 Roller archive manager.
212
213 %description -n cinnamon-nemo-extension-fileroller -l pl.UTF-8
214 To rozszerzenie dodane do menu kontekstowego w Nemo pozycje
215 pozwalające na wykorzystanie funkcji kompresji i rozpakowywania
216 zarządcy archiwów File Roller.
217
218 %package -n cinnamon-nemo-extension-gtkhash
219 Summary:        GtkHash extension for Nemo
220 Summary(pl.UTF-8):      Rozszerzenie GtkHash dla Nemo
221 License:        GPL v2+
222 Group:          X11/Applications
223 Requires(post,postun):  glib2 >= 1:2.38
224 Requires:       %{name}-common = %{version}-%{release}
225 Requires:       cinnamon-nemo >= %{nemo_ver}
226 Requires:       glib2 >= 1:2.38
227
228 %description -n cinnamon-nemo-extension-gtkhash
229 Nemo GtkHash extension for computing message digests or checksums.
230
231 %description -n cinnamon-nemo-extension-gtkhash -l pl.UTF-8
232 Rozszerzenie Nemo GtkHash do obliczania skrótów lub sum kontrolnych.
233
234 %package -n cinnamon-nemo-extension-image-converter
235 Summary:        Nemo extension to mass resize images
236 Summary(pl.UTF-8):      Rozszerzenie Nemo do masowej zmiany rozmiarów obrazów
237 License:        GPL v2+
238 Group:          X11/Applications
239 Requires:       %{name}-common = %{version}-%{release}
240 Requires:       cinnamon-nemo >= %{nemo_ver}
241 Requires:       ImageMagick
242
243 %description -n cinnamon-nemo-extension-image-converter
244 Adds a "Resize Images..." menu item to the context menu. This opens a
245 dialog where you set the desired image size and file name.
246
247 %description -n cinnamon-nemo-extension-image-converter -l pl.UTF-8
248 To rozszerzenie dodaje element menu kontekstowego "Zmień rozmiar
249 zdjęć...", otwierający okno dialogowe, gdzie można ustawić pożądany
250 rozmiar obrazu i nazwę pliku.
251
252 %package -n cinnamon-nemo-extension-media-columns
253 Summary:        Nemo Media Columns extension
254 Summary(pl.UTF-8):      Rozszerzenie Nemo Media Columns
255 License:        GPL v3
256 Group:          X11/Applications
257 Requires:       %{name}-common = %{version}-%{release}
258 Requires:       cinnamon-nemo-python = %{version}-%{release}
259 Requires:       gdk-pixbuf2 >= 2
260 Requires:       gexiv2 >= 0.10
261 Requires:       python3-PyPDF2
262 Requires:       python3-pygobject3 >= 3.0
263 Requires:       python3-mutagen
264 Requires:       python3-pillow
265 Requires:       python3-pymediainfo
266
267 %description -n cinnamon-nemo-extension-media-columns
268 This Nemo File Manager extension provides additional columns for the
269 List View related to media-type files.
270
271 %description -n cinnamon-nemo-extension-media-columns -l pl.UTF-8
272 To rozszerzenie zarządcy plików Nemo zapewnia na widoku listy
273 dodatkowe kolumny związane z plikami multimedialnymi.
274
275 %package -n cinnamon-nemo-extension-pastebin
276 Summary:        Pastebin extension for Nemo
277 Summary(pl.UTF-8):      Rozszerzenie Pastebin dla Nemo
278 License:        GPL v2+
279 Group:          X11/Applications
280 Requires(post,postun):  glib2 >= 1:2.38
281 Requires(post,postun):  gtk-update-icon-cache
282 Requires:       %{name}-common = %{version}-%{release}
283 Requires:       cinnamon-nemo-python = %{version}-%{release}
284 Requires:       hicolor-icon-theme
285 Requires:       libnotify >= 0.7
286 Requires:       pastebinit
287 Requires:       python3-pygobject3 >= 3.0
288 BuildArch:      noarch
289
290 %description -n cinnamon-nemo-extension-pastebin
291 nemo-pastebin is an extension for the Nemo file manager, which allows
292 users to send files to pastebins just a right-click away.
293
294 %description -n cinnamon-nemo-extension-pastebin -l pl.UTF-8
295 nemo-pastebin to rozszerzenie zarządcy plików Nemo, pozwalające
296 użytkownikom wysyłać pliki do pastebinów zwykłym kliknięciem prawym
297 przyciskiem.
298
299 %package -n cinnamon-nemo-extension-preview
300 Summary:        A quick previewer for Nemo
301 Summary(pl.UTF-8):      Szybki podgląd dla Nemo
302 License:        GPL v2+
303 Group:          X11/Applications
304 Requires:       %{name}-common = %{version}-%{release}
305 Requires:       cinnamon-nemo >= %{nemo_ver}
306
307 %description -n cinnamon-nemo-extension-preview
308 Nemo Preview is a GtkClutter and Javascript-based quick previewer for
309 Nemo. It is capable of previewing documents, PDFs, sound and video
310 files, some text files, and possibly others in the future.
311
312 %description -n cinnamon-nemo-extension-preview -l pl.UTF-8
313 Nemo Preview to oparty na bibliotece GtkClutter i JavaScripcie szybki
314 podgląd dla Nemo. Potrafi podglądać dokumenty, pliki PDF, dźwiękowe i
315 filmowe, niektóre pliki tekstowe, a w przyszłości inne.
316
317 %package -n cinnamon-nemo-extension-repairer
318 Summary:        Nemo extension for filename encoding repair
319 Summary(pl.UTF-8):      Rozszerzenie Nemo do naprawy kodowania nazw plików
320 License:        GPL v2+
321 Group:          X11/Applications
322 Requires:       %{name}-common = %{version}-%{release}
323 Requires:       cinnamon-nemo >= %{nemo_ver}
324
325 %description -n cinnamon-nemo-extension-repairer
326 nemo-filename-repairer is a Nemo extension which repairs filename
327 which uses wrong encoding in Nemo. This extension provides the context
328 menu for any file whose filename uses wrong encoding, so that you
329 cannot read the filename in Nemo. You can find a candidate for
330 filename in context menu or submenu. This extension also provides a
331 decoded name for URL encoded filename.
332
333 %description -n cinnamon-nemo-extension-repairer -l pl.UTF-8
334 nemo-filename-repairer to rozszerzenie Nemo służące do naprawiania
335 nazw plików, które w Nemo używają złego kodowania. Rozszerzenie
336 udostępnia menu kontekstowe dla każdego pliku ze złym kodowaniem,
337 pozwalając wybrać kandydata dla właściwej nazwy. Rozszerzenie
338 pozwala także dekodować nazwy z kodowania URL.
339
340 %package -n cinnamon-nemo-extension-seahorse
341 Summary:        PGP encryption and signing for Nemo
342 Summary(pl.UTF-8):      Szyfrowanie i podpisy PGP dla Nemo
343 License:        GPL v2+
344 Group:          X11/Applications
345 Requires(post,postun):  glib2 >= 1:2.38
346 Requires:       %{name}-common = %{version}-%{release}
347 Requires:       cinnamon-nemo >= %{nemo_ver}
348 Requires:       dbus-glib >= 0.78
349 Requires:       gcr >= 3.4.0
350 Requires:       glib2 >= 1:2.38
351 Requires:       gnupg2 >= 2.2
352 Requires:       gpgme >= 1.2.0
353 Requires:       libnotify >= 0.7.0
354 Requires:       seahorse
355
356 %description -n cinnamon-nemo-extension-seahorse
357 Seahorse Nemo is an extension for Nemo which allows encryption and
358 decryption of OpenPGP files using GnuPG.
359
360 %description -n cinnamon-nemo-extension-seahorse -l pl.UTF-8
361 Seahorse Nemo to rozszerzenie Nemo pozwalające na szyfrowanie i
362 odszyfrowywanie plików OpenPGP przy użyciu GnuPG.
363
364 %package -n cinnamon-nemo-extension-share
365 Summary:        Nemo extension to share folder using Samba
366 Summary(pl.UTF-8):      Rozszerzenie Nemo do współdzielenia folderów przy użyciu Samby
367 License:        GPL v2+
368 Group:          X11/Applications
369 Requires:       %{name}-common = %{version}-%{release}
370 Requires:       cinnamon-desktop >= 3.0.0
371 Requires:       cinnamon-nemo >= %{nemo_ver}
372 Requires:       glib2 >= 1:2.38
373 Requires:       samba-client
374
375 %description -n cinnamon-nemo-extension-share
376 Nemo Share allows you to quickly share a folder from the Nemo file
377 manager without requiring root access.
378
379 %description -n cinnamon-nemo-extension-share -l pl.UTF-8
380 Nemo Share pozwala na szybkie udostępnienie folderu z zarządcy plików
381 Nemo bez wymagania dostępu administratora.
382
383 %package -n cinnamon-nemo-extension-terminal
384 Summary:        Embedded terminal window for Nemo
385 Summary(pl.UTF-8):      Osadzone okno terminala dla Nemo
386 License:        GPL v3+
387 Group:          X11/Applications
388 Requires(post,postun):  glib2 >= 1:2.38
389 Requires:       %{name}-common = %{version}-%{release}
390 Requires:       cinnamon-nemo-python = %{version}-%{release}
391 Requires:       gtk+3 >= 3.8.4
392 Requires:       python3-pygobject3 >= 3.0
393 Requires:       vte >= 0.38
394 Requires:       xapps >= 2.2.3
395 BuildArch:      noarch
396
397 %description -n cinnamon-nemo-extension-terminal
398 Embedded terminal window for Nemo.
399
400 %description -n cinnamon-nemo-extension-terminal -l pl.UTF-8
401 Osadzone okno terminala dla Nemo.
402
403 %prep
404 %setup -q -n nemo-extensions-%{version} -a1
405 %patch0 -p1
406 %patch1 -p1
407
408 %build
409 cd nemo-python
410 %meson build \
411         -Dgtk_doc=true
412 %ninja_build -C build
413
414 cd ../nemo-audio-tab
415 %py3_build
416
417 cd ../nemo-compare
418 %py3_build
419
420 cd ../nemo-dropbox
421 %{__libtoolize}
422 %{__aclocal}
423 %{__autoconf}
424 %{__autoheader}
425 %{__automake}
426 %configure \
427         --disable-static
428 %{__make}
429
430 cd ../nemo-emblems
431 %py3_build
432
433 cd ../nemo-fileroller
434 %{__libtoolize}
435 %{__aclocal}
436 %{__autoconf}
437 %{__autoheader}
438 %{__automake}
439 %configure \
440         --disable-static
441 %{__make}
442
443 cd ../nemo-gtkhash
444 install -d m4
445 %{__glib_gettextize}
446 %{__intltoolize}
447 %{__libtoolize}
448 %{__aclocal} -I m4
449 %{__autoconf}
450 %{__autoheader}
451 %{__automake}
452 %configure \
453         --enable-linux-crypto \
454         --enable-nemo \
455         --disable-silent-rules \
456         --with-gtk=3.0
457 %{__make}
458
459 cd ../nemo-image-converter
460 install -d m4
461 %{__glib_gettextize}
462 %{__intltoolize}
463 %{__libtoolize}
464 %{__aclocal} -I m4
465 %{__autoconf}
466 %{__autoheader}
467 %{__automake}
468 %configure \
469         --disable-silent-rules
470 %{__make}
471
472 cd ../nemo-media-columns
473 %py3_build
474
475 cd ../nemo-pastebin
476 %py3_build
477
478 cd ../nemo-preview
479 %meson build
480 %ninja_build -C build
481
482 cd ../nemo-repairer
483 install -d m4
484 %{__glib_gettextize}
485 %{__intltoolize}
486 %{__libtoolize}
487 %{__aclocal} -I m4
488 %{__autoconf}
489 %{__autoheader}
490 %{__automake}
491 %configure \
492         --disable-static
493 %{__make}
494
495 cd ../nemo-seahorse
496 %{__glib_gettextize}
497 %{__intltoolize}
498 %{__libtoolize}
499 %{__aclocal} -I m4
500 %{__autoconf}
501 %{__autoheader}
502 %{__automake}
503 %configure \
504         GNUPG=/usr/bin/gpg \
505         --disable-gpg-check \
506         --disable-silent-rules
507 %{__make}
508
509 cd ../nemo-share
510 install -d m4
511 %{__glib_gettextize}
512 %{__intltoolize}
513 %{__libtoolize}
514 %{__aclocal} -I m4
515 %{__autoconf}
516 %{__autoheader}
517 %{__automake}
518 %configure \
519         --disable-static
520 %{__make}
521
522 cd ../nemo-terminal
523 %py3_build
524 cd ..
525
526 %{__make} -C cinnamon-translations-%{translations_version}
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530
531 %ninja_install -C nemo-python/build
532
533 install -d $RPM_BUILD_ROOT%{_examplesdir}/cinnamon-nemo-python-%{version}
534 cp -p nemo-python/examples/* $RPM_BUILD_ROOT%{_examplesdir}/cinnamon-nemo-python-%{version}
535
536 cd nemo-audio-tab
537 %py3_install
538
539 cd ../nemo-compare
540 %py3_install
541 cd ..
542
543 %{__make} -C nemo-dropbox install \
544         DESTDIR=$RPM_BUILD_ROOT
545
546 cd nemo-emblems
547 %py3_install
548 cd ..
549
550 %{__make} -C nemo-fileroller install \
551         DESTDIR=$RPM_BUILD_ROOT
552
553 %{__make} -C nemo-gtkhash install \
554         DESTDIR=$RPM_BUILD_ROOT
555
556 %{__make} -C nemo-image-converter install \
557         DESTDIR=$RPM_BUILD_ROOT
558
559 cd nemo-media-columns
560 %py3_install
561
562 cd ../nemo-pastebin
563 %py3_install
564 cd ..
565
566 %ninja_install -C nemo-preview/build
567
568 %{__make} -C nemo-repairer install \
569         DESTDIR=$RPM_BUILD_ROOT
570
571 %{__make} -C nemo-seahorse install \
572         DESTDIR=$RPM_BUILD_ROOT
573
574 %{__make} -C nemo-share install \
575         DESTDIR=$RPM_BUILD_ROOT
576
577 cd nemo-terminal
578 %py3_install
579 cd ..
580
581 # drop useless .la
582 %{__rm} $RPM_BUILD_ROOT%{_libdir}/nemo/extensions-3.0/libnemo-*.la
583 %{__rm} $RPM_BUILD_ROOT%{_libdir}/nemo/extensions-3.0/libgtkhash-properties.la
584
585 #%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nemo-python/
586
587 cd cinnamon-translations-%{translations_version}
588 for f in usr/share/locale/*/LC_MESSAGES/nemo-extensions.mo ; do
589         install -D "$f" "$RPM_BUILD_ROOT/$f"
590 done
591 cd ..
592
593 # not supported by glibc
594 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ie,zgh}
595
596 # common for nemo-audio-tab[py],nemo-compare[py],nemo-emblems[py],nemo-fileroller[so],nemo-gtkhash[so],nemo-image-converter[so],nemo-media-columns[py],nemo-pastebin[py],nemo-preview[so],nemo-repairer[so],nemo-seahorse[so],nemo-share[so],nemo-terminal[py]
597 %find_lang nemo-extensions
598 # not used(?), C part doesn't have defined domain, JS part uses "nemo-extensions" domain
599 %find_lang nemo-preview
600 # not used actually(?), sources have "nemo-extensions" domain hardcoded
601 %find_lang nemo-share
602
603 %clean
604 rm -rf $RPM_BUILD_ROOT
605
606 %post   -n cinnamon-nemo-extension-dropbox
607 %update_icon_cache hicolor
608
609 %postun -n cinnamon-nemo-extension-dropbox
610 %update_icon_cache hicolor
611
612 %post   -n cinnamon-nemo-extension-gtkhash
613 %glib_compile_schemas
614
615 %postun -n cinnamon-nemo-extension-gtkhash
616 %glib_compile_schemas
617
618 %post   -n cinnamon-nemo-extension-pastebin
619 %glib_compile_schemas
620 %update_icon_cache hicolor
621
622 %postun -n cinnamon-nemo-extension-pastebin
623 %glib_compile_schemas
624 %update_icon_cache hicolor
625
626 %post   -n cinnamon-nemo-extension-seahorse
627 %glib_compile_schemas
628
629 %postun -n cinnamon-nemo-extension-seahorse
630 %glib_compile_schemas
631
632 %post   -n cinnamon-nemo-extension-terminal
633 %glib_compile_schemas
634
635 %postun -n cinnamon-nemo-extension-terminal
636 %glib_compile_schemas
637
638 %files common -f nemo-extensions.lang
639 %defattr(644,root,root,755)
640 %doc README
641
642 %files -n cinnamon-nemo-python
643 %defattr(644,root,root,755)
644 %doc nemo-python/{AUTHORS,README}
645 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-python.so
646 %dir %{_datadir}/nemo-python
647 %dir %{_datadir}/nemo-python/extensions
648
649 %files -n cinnamon-nemo-python-devel
650 %defattr(644,root,root,755)
651 %{_pkgconfigdir}/nemo-python.pc
652
653 %files -n cinnamon-nemo-python-apidocs
654 %defattr(644,root,root,755)
655 %{_gtkdocdir}/nemo-python
656 %{_examplesdir}/cinnamon-nemo-python-%{version}
657
658 %files -n cinnamon-nemo-extension-audio-tab
659 %defattr(644,root,root,755)
660 %{_datadir}/nemo-python/extensions/nemo-audio-tab.py
661 %dir %{_datadir}/nemo-audio-tab
662 %{_datadir}/nemo-audio-tab/nemo-audio-tab.glade
663 %{py3_sitescriptdir}/nemo_audio_tab-%{version}-py*.egg-info
664
665 %files -n cinnamon-nemo-extension-compare
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/nemo-compare-preferences
668 %{_datadir}/nemo-python/extensions/nemo-compare.py
669 %dir %{_datadir}/nemo-compare
670 %{_datadir}/nemo-compare/nemo-compare-preferences.py
671 %{_datadir}/nemo-compare/utils.py*
672 %{py3_sitescriptdir}/nemo_compare-%{version}-py?.?.egg-info/
673
674 %files -n cinnamon-nemo-extension-dropbox
675 %defattr(644,root,root,755)
676 %doc nemo-dropbox/{AUTHORS,README}
677 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-dropbox.so
678 %{_datadir}/nemo-dropbox
679 %{_iconsdir}/hicolor/*x*/apps/dropbox.png
680
681 %files -n cinnamon-nemo-extension-emblems
682 %defattr(644,root,root,755)
683 %{_datadir}/nemo-python/extensions/nemo-emblems.py
684 %{py3_sitescriptdir}/nemo_emblems-%{version}-py?.?.egg-info/
685
686 %files -n cinnamon-nemo-extension-fileroller
687 %defattr(644,root,root,755)
688 %doc nemo-fileroller/README
689 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-fileroller.so
690
691 %files -n cinnamon-nemo-extension-gtkhash
692 %defattr(644,root,root,755)
693 %doc nemo-gtkhash/{AUTHORS,NEWS,README}
694 %attr(755,root,root) %{_bindir}/gtkhash
695 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libgtkhash-properties.so
696 %{_datadir}/glib-2.0/schemas/app.gtkhash.gschema.xml
697 %{_datadir}/glib-2.0/schemas/org.nemo.extensions.gtkhash.gschema.xml
698 %{_datadir}/nemo-gtkhash
699
700 %files -n cinnamon-nemo-extension-image-converter
701 %defattr(644,root,root,755)
702 %doc nemo-image-converter/{AUTHORS,NEWS,README}
703 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-image-converter.so
704 %{_datadir}/nemo-image-converter
705
706 %files -n cinnamon-nemo-extension-media-columns
707 %defattr(644,root,root,755)
708 %doc nemo-media-columns/{AUTHORS,MAINTAINERS,README}
709 %{_datadir}/nemo-python/extensions/nemo-media-columns.py
710 %{py3_sitescriptdir}/nemo_media_columns-%{version}-py*.egg-info
711
712 %files -n cinnamon-nemo-extension-pastebin
713 %defattr(644,root,root,755)
714 %doc nemo-pastebin/{NEWS,README}
715 %attr(755,root,root) %{_bindir}/nemo-pastebin-configurator
716 %{_datadir}/nemo-python/extensions/nemo-pastebin.py
717 %{_datadir}/glib-2.0/schemas/nemo-pastebin.gschema.xml
718 %{_datadir}/nemo-pastebin
719 %{py3_sitescriptdir}/nemo_pastebin-%{version}-py*.egg-info
720 %{_iconsdir}/hicolor/48x48/apps/nemo-pastebin.png
721 %{_iconsdir}/hicolor/scalable/apps/nemo-pastebin.svg
722
723 %files -n cinnamon-nemo-extension-preview -f nemo-preview.lang
724 %defattr(644,root,root,755)
725 %doc nemo-preview/{AUTHORS,README,TODO}
726 %attr(755,root,root) %{_bindir}/nemo-preview
727 %attr(755,root,root) %{_libexecdir}/nemo-preview-start
728 %dir %{_libdir}/nemo-preview
729 %attr(755,root,root) %{_libdir}/nemo-preview/libnemo-preview-1.0.so
730 %{_libdir}/nemo-preview/girepository-1.0
731 %dir %{_datadir}/nemo-preview
732 %{_datadir}/nemo-preview/gir-1.0
733 %{_datadir}/nemo-preview/js
734 %{_datadir}/dbus-1/services/org.nemo.Preview.service
735
736 %files -n cinnamon-nemo-extension-repairer
737 %defattr(644,root,root,755)
738 %doc nemo-repairer/{AUTHORS,NEWS,README}
739 %attr(755,root,root) %{_bindir}/nemo-filename-repairer
740 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-filename-repairer.so
741 %{_datadir}/nemo-filename-repairer
742
743 %files -n cinnamon-nemo-extension-seahorse
744 %defattr(644,root,root,755)
745 %doc nemo-seahorse/{AUTHORS,MAINTAINERS,NEWS,README}
746 %attr(755,root,root) %{_bindir}/nemo-seahorse-tool
747 %attr(755,root,root) %{_libdir}/nemo/extensions-3.0/libnemo-seahorse.so
748 %{_desktopdir}/nemo-seahorse-pgp-*.desktop
749 %{_datadir}/glib-2.0/schemas/org.nemo.plugins.seahorse*gschema.xml
750 %{_datadir}/nemo-seahorse
751 %{_mandir}/man1/nemo-seahorse-tool.1*
752
753 %files -n cinnamon-nemo-extension-share -f nemo-share.lang
754 %defattr(644,root,root,755)
755 %doc nemo-share/AUTHORS
756 %{_libdir}/nemo/extensions-3.0/libnemo-share.so
757 %{_datadir}/nemo-share
758 %{_datadir}/polkit-1/actions/org.nemo.share.samba_install.policy
759
760 %files -n cinnamon-nemo-extension-terminal
761 %defattr(644,root,root,755)
762 %doc nemo-terminal/{AUTHORS,README}
763 %attr(755,root,root) %{_bindir}/nemo-terminal-prefs
764 %{_datadir}/nemo-python/extensions/nemo_terminal.py
765 %{_datadir}/nemo-terminal
766 %{_datadir}/glib-2.0/schemas/org.nemo.extensions.nemo-terminal.gschema.xml
767 %{py3_sitescriptdir}/nemo_terminal-%{version}-py*.egg-info
This page took 0.165228 seconds and 3 git commands to generate.