]> git.pld-linux.org Git - packages/cinelerra.git/blob - cinelerra.spec
39f0646866f818e25f61cacfe61c834cccb2f1b5
[packages/cinelerra.git] / cinelerra.spec
1 #
2 # imho, it is pointless to build this app with system libraries until we
3 # start submitting patches to the author (is that possible with his
4 # current development and release strategy?)... anyway, the todo follows
5 # - make a patch for plugin dir in preferences.C, i.e.
6 #       get_exe_path(plugin_dir); -> sprintf(plugin_dir, PLUGIN_DIR);
7 #   or move plugins to %{_bindir}... otherwise you cannot run it 
8 # - review existing, but commented out patches
9 # - send the existing patches to the author (so we do not have to maintain
10 #   them forever)
11 # - build with set of current systems libs
12 # - quicktime4linux seems to be dead as separate library, use the provided
13 #   one
14 # - build guicast as separate, shared library to use in xmovie,
15 #   mix2005 and cinelerra
16 #
17 Summary:        Cinelerra - capturing, editing and production of audio/video material
18 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
19 Name:           cinelerra
20 Version:        4.4
21 Release:        0.1
22 License:        GPL v2+
23 Group:          X11/Applications
24 Source0:        http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.xz
25 # Source0-md5:  252d811546025470ae4d7fa31c1f52d4
26 Patch0:         %{name}-system-libs.patch
27 Patch1:         %{name}-strip.patch
28 Patch2:         %{name}-fontsdir.patch
29 Patch3:         %{name}-locale_h.patch
30 Patch4:         %{name}-guicast_bootstrap.patch
31 Patch6:         %{name}-libpng.patch
32 Patch7:         %{name}-ffmpeg.patch
33 Patch8:         %{name}-typo.patch
34 # see speech_tools package
35 Patch9:         %{name}-st.patch
36 URL:            http://www.heroinewarrior.com/cinelerra.php
37 BuildRequires:  OpenEXR-devel >= 1.6.1
38 BuildRequires:  OpenGL-GLU-devel
39 BuildRequires:  OpenGL-devel >= 2.0
40 BuildRequires:  alsa-lib-devel >= 1.0.8
41 BuildRequires:  bzip2-devel
42 #x#BuildRequires:       esound-devel
43 BuildRequires:  ffmpeg-devel >= 0.6
44 BuildRequires:  flac-devel >= 1.1.4
45 BuildRequires:  freetype-devel >= 2.1.4
46 BuildRequires:  lame-libs-devel >= 3.93.1
47 BuildRequires:  libavc1394-devel >= 0.5.1
48 BuildRequires:  libiec61883-devel >= 1.0.0
49 BuildRequires:  libmpeg3-devel >= 1.8
50 BuildRequires:  libraw1394-devel >= 1.2.0
51 BuildRequires:  libsndfile-devel >= 1.0.11
52 BuildRequires:  libstdc++-devel >= 5:3.2.2
53 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
54 BuildRequires:  libtiff-devel >= 3.5.7
55 BuildRequires:  libuuid-devel
56 %ifarch %{ix86}
57 BuildRequires:  nasm
58 %endif
59 #x#BuildRequires:       quicktime4linux-devel >= 2.3
60 BuildRequires:  xorg-lib-libX11-devel
61 BuildRequires:  xorg-lib-libXext-devel
62 BuildRequires:  xorg-lib-libXv-devel
63 BuildRequires:  xorg-lib-libXxf86vm-devel
64 Requires:       OpenEXR >= 1.6.1
65 Requires:       alsa-lib >= 1.0.8
66 Requires:       freetype >= 2.1.4
67 Requires:       libavc1394 >= 0.5.1
68 Requires:       libiec61883 >= 1.0.0
69 Requires:       libmpeg3 >= 1.8
70 Requires:       libraw1394 >= 1.2.0
71 Requires:       libsndfile >= 1.0.11
72 Requires:       libtheora >= 1.0-0.alpha4
73 #x#Requires:    quicktime4linux >= 2.3
74 Obsoletes:      bcast
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _noautostrip    .*/microtheme.plugin
78
79 %description
80 There are two types of moviegoers: producers who create new content,
81 going back over their content at future points for further refinement,
82 and consumers who want to acquire the content and watch it. Cinelerra
83 is not intended for consumers. Cinelerra has many features for
84 uncompressed content, high resolution processing, and compositing,
85 with very few shortcuts. Producers need these features because of the
86 need to retouch many generations of footage with alterations to the
87 format, which makes Cinelerra very complex.
88
89 Cinelerra was meant to be a Broadcast 2000 replacement.
90
91 %description -l pl.UTF-8
92 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
93 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
94 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
95 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
96 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
97 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
98 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
99 modyfikacji formatu, co czyni program bardzo złożonym.
100
101 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
102
103 %prep
104 %setup -q
105 #x#%patch0 -p1
106 #x#%patch1 -p1
107 %patch2 -p1
108 #x#%patch3 -p1
109 #x#%patch4 -p1
110 #x#%patch5 -p1
111 %patch6 -p0
112 #x#%patch7 -p1
113 %patch8 -p1
114 %patch9 -p0
115
116 #x## assume we have <linux/videodev2.h> and <linux/dvb/*> (present in llh)
117 #x#cat > hvirtual_config.h <<EOF
118 #x##define HAVE_VIDEO4LINUX2
119 #x##define HAVE_DVB
120 #x##define HAVE_GL
121 #x##define PACKAGE_STRING "cinelerra"
122 #x#EOF
123
124 #x#%{__rm} -r libmpeg3 quicktime \
125 #x#        thirdparty/{audiofile,esound,fftw-*,flac-*,freetype-*,ilmbase-*,libavc1394-*,libiec61883-*,libraw1394-*,libsndfile-*,libtheora-*,mjpegtools-*,openexr-*,tiff-*,uuid}
126
127 %build
128 export CFLAGS="%{rpmcflags}"
129 #x#%{__make} -f build/Makefile.toolame \
130 #x#    STRIP="true" \
131 #x#    GCC="%{__cc}"
132 #x#%{__make} -C mpeg2enc \
133 #x#    STRIP="true" \
134 #x#    CC="%{__cc}"
135 #x#%{__make} -C mplexlo \
136 #x#    STRIP="true" \
137 #x#    CC="%{__cc}"
138 #x#%{__make} -C guicast \
139 #x#    STRIP="true" \
140 #x#    GCC="%{__cc}" \
141 #x#    CC="%{__cxx}"
142 #x## cinelerra, defaulttheme and microtheme are stripped before running "bootstrap"
143 #x#%{__make} -C cinelerra \
144 #x#    STRIP="true" \
145 #x#    GCC="%{__cc}" \
146 #x#    CC="%{__cxx}" \
147 #x#    LINKER='%{__cxx} -o $(OUTPUT)'
148 #x#%{__make} -C plugins \
149 #x#    STRIP="true" \
150 #x#    CC="%{__cxx}" \
151
152 (
153     # to replace -ltermcap with -tncurses
154     cd thirdparty/speech_tools
155     rm ./config.cache
156     ./configure
157 )
158
159 ./configure
160 make
161
162 (
163     # to link with libva
164     cd cinelerra
165     g++ -o ../bin/cinelerra `cat x86_64/objs` -lva
166 )
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cinelerra}
171 cp -a bin/* $RPM_BUILD_ROOT%{_libdir}/cinelerra
172 mv $RPM_BUILD_ROOT{%{_libdir}/cinelerra,%{_bindir}}/cinelerra
173 rm -r $RPM_BUILD_ROOT%{_libdir}/cinelerra/c_flags
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc doc/{*.png,*.html,press} cinelerra/{CHANGELOG*,TODO}
181 %attr(755,root,root) %{_bindir}/cinelerra
182 %dir %{_libdir}/cinelerra
183 %attr(755,root,root) %{_libdir}/cinelerra/*.plugin
184 %{_libdir}/cinelerra/Cinelerra_plugins
This page took 0.076561 seconds and 2 git commands to generate.