]> git.pld-linux.org Git - packages/chrony.git/blob - chrony.spec
36b6ce2b9a4034479a7c1cdfdc3f70173794e645
[packages/chrony.git] / chrony.spec
1 %define         nettle_ver      3.4
2
3 Summary:        An NTP client/server
4 Name:           chrony
5 Version:        3.5
6 Release:        3
7 License:        GPL v2
8 Group:          Daemons
9 Source0:        http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
10 # Source0-md5:  5f66338bc940a9b51eede8f391e7bed3
11 Source1:        %{name}.conf
12 Source2:        %{name}.keys
13 Source3:        %{name}d.sysconfig
14 Source4:        %{name}d.init
15 Source5:        %{name}.logrotate
16 Patch0:         allow-clock_adjtime.patch
17 Patch1:         fix-seccomp-build.patch
18 URL:            http://chrony.tuxfamily.org/
19 BuildRequires:  asciidoc
20 BuildRequires:  bison
21 BuildRequires:  libcap-devel
22 BuildRequires:  libseccomp-devel
23 BuildRequires:  nettle-devel >= %{nettle_ver}
24 BuildRequires:  nss-devel
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.453
27 Requires(postun):       /usr/sbin/groupdel
28 Requires(postun):       /usr/sbin/userdel
29 Requires(pre):  /bin/id
30 Requires(pre):  /usr/bin/getgid
31 Requires(pre):  /usr/sbin/groupadd
32 Requires(pre):  /usr/sbin/useradd
33 Provides:       group(ntp)
34 Provides:       ntpdaemon
35 Provides:       user(ntp)
36 Requires:       nettle >= %{nettle_ver}
37 Obsoletes:      ntpdaemon
38 Conflicts:      logrotate < 3.8.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir     /etc/ntp
42
43 # assume gcc 3.4 has it
44 %if "%{cc_version}" >= "3.4"
45 %define         specflags       -pie -fpie
46 %endif
47
48 %description
49 A client/server for the Network Time Protocol, this program keeps your
50 computer's clock accurate. It was specially designed to support
51 systems with dial-up Internet connections, and also supports computers
52 in permanently connected environments.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 # NOTE: It is not autoconf generated configre
61 CC="%{__cc}" \
62 CFLAGS="%{rpmcflags} -Wmissing-prototypes -Wall" \
63 CPPFLAGS="%{rpmcppflags}" \
64 ./configure \
65         --enable-ntp-signd \
66         --enable-scfilter \
67         --prefix=%{_prefix} \
68         --sysconfdir=%{_sysconfdir} \
69         --docdir=%{_docdir} \
70         --with-ntp-era=$(date -d '1970-01-01 00:00:00+00:00' +'%s') \
71         --with-hwclockfile=%{_sysconfdir}/adjtime \
72         --with-sendmail=%{_sbindir}/sendmail \
73         --without-editline
74
75 %{__make} getdate all docs \
76         ADOC=asciidoc
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} \
81         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{lib/ntp,log/chrony}}
82
83 %{__make} install install-docs \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 rm -rf $RPM_BUILD_ROOT%{_docdir}
87
88 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
89 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
90 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
91 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
92 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
93
94 touch $RPM_BUILD_ROOT%{_localstatedir}/lib/ntp/{drift,rtc}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %pre
100 %groupadd -g 246 ntp
101 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
102
103 %post
104 /sbin/chkconfig --add chronyd
105 %service chronyd restart
106
107 %preun
108 if [ "$1" = "0" ]; then
109         %service chronyd stop
110         /sbin/chkconfig --del chronyd
111 fi
112
113 %postun
114 if [ "$1" = "0" ]; then
115         %userremove ntp
116         %groupremove ntp
117 fi
118
119 %files
120 %defattr(644,root,root,755)
121 %doc NEWS README FAQ examples/* doc/{faq,installation}.html
122 %dir %{_sysconfdir}
123 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
124 %attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
125 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
126 %config(noreplace) /etc/logrotate.d/chrony
127 %attr(754,root,root) /etc/rc.d/init.d/chronyd
128 %attr(755,root,root) %{_bindir}/chronyc
129 %attr(755,root,root) %{_sbindir}/chronyd
130 %{_mandir}/man1/chronyc.1*
131 %{_mandir}/man5/chrony.conf.5*
132 %{_mandir}/man8/chronyd.8*
133
134 %dir %attr(770,root,ntp) /var/lib/ntp
135 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
136 %attr(640,ntp,ntp) %ghost /var/lib/ntp/rtc
137
138 %dir %attr(770,ntp,ntp) /var/log/chrony
This page took 0.024945 seconds and 2 git commands to generate.