]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
link with libpci, because xserver loads it anyway
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_without  system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_without  system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 # TODO
38 # - check system sqlite linking problems
39 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
40 # - use_system_ssl (use_openssl: http://crbug.com/62803)
41 # - use_system_hunspell
42 # - use_system_stlport
43 # - other defaults: src/build/common.gypi
44 # - system usb-ids stuff
45
46 # NOTES:
47 # - mute BEEP mixer if you do not want to hear horrible system bell when
48 #   pressing home/end in url bar or more ^F search results on page.
49 # - space considerations:
50 #   - unpacked sources: ~566MiB
51 #   - built code: ~1.4GiB (x86_64/i686)
52 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
53 # - to look for new tarball, use update-source.sh script
54
55 # NOTE TO USERS:
56 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
57 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
58 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
59
60 %define         gyp_rev 1014
61 Summary:        A WebKit powered web browser
62 Name:           chromium-browser
63 Version:        25.0.1364.29
64 Release:        0.25
65 License:        BSD, LGPL v2+ (ffmpeg)
66 Group:          X11/Applications/Networking
67 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{version}.tar.gz
68 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
69 Source1:        %{name}.default
70 Source2:        %{name}.sh
71 Source3:        %{name}.desktop
72 Source5:        find-lang.sh
73 Source6:        update-source.sh
74 Source7:        clean-source.sh
75 Source8:        get-source.sh
76 Source9:        master_preferences.json
77 Patch1:         plugin-searchdirs.patch
78 #Patch2:                system-nspr.patch
79 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
80 Patch4:         path-libpdf.patch
81 Patch6:         get-webkit_revision.patch
82 Patch7:         dlopen_sonamed_gl.patch
83 Patch8:         chromium_useragent.patch.in
84 Patch9:         chromium-ppapi.patch
85 Patch10:        system-libxnvctrl.patch
86 # https://bugs.gentoo.org/show_bug.cgi?id=393471
87 # libjpeg-turbo >= 1.1.90 supports that feature
88 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
89 Patch12:        system-ffmpeg.patch
90 Patch13:        system-libpng.patch
91 Patch14:        system-opus.patch
92 Patch15:        nacl-build-irt.patch
93 Patch16:        nacl-linkingfix.patch
94 Patch18:        nacl-no-untar.patch
95 Patch19:        system-jsoncpp.patch
96 Patch23:        no-pnacl.patch
97 Patch24:        nacl-verbose.patch
98 Patch25:        gnome3-volume-control.patch
99 Patch26:        master-prefs-path.patch
100 Patch27:        tcmalloc-glibc2.16.patch
101 URL:            http://www.chromium.org/Home
102 %{?with_gconf:BuildRequires:    GConf2-devel}
103 BuildRequires:  alsa-lib-devel
104 BuildRequires:  atk-devel
105 BuildRequires:  bison
106 BuildRequires:  bzip2-devel
107 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
108 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
109 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
110 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
111 %{?with_cups:BuildRequires:     cups-devel}
112 BuildRequires:  elfutils-devel
113 BuildRequires:  expat-devel
114 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
115 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
116 BuildRequires:  fontconfig-devel
117 BuildRequires:  glib2-devel
118 BuildRequires:  gperf
119 BuildRequires:  gtest-devel
120 BuildRequires:  gtk+2-devel
121 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
122 %{?with_kerberos:BuildRequires: heimdal-devel}
123 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
124 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
125 BuildRequires:  libevent-devel
126 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
127 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
128 BuildRequires:  libicu-devel >= 4.6
129 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
130 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
131 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
132 BuildRequires:  libpng-devel
133 %{?with_selinux:BuildRequires:  libselinux-devel}
134 BuildRequires:  libstdc++-devel
135 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
136 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
137 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
138 BuildRequires:  libxml2-devel
139 BuildRequires:  libxslt-devel
140 %{?with_system_minizip:BuildRequires:   minizip-devel}
141 BuildRequires:  nspr-devel
142 BuildRequires:  nss-devel >= 1:3.12.3
143 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
144 BuildRequires:  pam-devel
145 BuildRequires:  pango-devel
146 BuildRequires:  pciutils-devel
147 BuildRequires:  perl-modules
148 BuildRequires:  pkgconfig
149 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
150 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
151 BuildRequires:  python
152 #BuildRequires: python-gyp >= 1-%{gyp_rev}
153 BuildRequires:  python-modules
154 BuildRequires:  python-ply
155 BuildRequires:  rpm >= 4.4.9-56
156 BuildRequires:  rpmbuild(macros) >= 1.453
157 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
158 BuildRequires:  sqlite3-devel >= 3.6.1
159 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
160 BuildRequires:  subversion
161 BuildRequires:  tar >= 1:1.22
162 BuildRequires:  udev-devel
163 BuildRequires:  util-linux
164 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
165 BuildRequires:  which
166 BuildRequires:  xorg-lib-libXScrnSaver-devel
167 BuildRequires:  xz
168 %{?with_system_yasm:BuildRequires:      yasm}
169 %{?with_system_zlib:BuildRequires:      zlib-devel}
170 Requires:       browser-plugins >= 2.0
171 Requires:       desktop-file-utils
172 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
173 Requires:       hicolor-icon-theme
174 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
175 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
176 Requires:       xdg-utils >= 1.0.2-4
177 Provides:       wwwbrowser
178 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
179 Obsoletes:      chromium-browser-inspector < 15.0.863.0
180 ExclusiveArch:  %{ix86} %{x8664} arm
181 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
182
183 %define         find_lang       sh find-lang.sh %{buildroot}
184
185 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
186 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
187
188 %if %{without debuginfo}
189 %define         _enable_debug_packages  0
190 %endif
191
192 %description
193 Chromium is an open-source browser project that aims to build a safer,
194 faster, and more stable way for all Internet users to experience the
195 web.
196
197 Chromium serves as a base for Google Chrome, which is Chromium
198 rebranded (name and logo) with very few additions such as usage
199 tracking and an auto-updater system.
200
201 %package l10n
202 Summary:        chromium-browser language packages
203 Group:          I18n
204 Requires:       %{name} = %{version}-%{release}
205
206 %description l10n
207 Chromium is an open-source browser project that aims to build a safer,
208 faster, and more stable way for all Internet users to experience the
209 web.
210
211 This package contains language packages for 50 languages:
212
213 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
214 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
215 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
216 zh-TW
217
218 %prep
219 %setup -q
220
221 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
222 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
223 . ./src/chrome/VERSION
224 ver=$MAJOR.$MINOR.$BUILD.$PATCH
225 test "$ver" = %{version}
226
227 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
228 test "$gyp_rev" = %{gyp_rev} || :
229
230 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
231
232 # add chromium and pld to useragent
233 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
234 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
235     -e 's/@BUILD_DIST_NAME@/PLD/g' \
236     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
237     < %{PATCH8} | %{__patch} -p1
238
239 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
240 ln -s %{SOURCE7} src
241
242 %patch1 -p1
243 %patch3 -p1
244 %patch4 -p1
245 %patch6 -p1
246 %patch7 -p1
247 %patch10 -p1
248 %patch15 -p1
249 cd src
250 %patch9 -p0
251 #%patch2 -p1
252 %{!?with_libjpegturbo:%patch11 -p0}
253 %patch12 -p1
254 %patch13 -p0
255 %patch14 -p2
256 %patch16 -p1
257 %patch19 -p1
258 %patch25 -p1
259 %patch27 -p1
260 cd ..
261 %patch18 -p1
262 %patch23 -p1
263 %patch24 -p1
264 %patch26 -p1
265
266 cd src
267
268 # Missing gyp files in tarball.
269 # https://code.google.com/p/chromium/issues/detail?id=144823
270 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
271         echo "tarball fixed, please remove workaround"
272         exit 1
273 fi
274
275 install -d chrome/test/data/nacl
276 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
277 {
278  'targets': [
279    {
280      'target_name': 'nacl_tests',
281      'type': 'none',
282    },
283  ],
284 }
285 EOF
286
287 sh -x clean-source.sh \
288         %{!?with_nacl:nacl=0} \
289         %{!?with_system_protobuf:protobuf=0} \
290         %{!?with_system_v8:v8=0} \
291         %{!?with_system_zlib:zlib=0} \
292         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
293         %{nil}
294
295 %build
296 cd src
297
298 %if %{with nacl}
299 rm -rf native_client/toolchain/linux_x86_newlib
300 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
301 # Make symlinks for NaCL
302 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
303
304 cd native_client/toolchain/linux_x86_newlib
305 ln -s x86_64-nacl/bin bin
306 cd x86_64-nacl/bin
307 __cc='%{__cc}'
308 if [ "${__cc#ccache}" != "$__cc" ]; then
309         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
310         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
311         %{__sed} -i -e '1i#!/bin/sh' gcc g++
312         chmod +x gcc g++
313 else
314         ln -s %{_bindir}/x86_64-nacl-gcc gcc
315         ln -s %{_bindir}/x86_64-nacl-g++ g++
316 fi
317 ln -s gcc x86_64-nacl-gcc
318 ln -s g++ x86_64-nacl-g++
319 ln -s %{_bindir}/x86_64-nacl-ar .
320 ln -s %{_bindir}/x86_64-nacl-ar ar
321 ln -s %{_bindir}/x86_64-nacl-as as
322 ln -s %{_bindir}/x86_64-nacl-ranlib .
323 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
324 ln -s %{_bindir}/x86_64-nacl-strip .
325 ln -s %{_bindir}/x86_64-nacl-strip strip
326 ln -s %{_prefix}/x86_64-nacl/lib ../lib
327 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
328 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
329 cd ../../../../..
330 fi
331 %endif
332
333 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
334 test -e Makefile || \
335         CC="%{__cc}" \
336         CXX="%{__cxx}" \
337         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
338         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
339         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
340 %{__python} build/gyp_chromium \
341         --format=make \
342         -Goutput_dir=../out \
343         build/all.gyp \
344 %ifarch %{ix86}
345         -Dtarget_arch=ia32 \
346 %endif
347 %ifarch %{x8664}
348         -Dtarget_arch=x64 \
349 %endif
350 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
351         -Dno_strict_aliasing=1 -Dgcc_version=44 \
352 %endif
353 %if %{with sandboxing}
354         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
355         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
356 %endif
357         %{!?debug:-Dwerror=} \
358         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
359         %{?with_shared_libs:-Dlibrary=shared_library} \
360         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
361         -Dinclude_tests=0 \
362 %if %{with nacl}
363         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
364         -Ddisable_glibc_untar=1 \
365         -Ddisable_newlib_untar=1 \
366         -Ddisable_glibc=1 \
367         -Ddisable_pnacl=1 \
368         -Dbuild_pnacl_newlib=0 \
369 %else
370         -Ddisable_pnacl_untar=1 \
371         -Ddisable_nacl=1 \
372 %endif
373         %{!?with_sse2:-Ddisable_sse2=1} \
374         %{?with_selinux:-Dselinux=1} \
375         -Dlinux_link_libpci=1 \
376         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
377         -Dlinux_use_gold_binary=0 \
378         -Dlinux_use_gold_flags=0 \
379         %{gyp_with cups} \
380         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
381         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
382         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
383         %{gyp_with pulseaudio} \
384         %{gyp_with system_ffmpeg} \
385         %{gyp_with system_flac} \
386         %{gyp_with system_harfbuzz} \
387         %{gyp_with system_libexif} \
388         %{gyp_with system_libmtp} \
389         %{gyp_with system_libsrtp} \
390         %{gyp_with system_libusb} \
391         %{gyp_with system_libvpx} \
392         %{gyp_with system_libwebp} \
393         %{gyp_with system_libxnvctrl} \
394         %{gyp_with system_minizip} \
395         %{gyp_with system_opus} \
396         %{gyp_with system_protobuf} \
397         %{gyp_with system_speex} \
398         %{gyp_with system_sqlite} \
399         %{gyp_with system_v8} \
400         %{gyp_with system_yasm} \
401         %{gyp_with system_zlib} \
402         -Duse_system_bzip2=1 \
403         -Duse_system_expat=1 \
404         -Duse_system_icu=1 \
405         -Duse_system_libevent=1 \
406         -Duse_system_libjpeg=1 \
407         -Duse_system_libpng=1 \
408         -Duse_system_libxml=1 \
409         -Duse_system_libxslt=1 \
410         -Duse_system_xdg_utils=1 \
411
412 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
413 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
414         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
415         %{?with_verbose:V=1} \
416         CC.host="%{__cc}" \
417         CXX.host="%{__cxx}" \
418         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
419
420 %install
421 rm -rf $RPM_BUILD_ROOT
422 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
423         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
424
425 cd out/%{!?debug:Release}%{?debug:Debug}
426 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
427 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
428 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
429 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
430 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
431 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
432 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
433 %if %{without system_ffmpeg}
434 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
435 %endif
436 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
437 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
438
439 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
440
441 %if %{with nacl}
442 # Install Native Client files on platforms that support it.
443 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
444 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
445 %ifarch %{x8664}
446 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
447 %endif
448 %ifarch %{ix86}
449 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
450 %endif
451 %endif
452
453 cd -
454
455 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
456         size=${icon##*/product_logo_}
457         size=${size%.png}
458
459         # this will skip non-numeric (22_mono_invert, 22_mono)
460         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
461         test -d "$dir" || continue
462
463         install -d $RPM_BUILD_ROOT$dir
464         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
465 done
466
467 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
468 # http://code.google.com/p/chromium/issues/detail?id=24507
469 gecko-mediaplayer*.so
470 EOF
471
472 # find locales
473 %find_lang %{name}.lang
474 # always package en-US
475 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %post
481 %update_icon_cache hicolor
482 %update_desktop_database
483 %update_browser_plugins
484
485 %postun
486 if [ "$1" = 0 ]; then
487         %update_icon_cache hicolor
488         %update_browser_plugins
489 fi
490
491 %files
492 %defattr(644,root,root,755)
493 %doc src/{AUTHORS,LICENSE}
494 %{_browserpluginsconfdir}/browsers.d/%{name}.*
495 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
496 %dir %{_sysconfdir}/%{name}
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
499 %attr(755,root,root) %{_bindir}/%{name}
500 %{_mandir}/man1/%{name}.1*
501 %{_desktopdir}/*.desktop
502 %{_iconsdir}/hicolor/*/apps/%{name}.png
503 %dir %{_libdir}/%{name}
504 %{_libdir}/%{name}/chrome*.pak
505 %{_libdir}/%{name}/content_resources.pak
506 %{_libdir}/%{name}/resources.pak
507 %dir %{_libdir}/%{name}/locales
508 %{_libdir}/%{name}/locales/en-US.pak
509 %dir %{_libdir}/%{name}/resources
510 %{_libdir}/%{name}/resources/inspector
511 %dir %{_libdir}/%{name}/themes
512 %dir %{_libdir}/%{name}/extensions
513 %dir %{_libdir}/%{name}/plugins
514 %attr(755,root,root) %{_libdir}/%{name}/%{name}
515 # These unique permissions are intentional and necessary for the sandboxing
516 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
517
518 # ffmpeg libs
519 %if %{without system_ffmpeg}
520 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
521 %endif
522
523 %if %{with nacl}
524 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
525 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
526 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
527 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
528 %endif
529
530 %files l10n -f %{name}.lang
531 %defattr(644,root,root,755)
This page took 0.086947 seconds and 3 git commands to generate.