]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
update stable to 24.0.1312.52
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_with             system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_with             system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 %if %{with nacl}
38 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42 #14:51:06 @baggins> as-needed will take care of unneeded lib
43 #14:52:03 @baggins> -lssp comes with gcc
44 %define         _ssp_cflags     %{nil}
45 %endif
46
47 # TODO
48 # - check system sqlite linking problems
49 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~574MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 # NOTE TO USERS:
65 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
67 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
68
69 %define         branch          24.0.1312
70 %define         basever         52
71 #define         patchver        %{nil}
72 %define         gyp_rev 1014
73 Summary:        A WebKit powered web browser
74 Name:           chromium-browser
75 Version:        %{branch}.%{!?patchver:%{basever}}%{?patchver}
76 Release:        0.24
77 License:        BSD, LGPL v2+ (ffmpeg)
78 Group:          X11/Applications/Networking
79 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
80 # Source0-md5:  6c467affd292ee9a9020ac91147969c8
81 %if "%{?patchver}" != ""
82 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
83 # Patch0-md5:   2f4e98e37053705fd86ffcb49f1f2247
84 %endif
85 Source1:        %{name}.default
86 Source2:        %{name}.sh
87 Source3:        %{name}.desktop
88 Source5:        find-lang.sh
89 Source6:        update-source.sh
90 Source7:        clean-source.sh
91 Source8:        get-source.sh
92 Source9:        master_preferences.json
93 Patch1:         plugin-searchdirs.patch
94 #Patch2:                system-nspr.patch
95 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
96 Patch4:         path-libpdf.patch
97 Patch6:         get-webkit_revision.patch
98 Patch7:         dlopen_sonamed_gl.patch
99 Patch8:         chromium_useragent.patch.in
100 Patch9:         chromium-ppapi.patch
101 Patch10:        system-libxnvctrl.patch
102 # https://bugs.gentoo.org/show_bug.cgi?id=393471
103 # libjpeg-turbo >= 1.1.90 supports that feature
104 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
105 Patch15:        nacl-build-irt.patch
106 Patch16:        nacl-linkingfix.patch
107 Patch18:        nacl-no-untar.patch
108 Patch19:        system-jsoncpp.patch
109 Patch22:        pulse_fix-157876.patch
110 Patch23:        no-pnacl.patch
111 Patch24:        nacl-verbose.patch
112 Patch25:        gnome3-volume-control.patch
113 Patch26:        master-prefs-path.patch
114 Patch27:        tcmalloc-glibc2.16.patch
115 URL:            http://www.chromium.org/Home
116 %{?with_gconf:BuildRequires:    GConf2-devel}
117 BuildRequires:  OpenGL-GLU-devel
118 BuildRequires:  alsa-lib-devel
119 BuildRequires:  atk-devel
120 BuildRequires:  bison
121 BuildRequires:  bzip2-devel
122 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
123 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
124 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
125 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
126 %{?with_cups:BuildRequires:     cups-devel}
127 BuildRequires:  dbus-glib-devel
128 BuildRequires:  expat-devel
129 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
130 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
131 BuildRequires:  flex
132 BuildRequires:  fontconfig-devel
133 BuildRequires:  glib2-devel
134 BuildRequires:  gperf
135 BuildRequires:  gtest-devel
136 BuildRequires:  gtk+2-devel
137 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
138 %{?with_kerberos:BuildRequires: heimdal-devel}
139 BuildRequires:  hicolor-icon-theme
140 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
141 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
142 BuildRequires:  libevent-devel
143 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
144 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
145 BuildRequires:  libicu-devel >= 4.6
146 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
147 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
148 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
149 BuildRequires:  libpng-devel
150 %{?with_selinux:BuildRequires:  libselinux-devel}
151 BuildRequires:  libstdc++-devel
152 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
153 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
154 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
155 BuildRequires:  libxml2-devel
156 BuildRequires:  libxslt-devel
157 BuildRequires:  lzma
158 %{?with_system_minizip:BuildRequires:   minizip-devel}
159 BuildRequires:  nspr-devel
160 BuildRequires:  nss-devel >= 1:3.12.3
161 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
162 BuildRequires:  pam-devel
163 BuildRequires:  pango-devel
164 BuildRequires:  perl-modules
165 BuildRequires:  pkgconfig
166 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
167 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
168 BuildRequires:  python
169 #BuildRequires: python-gyp >= 1-%{gyp_rev}
170 BuildRequires:  python-modules
171 BuildRequires:  rpm >= 4.4.9-56
172 BuildRequires:  rpmbuild(macros) >= 1.453
173 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
174 BuildRequires:  sqlite3-devel >= 3.6.1
175 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
176 BuildRequires:  subversion
177 BuildRequires:  tar >= 1:1.22
178 BuildRequires:  udev-devel
179 BuildRequires:  util-linux
180 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
181 BuildRequires:  which
182 BuildRequires:  xorg-lib-libXScrnSaver-devel
183 BuildRequires:  xorg-lib-libXt-devel
184 BuildRequires:  xorg-lib-libXtst-devel
185 BuildRequires:  xz
186 %{?with_system_yasm:BuildRequires:      yasm}
187 %{?with_system_zlib:BuildRequires:      zlib-devel}
188 Requires:       browser-plugins >= 2.0
189 Requires:       desktop-file-utils
190 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
191 Requires:       hicolor-icon-theme
192 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
193 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
194 Requires:       xdg-utils >= 1.0.2-4
195 Provides:       wwwbrowser
196 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
197 Obsoletes:      chromium-browser-inspector < 15.0.863.0
198 ExclusiveArch:  %{ix86} %{x8664} arm
199 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
200
201 %define         find_lang       sh find-lang.sh %{buildroot}
202
203 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
204 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
205
206 %if %{without debuginfo}
207 %define         _enable_debug_packages  0
208 %endif
209
210 %description
211 Chromium is an open-source browser project that aims to build a safer,
212 faster, and more stable way for all Internet users to experience the
213 web.
214
215 Chromium serves as a base for Google Chrome, which is Chromium
216 rebranded (name and logo) with very few additions such as usage
217 tracking and an auto-updater system.
218
219 %package l10n
220 Summary:        chromium-browser language packages
221 Group:          I18n
222 Requires:       %{name} = %{version}-%{release}
223
224 %description l10n
225 Chromium is an open-source browser project that aims to build a safer,
226 faster, and more stable way for all Internet users to experience the
227 web.
228
229 This package contains language packages for 50 languages:
230
231 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
232 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
233 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
234 zh-TW
235
236 %prep
237 %setup -qc
238 %if "%{?patchver}" != ""
239 cd %{name}-%{branch}.%{basever}
240 %patch0 -p1
241 cd ..
242 %endif
243 mv %{name}-%{branch}.%{basever}/src .
244
245 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
246 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
247 . ./src/chrome/VERSION
248 ver=$MAJOR.$MINOR.$BUILD.$PATCH
249 test "$ver" = %{version}
250
251 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
252 test "$gyp_rev" = %{gyp_rev} || :
253
254 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
255
256 # add chromium and pld to useragent
257 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
258 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
259     -e 's/@BUILD_DIST_NAME@/PLD/g' \
260     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
261     < %{PATCH8} | %{__patch} -p1
262
263 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
264 ln -s %{SOURCE7} src
265
266 %patch1 -p1
267 %patch3 -p1
268 %patch4 -p1
269 %patch6 -p1
270 %patch7 -p1
271 %patch15 -p1
272 cd src
273 %patch9 -p0
274 #%patch2 -p1
275 %{!?with_libjpegturbo:%patch11 -p0}
276 %patch16 -p1
277 %patch19 -p1
278 %patch22 -p1
279 %patch25 -p1
280 %patch27 -p1
281 cd ..
282 %patch18 -p1
283 %patch23 -p1
284 %patch24 -p1
285 %patch26 -p1
286
287 cd src
288
289 # Missing gyp files in tarball.
290 # https://code.google.com/p/chromium/issues/detail?id=144823
291 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
292         echo "tarball fixed, please remove workaround"
293         exit 1
294 fi
295
296 install -d chrome/test/data/nacl
297 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
298 {
299  'targets': [
300    {
301      'target_name': 'nacl_tests',
302      'type': 'none',
303    },
304  ],
305 }
306 EOF
307
308 sh -x clean-source.sh \
309         %{!?with_nacl:nacl=0} \
310         %{!?with_system_protobuf:protobuf=0} \
311         %{!?with_system_v8:v8=0} \
312         %{!?with_system_zlib:zlib=0} \
313         %{nil}
314
315 %build
316 cd src
317
318 %if %{with nacl}
319 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
320 # Make symlinks for NaCL
321 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
322
323 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
324 __cc='%{__cc}'
325 if [ "${__cc#ccache}" != "$__cc" ]; then
326         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
327         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
328         %{__sed} -i -e '1i#!/bin/sh' gcc g++
329         chmod +x gcc g++
330 else
331         ln -s %{_bindir}/x86_64-nacl-gcc gcc
332         ln -s %{_bindir}/x86_64-nacl-g++ g++
333 fi
334 ln -s %{_bindir}/x86_64-nacl-ar ar
335 ln -s %{_bindir}/x86_64-nacl-as as
336 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
337 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
338 ln -s %{_bindir}/x86_64-nacl-strip strip
339 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
340 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
341 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
342 cd ../../../../..
343 fi
344 %endif
345
346 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
347 test -e Makefile || %{__python} build/gyp_chromium \
348         --format=make \
349         -Goutput_dir=../out \
350         build/all.gyp \
351 %ifarch %{ix86}
352         -Dtarget_arch=ia32 \
353 %endif
354 %ifarch %{x8664}
355         -Dtarget_arch=x64 \
356 %endif
357 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
358         -Dno_strict_aliasing=1 -Dgcc_version=44 \
359 %endif
360 %if %{with sandboxing}
361         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
362         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
363 %endif
364         %{!?debug:-Dwerror=} \
365         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
366         %{?with_shared_libs:-Dlibrary=shared_library} \
367         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
368         -Dinclude_tests=0 \
369 %if %{with nacl}
370         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
371         -Ddisable_glibc_untar=1 \
372         -Ddisable_newlib_untar=1 \
373         -Ddisable_glibc=1 \
374         -Ddisable_pnacl=1 \
375         -Dbuild_pnacl_newlib=0 \
376 %else
377         -Ddisable_pnacl_untar=1 \
378         -Ddisable_nacl=1 \
379 %endif
380         %{!?with_sse2:-Ddisable_sse2=1} \
381         %{?with_selinux:-Dselinux=1} \
382         %{gyp_with cups} \
383         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
384         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
385         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
386         %{gyp_with pulseaudio} \
387         %{gyp_with system_ffmpeg} \
388         %{gyp_with system_flac} \
389         %{gyp_with system_harfbuzz} \
390         %{gyp_with system_libexif} \
391         %{gyp_with system_libmtp} \
392         %{gyp_with system_libsrtp} \
393         %{gyp_with system_libusb} \
394         %{gyp_with system_libvpx} \
395         %{gyp_with system_libwebp} \
396         %{gyp_with system_libxnvctrl} \
397         %{gyp_with system_minizip} \
398         %{gyp_with system_opus} \
399         %{gyp_with system_protobuf} \
400         %{gyp_with system_speex} \
401         %{gyp_with system_sqlite} \
402         %{gyp_with system_v8} \
403         %{gyp_with system_yasm} \
404         %{gyp_with system_zlib} \
405         -Duse_system_bzip2=1 \
406         -Duse_system_expat=1 \
407         -Duse_system_icu=1 \
408         -Duse_system_libevent=1 \
409         -Duse_system_libjpeg=1 \
410         -Duse_system_libpng=1 \
411         -Duse_system_libxml=1 \
412         -Duse_system_libxslt=1 \
413         -Duse_system_xdg_utils=1 \
414         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
415         -Dlinux_use_gold_binary=0 \
416         -Dlinux_use_gold_flags=0
417
418 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
419         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
420         %{?with_verbose:V=1} \
421         CC="%{__cc}" \
422         CXX="%{__cxx}" \
423         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
424         CC.host="%{__cc}" \
425         CXX.host="%{__cxx}" \
426         LDFLAGS.host="%{rpmldflags}" \
427         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
428         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
429
430 %install
431 rm -rf $RPM_BUILD_ROOT
432 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
433         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
434
435 cd out/%{!?debug:Release}%{?debug:Debug}
436 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
437 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
438 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
439 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
440 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
441 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
442 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
443 %if %{without system_ffmpeg}
444 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
445 %endif
446 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
447 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
448
449 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
450
451 %if %{with nacl}
452 # Install Native Client files on platforms that support it.
453 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
454 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
455 %ifarch %{x8664}
456 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
457 %endif
458 %ifarch %{ix86}
459 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
460 %endif
461 %endif
462
463 cd -
464
465 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
466         size=${icon##*/product_logo_}
467         size=${size%.png}
468
469         # this will skip non-numeric (22_mono_invert, 22_mono)
470         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
471         test -d "$dir" || continue
472
473         install -d $RPM_BUILD_ROOT$dir
474         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
475 done
476
477 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
478 # http://code.google.com/p/chromium/issues/detail?id=24507
479 gecko-mediaplayer*.so
480 EOF
481
482 # find locales
483 %find_lang %{name}.lang
484 # always package en-US
485 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
486
487 %clean
488 rm -rf $RPM_BUILD_ROOT
489
490 %post
491 %update_icon_cache hicolor
492 %update_desktop_database
493 %update_browser_plugins
494
495 %postun
496 if [ "$1" = 0 ]; then
497         %update_icon_cache hicolor
498         %update_browser_plugins
499 fi
500
501 %files
502 %defattr(644,root,root,755)
503 %doc src/{AUTHORS,LICENSE}
504 %{_browserpluginsconfdir}/browsers.d/%{name}.*
505 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
506 %dir %{_sysconfdir}/%{name}
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
508 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
509 %attr(755,root,root) %{_bindir}/%{name}
510 %{_mandir}/man1/%{name}.1*
511 %{_desktopdir}/*.desktop
512 %{_iconsdir}/hicolor/*/apps/%{name}.png
513 %dir %{_libdir}/%{name}
514 %{_libdir}/%{name}/chrome*.pak
515 %{_libdir}/%{name}/content_resources.pak
516 %{_libdir}/%{name}/resources.pak
517 %dir %{_libdir}/%{name}/locales
518 %{_libdir}/%{name}/locales/en-US.pak
519 %dir %{_libdir}/%{name}/resources
520 %{_libdir}/%{name}/resources/inspector
521 %dir %{_libdir}/%{name}/themes
522 %dir %{_libdir}/%{name}/extensions
523 %dir %{_libdir}/%{name}/plugins
524 %attr(755,root,root) %{_libdir}/%{name}/%{name}
525 # These unique permissions are intentional and necessary for the sandboxing
526 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
527
528 # ffmpeg libs
529 %if %{without system_ffmpeg}
530 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
531 %endif
532
533 %if %{with nacl}
534 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
535 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
536 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
537 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
538 %endif
539
540 %files l10n -f %{name}.lang
541 %defattr(644,root,root,755)
This page took 0.117718 seconds and 3 git commands to generate.