]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
88d27fa69b40e4aec0843ad48caef162c70b2af9
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_with             system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_with             system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 %if %{with nacl}
38 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42 #14:51:06 @baggins> as-needed will take care of unneeded lib
43 #14:52:03 @baggins> -lssp comes with gcc
44 %define         _ssp_cflags     %{nil}
45 %endif
46
47 # TODO
48 # - check system sqlite linking problems
49 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~574MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 # NOTE TO USERS:
65 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
67 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
68
69 %define         branch          24.0.1312
70 %define         basever         52
71 %define         patchver        69
72 %define         gyp_rev 1014
73 Summary:        A WebKit powered web browser
74 Name:           chromium-browser
75 %if "%{?patchver}" != ""
76 Version:        %{branch}.%{patchver}
77 %else
78 Version:        %{branch}.%{basever}
79 %endif
80 Release:        1
81 License:        BSD, LGPL v2+ (ffmpeg)
82 Group:          X11/Applications/Networking
83 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
84 # Source0-md5:  bcc3976e61b9ce715ba9c85d46df72f1
85 %if "%{?patchver}" != ""
86 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
87 # Patch0-md5:   130262d245d6833200cef43e61b641c2
88 %endif
89 Source1:        %{name}.default
90 Source2:        %{name}.sh
91 Source3:        %{name}.desktop
92 Source5:        find-lang.sh
93 Source6:        update-source.sh
94 Source7:        clean-source.sh
95 Source8:        get-source.sh
96 Source9:        master_preferences.json
97 Patch1:         plugin-searchdirs.patch
98 #Patch2:                system-nspr.patch
99 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
100 Patch4:         path-libpdf.patch
101 Patch6:         get-webkit_revision.patch
102 Patch7:         dlopen_sonamed_gl.patch
103 Patch8:         chromium_useragent.patch.in
104 Patch9:         chromium-ppapi.patch
105 Patch10:        system-libxnvctrl.patch
106 # https://bugs.gentoo.org/show_bug.cgi?id=393471
107 # libjpeg-turbo >= 1.1.90 supports that feature
108 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
109 Patch15:        nacl-build-irt.patch
110 Patch16:        nacl-linkingfix.patch
111 Patch18:        nacl-no-untar.patch
112 Patch19:        system-jsoncpp.patch
113 Patch22:        pulse_fix-157876.patch
114 Patch23:        no-pnacl.patch
115 Patch24:        nacl-verbose.patch
116 Patch25:        gnome3-volume-control.patch
117 Patch26:        master-prefs-path.patch
118 Patch27:        tcmalloc-glibc2.16.patch
119 URL:            http://www.chromium.org/Home
120 %{?with_gconf:BuildRequires:    GConf2-devel}
121 BuildRequires:  OpenGL-GLU-devel
122 BuildRequires:  alsa-lib-devel
123 BuildRequires:  atk-devel
124 BuildRequires:  bison
125 BuildRequires:  bzip2-devel
126 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
127 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
128 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
129 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
130 %{?with_cups:BuildRequires:     cups-devel}
131 BuildRequires:  dbus-glib-devel
132 BuildRequires:  elfutils-devel
133 BuildRequires:  expat-devel
134 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
135 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
136 BuildRequires:  flex
137 BuildRequires:  fontconfig-devel
138 BuildRequires:  glib2-devel
139 BuildRequires:  gperf
140 BuildRequires:  gtest-devel
141 BuildRequires:  gtk+2-devel
142 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
143 %{?with_kerberos:BuildRequires: heimdal-devel}
144 BuildRequires:  hicolor-icon-theme
145 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
146 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
147 BuildRequires:  libevent-devel
148 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
149 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
150 BuildRequires:  libicu-devel >= 4.6
151 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
152 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
153 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
154 BuildRequires:  libpng-devel
155 %{?with_selinux:BuildRequires:  libselinux-devel}
156 BuildRequires:  libstdc++-devel
157 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
158 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
159 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
160 BuildRequires:  libxml2-devel
161 BuildRequires:  libxslt-devel
162 BuildRequires:  lzma
163 %{?with_system_minizip:BuildRequires:   minizip-devel}
164 BuildRequires:  nspr-devel
165 BuildRequires:  nss-devel >= 1:3.12.3
166 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
167 BuildRequires:  pam-devel
168 BuildRequires:  pango-devel
169 BuildRequires:  perl-modules
170 BuildRequires:  pkgconfig
171 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
172 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
173 BuildRequires:  python
174 #BuildRequires: python-gyp >= 1-%{gyp_rev}
175 BuildRequires:  python-modules
176 BuildRequires:  python-ply
177 BuildRequires:  rpm >= 4.4.9-56
178 BuildRequires:  rpmbuild(macros) >= 1.453
179 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
180 BuildRequires:  sqlite3-devel >= 3.6.1
181 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
182 BuildRequires:  subversion
183 BuildRequires:  tar >= 1:1.22
184 BuildRequires:  udev-devel
185 BuildRequires:  util-linux
186 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
187 BuildRequires:  which
188 BuildRequires:  xorg-lib-libXScrnSaver-devel
189 BuildRequires:  xorg-lib-libXt-devel
190 BuildRequires:  xorg-lib-libXtst-devel
191 BuildRequires:  xz
192 %{?with_system_yasm:BuildRequires:      yasm}
193 %{?with_system_zlib:BuildRequires:      zlib-devel}
194 Requires:       browser-plugins >= 2.0
195 Requires:       desktop-file-utils
196 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
197 # requires any TTF font actually
198 Requires:       fonts-TTF-bitstream-vera
199 Requires:       hicolor-icon-theme
200 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
201 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
202 Requires:       lsb-release
203 Requires:       shared-mime-info
204 Requires:       xdg-utils >= 1.0.2-4
205 Provides:       wwwbrowser
206 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
207 Obsoletes:      chromium-browser-inspector < 15.0.863.0
208 ExclusiveArch:  %{ix86} %{x8664} arm
209 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
210
211 %define         find_lang       sh find-lang.sh %{buildroot}
212
213 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
214 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
215
216 %if %{without debuginfo}
217 %define         _enable_debug_packages  0
218 %endif
219
220 %description
221 Chromium is an open-source browser project that aims to build a safer,
222 faster, and more stable way for all Internet users to experience the
223 web.
224
225 Chromium serves as a base for Google Chrome, which is Chromium
226 rebranded (name and logo) with very few additions such as usage
227 tracking and an auto-updater system.
228
229 %package l10n
230 Summary:        chromium-browser language packages
231 Group:          I18n
232 Requires:       %{name} = %{version}-%{release}
233
234 %description l10n
235 Chromium is an open-source browser project that aims to build a safer,
236 faster, and more stable way for all Internet users to experience the
237 web.
238
239 This package contains language packages for 50 languages:
240
241 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
242 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
243 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
244 zh-TW
245
246 %prep
247 %setup -qc
248 %if "%{?patchver}" != ""
249 cd %{name}-%{branch}.%{basever}
250 %patch0 -p1
251 cd ..
252 %endif
253 mv %{name}-%{branch}.%{basever}/src .
254
255 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
256 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
257 . ./src/chrome/VERSION
258 ver=$MAJOR.$MINOR.$BUILD.$PATCH
259 test "$ver" = %{version}
260
261 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
262 test "$gyp_rev" = %{gyp_rev} || :
263
264 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
265
266 # add chromium and pld to useragent
267 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
268 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
269     -e 's/@BUILD_DIST_NAME@/PLD/g' \
270     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
271     < %{PATCH8} | %{__patch} -p1
272
273 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
274 ln -s %{SOURCE7} src
275
276 %patch1 -p1
277 %patch3 -p1
278 %patch4 -p1
279 %patch6 -p1
280 %patch7 -p1
281 %patch15 -p1
282 cd src
283 %patch9 -p0
284 #%patch2 -p1
285 %{!?with_libjpegturbo:%patch11 -p0}
286 %patch16 -p1
287 %patch19 -p1
288 %patch22 -p1
289 %patch25 -p1
290 %patch27 -p1
291 cd ..
292 %patch18 -p1
293 %patch23 -p1
294 %patch24 -p1
295 %patch26 -p1
296
297 cd src
298
299 # Missing gyp files in tarball.
300 # https://code.google.com/p/chromium/issues/detail?id=144823
301 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
302         echo "tarball fixed, please remove workaround"
303         exit 1
304 fi
305
306 install -d chrome/test/data/nacl
307 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
308 {
309  'targets': [
310    {
311      'target_name': 'nacl_tests',
312      'type': 'none',
313    },
314  ],
315 }
316 EOF
317
318 sh -x clean-source.sh \
319         %{!?with_nacl:nacl=0} \
320         %{!?with_system_protobuf:protobuf=0} \
321         %{!?with_system_v8:v8=0} \
322         %{!?with_system_zlib:zlib=0} \
323         %{nil}
324
325 %build
326 cd src
327
328 %if %{with nacl}
329 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
330 # Make symlinks for NaCL
331 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
332
333 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
334 __cc='%{__cc}'
335 if [ "${__cc#ccache}" != "$__cc" ]; then
336         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
337         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
338         %{__sed} -i -e '1i#!/bin/sh' gcc g++
339         chmod +x gcc g++
340 else
341         ln -s %{_bindir}/x86_64-nacl-gcc gcc
342         ln -s %{_bindir}/x86_64-nacl-g++ g++
343 fi
344 ln -s %{_bindir}/x86_64-nacl-ar ar
345 ln -s %{_bindir}/x86_64-nacl-as as
346 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
347 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
348 ln -s %{_bindir}/x86_64-nacl-strip strip
349 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
350 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
351 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
352 cd ../../../../..
353 fi
354 %endif
355
356 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
357 test -e Makefile || %{__python} build/gyp_chromium \
358         --format=make \
359         -Goutput_dir=../out \
360         build/all.gyp \
361 %ifarch %{ix86}
362         -Dtarget_arch=ia32 \
363 %endif
364 %ifarch %{x8664}
365         -Dtarget_arch=x64 \
366 %endif
367 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
368         -Dno_strict_aliasing=1 -Dgcc_version=44 \
369 %endif
370 %if %{with sandboxing}
371         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
372         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
373 %endif
374         %{!?debug:-Dwerror=} \
375         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
376         %{?with_shared_libs:-Dlibrary=shared_library} \
377         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
378         -Dinclude_tests=0 \
379 %if %{with nacl}
380         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
381         -Ddisable_glibc_untar=1 \
382         -Ddisable_newlib_untar=1 \
383         -Ddisable_glibc=1 \
384         -Ddisable_pnacl=1 \
385         -Dbuild_pnacl_newlib=0 \
386 %else
387         -Ddisable_pnacl_untar=1 \
388         -Ddisable_nacl=1 \
389 %endif
390         %{!?with_sse2:-Ddisable_sse2=1} \
391         %{?with_selinux:-Dselinux=1} \
392         %{gyp_with cups} \
393         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
394         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
395         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
396         %{gyp_with pulseaudio} \
397         %{gyp_with system_ffmpeg} \
398         %{gyp_with system_flac} \
399         %{gyp_with system_harfbuzz} \
400         %{gyp_with system_libexif} \
401         %{gyp_with system_libmtp} \
402         %{gyp_with system_libsrtp} \
403         %{gyp_with system_libusb} \
404         %{gyp_with system_libvpx} \
405         %{gyp_with system_libwebp} \
406         %{gyp_with system_libxnvctrl} \
407         %{gyp_with system_minizip} \
408         %{gyp_with system_opus} \
409         %{gyp_with system_protobuf} \
410         %{gyp_with system_speex} \
411         %{gyp_with system_sqlite} \
412         %{gyp_with system_v8} \
413         %{gyp_with system_yasm} \
414         %{gyp_with system_zlib} \
415         -Duse_system_bzip2=1 \
416         -Duse_system_expat=1 \
417         -Duse_system_icu=1 \
418         -Duse_system_libevent=1 \
419         -Duse_system_libjpeg=1 \
420         -Duse_system_libpng=1 \
421         -Duse_system_libxml=1 \
422         -Duse_system_libxslt=1 \
423         -Duse_system_xdg_utils=1 \
424         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
425         -Dlinux_use_gold_binary=0 \
426         -Dlinux_use_gold_flags=0
427
428 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
429         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
430         %{?with_verbose:V=1} \
431         CC="%{__cc}" \
432         CXX="%{__cxx}" \
433         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
434         CC.host="%{__cc}" \
435         CXX.host="%{__cxx}" \
436         LDFLAGS.host="%{rpmldflags}" \
437         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
438         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
439
440 %install
441 rm -rf $RPM_BUILD_ROOT
442 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
443         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
444
445 cd out/%{!?debug:Release}%{?debug:Debug}
446 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
447 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
448 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
449 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
450 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
451 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
452 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
453 %if %{without system_ffmpeg}
454 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
455 %endif
456 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
457 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
458
459 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
460
461 %if %{with nacl}
462 # Install Native Client files on platforms that support it.
463 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
464 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
465 %ifarch %{x8664}
466 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
467 %endif
468 %ifarch %{ix86}
469 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
470 %endif
471 %endif
472
473 cd -
474
475 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
476         size=${icon##*/product_logo_}
477         size=${size%.png}
478
479         # this will skip non-numeric (22_mono_invert, 22_mono)
480         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
481         test -d "$dir" || continue
482
483         install -d $RPM_BUILD_ROOT$dir
484         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
485 done
486
487 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
488 # http://code.google.com/p/chromium/issues/detail?id=24507
489 gecko-mediaplayer*.so
490 EOF
491
492 # find locales
493 %find_lang %{name}.lang
494 # always package en-US
495 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
496
497 %clean
498 rm -rf $RPM_BUILD_ROOT
499
500 %post
501 %update_icon_cache hicolor
502 %update_desktop_database
503 %update_browser_plugins
504
505 %postun
506 if [ "$1" = 0 ]; then
507         %update_icon_cache hicolor
508         %update_browser_plugins
509 fi
510
511 %files
512 %defattr(644,root,root,755)
513 %doc src/{AUTHORS,LICENSE}
514 %{_browserpluginsconfdir}/browsers.d/%{name}.*
515 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
516 %dir %{_sysconfdir}/%{name}
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
519 %attr(755,root,root) %{_bindir}/%{name}
520 %{_mandir}/man1/%{name}.1*
521 %{_desktopdir}/*.desktop
522 %{_iconsdir}/hicolor/*/apps/%{name}.png
523 %dir %{_libdir}/%{name}
524 %{_libdir}/%{name}/chrome*.pak
525 %{_libdir}/%{name}/content_resources.pak
526 %{_libdir}/%{name}/resources.pak
527 %dir %{_libdir}/%{name}/locales
528 %{_libdir}/%{name}/locales/en-US.pak
529 %dir %{_libdir}/%{name}/resources
530 %{_libdir}/%{name}/resources/inspector
531 %dir %{_libdir}/%{name}/themes
532 %dir %{_libdir}/%{name}/extensions
533 %dir %{_libdir}/%{name}/plugins
534 %attr(755,root,root) %{_libdir}/%{name}/%{name}
535 # These unique permissions are intentional and necessary for the sandboxing
536 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
537
538 # ffmpeg libs
539 %if %{without system_ffmpeg}
540 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
541 %endif
542
543 %if %{with nacl}
544 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
545 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
546 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
547 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
548 %endif
549
550 %files l10n -f %{name}.lang
551 %defattr(644,root,root,755)
This page took 0.054352 seconds and 2 git commands to generate.