]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
use GNOME3 gnome-volume-control in Th
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  ffmpegsumo              # build with ffmpegsumo
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libusb   # system libusb-1
19 %bcond_without  system_libwebp  # system libwebp
20 %bcond_without  system_speex    # system speex
21 %bcond_with             system_sqlite   # system sqlite
22 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
23 %bcond_with             system_v8               # system v8
24 %bcond_without  system_vpx              # system vpx
25 %bcond_without  system_yasm             # system yasm
26 # system zlib disabled because of mixed-source.patch
27 # https://code.google.com/p/chromium/issues/detail?id=143623
28 %bcond_with             system_zlib             # system zlib
29 %bcond_with             tcmalloc                # use tcmalloc
30 %bcond_without  verbose                 # verbose build (V=1)
31
32 %if %{with nacl}
33 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37 #14:51:06 @baggins> as-needed will take care of unneeded lib
38 #14:52:03 @baggins> -lssp comes with gcc
39 %define         _ssp_cflags     %{nil}
40 %endif
41
42 # TODO
43 # - check system sqlite linking problems
44 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
45 # - use_system_ssl (use_openssl: http://crbug.com/62803)
46 # - use_system_ffmpeg && build_ffmpegsumo
47 # - use_system_hunspell
48 # - use_system_stlport
49 # - other defaults: src/build/common.gypi
50
51 # NOTES:
52 # - mute BEEP mixer if you do not want to hear horrible system bell when
53 #   pressing home/end in url bar or more ^F search results on page.
54 # - build -bp: 1.2G
55 # - build i686: -bc: 2.7G; -bb: ~1.0GB
56 # - build x86_64: ~1.9G
57 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
58 # - to look for new tarball, use update-source.sh script
59
60 # NOTE TO USERS:
61 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
62 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
64
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 Version:        23.0.1271.64
69 Release:        2
70 License:        BSD, LGPL v2+ (ffmpeg)
71 Group:          X11/Applications/Networking
72 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
73 # Source0-md5:  6c467affd292ee9a9020ac91147969c8
74 Source1:        %{name}.default
75 Source2:        %{name}.sh
76 Source3:        %{name}.desktop
77 Source5:        find-lang.sh
78 Source6:        update-source.sh
79 Source7:        clean-source.sh
80 Source8:        get-source.sh
81 #Patch0:                system-libs.patch
82 Patch1:         plugin-searchdirs.patch
83 Patch2:         gyp-system-minizip.patch
84 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
85 Patch4:         path-libpdf.patch
86 Patch5:         options-support.patch
87 Patch6:         get-webkit_revision.patch
88 Patch7:         dlopen_sonamed_gl.patch
89 Patch8:         chromium_useragent.patch.in
90 Patch9:         chromium-ppapi.patch
91 # https://bugs.gentoo.org/show_bug.cgi?id=393471
92 # libjpeg-turbo >= 1.1.90 supports that feature
93 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
94 Patch15:        nacl-build-irt.patch
95 Patch16:        nacl-linkingfix.patch
96 Patch17:        system-icu.patch
97 Patch18:        nacl-no-untar.patch
98 Patch19:        system-jsoncpp.patch
99 Patch20:        system-speex.patch
100 Patch21:        system-srtp.patch
101 Patch22:        gnome3-volume-control.patch
102 URL:            http://www.chromium.org/Home
103 %{?with_gconf:BuildRequires:    GConf2-devel}
104 BuildRequires:  OpenGL-GLU-devel
105 BuildRequires:  alsa-lib-devel
106 BuildRequires:  atk-devel
107 BuildRequires:  bison
108 BuildRequires:  bzip2-devel
109 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
110 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
111 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
112 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
113 %{?with_cups:BuildRequires:     cups-devel}
114 BuildRequires:  dbus-glib-devel
115 BuildRequires:  expat-devel
116 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
117 BuildRequires:  flex
118 BuildRequires:  fontconfig-devel
119 BuildRequires:  glib2-devel
120 BuildRequires:  gperf
121 BuildRequires:  gtk+2-devel
122 %{?with_kerberos:BuildRequires: heimdal-devel}
123 BuildRequires:  hicolor-icon-theme
124 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
125 BuildRequires:  libevent-devel
126 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
127 BuildRequires:  libicu-devel >= 4.6
128 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
129 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
130 BuildRequires:  libpng-devel
131 %{?with_selinux:BuildRequires:  libselinux-devel}
132 BuildRequires:  libstdc++-devel
133 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
134 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
135 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
136 BuildRequires:  libxml2-devel
137 BuildRequires:  libxslt-devel
138 BuildRequires:  lzma
139 BuildRequires:  minizip-devel
140 BuildRequires:  nspr-devel
141 BuildRequires:  nss-devel >= 1:3.12.3
142 BuildRequires:  pam-devel
143 BuildRequires:  pango-devel
144 BuildRequires:  perl-modules
145 BuildRequires:  pkgconfig
146 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
147 BuildRequires:  python
148 #BuildRequires: python-gyp >= 1-%{gyp_rev}
149 BuildRequires:  python-modules
150 BuildRequires:  rpm >= 4.4.9-56
151 BuildRequires:  rpmbuild(macros) >= 1.453
152 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
153 BuildRequires:  sqlite3-devel >= 3.6.1
154 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
155 BuildRequires:  subversion
156 BuildRequires:  tar >= 1:1.22
157 BuildRequires:  udev-devel
158 BuildRequires:  util-linux
159 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
160 BuildRequires:  which
161 BuildRequires:  xorg-lib-libXScrnSaver-devel
162 BuildRequires:  xorg-lib-libXt-devel
163 BuildRequires:  xorg-lib-libXtst-devel
164 BuildRequires:  xz
165 %{?with_system_yasm:BuildRequires:      yasm}
166 %{?with_system_zlib:BuildRequires:      zlib-devel}
167 Requires:       browser-plugins >= 2.0
168 Requires:       desktop-file-utils
169 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
170 Requires:       hicolor-icon-theme
171 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
172 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
173 Requires:       xdg-utils >= 1.0.2-4
174 Provides:       wwwbrowser
175 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
176 Obsoletes:      chromium-browser-inspector < 15.0.863.0
177 ExclusiveArch:  %{ix86} %{x8664} arm
178 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
179
180 %define         find_lang       sh find-lang.sh %{buildroot}
181
182 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
183 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
184
185 %if %{without debuginfo}
186 %define         _enable_debug_packages  0
187 %endif
188
189 %description
190 Chromium is an open-source browser project that aims to build a safer,
191 faster, and more stable way for all Internet users to experience the
192 web.
193
194 Chromium serves as a base for Google Chrome, which is Chromium
195 rebranded (name and logo) with very few additions such as usage
196 tracking and an auto-updater system.
197
198 %package l10n
199 Summary:        chromium-browser language packages
200 Group:          I18n
201 Requires:       %{name} = %{version}-%{release}
202
203 %description l10n
204 Chromium is an open-source browser project that aims to build a safer,
205 faster, and more stable way for all Internet users to experience the
206 web.
207
208 This package contains language packages for 50 languages:
209
210 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
211 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
212 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
213 zh-TW
214
215 %prep
216 %setup -q
217
218 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
219 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
220 . ./src/chrome/VERSION
221 ver=$MAJOR.$MINOR.$BUILD.$PATCH
222 test "$ver" = %{version}
223
224 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
225 test "$gyp_rev" = %{gyp_rev} || :
226
227 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
228
229 # add chromium and pld to useragent
230 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
231 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
232     -e 's/@BUILD_DIST_NAME@/PLD/g' \
233     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
234     < %{PATCH8} | %{__patch} -p1
235
236 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
237 ln -s %{SOURCE7} src
238
239 #%patch0 -p1
240 %patch1 -p1
241 %patch2 -p1
242 %patch3 -p1
243 %patch4 -p1
244 %patch5 -p1
245 %patch6 -p1
246 %patch7 -p1
247 %patch15 -p1
248 cd src
249 %patch9 -p0
250 %{!?with_libjpegturbo:%patch11 -p0}
251 %patch16 -p1
252 %patch17 -p0
253 %patch19 -p1
254 %patch21 -p1
255 %patch22 -p1
256 cd ..
257 %patch18 -p1
258 %patch20 -p1
259
260 cd src
261
262 # Missing gyp files in tarball.
263 # https://code.google.com/p/chromium/issues/detail?id=144823
264 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
265         echo "tarball fixed, please remove workaround"
266         exit 1
267 fi
268
269 install -d chrome/test/data/nacl
270 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
271 {
272  'targets': [
273    {
274      'target_name': 'nacl_tests',
275      'type': 'none',
276    },
277  ],
278 }
279 EOF
280
281 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
282
283 %build
284 cd src
285
286 %if %{with nacl}
287 rm -rf native_client/toolchain/linux_x86_newlib
288 # Make symlinks for nacl
289 cd native_client/toolchain
290 install -d linux_x86_newlib/x86_64-nacl/bin
291 install -d linux_x86_newlib/x86_64-nacl/lib
292 install -d linux_x86_newlib/x86_64-nacl/lib32
293 install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
294 install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
295 install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
296 # link newlib toolchain to glibc as well, see gentoo bug #417019
297 #ln -s linux_x86_newlib linux_x86
298 cd linux_x86_newlib/x86_64-nacl/bin
299 ln -s %{_bindir}/x86_64-nacl-gcc gcc
300 ln -s %{_bindir}/x86_64-nacl-g++ g++
301 ln -s %{_bindir}/x86_64-nacl-ar ar
302 ln -s %{_bindir}/x86_64-nacl-as as
303 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
304 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
305 ln -s %{_bindir}/x86_64-nacl-strip strip
306 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
307 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
308 cd ../nacl/include
309 for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
310         ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
311 done
312 cd ../../../../../..
313 %endif
314
315 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
316 %ifarch %{ix86}
317         -Dtarget_arch=ia32 \
318 %endif
319 %ifarch %{x8664}
320         -Dtarget_arch=x64 \
321 %endif
322 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
323         -Dno_strict_aliasing=1 -Dgcc_version=44 \
324 %endif
325 %if %{with sandboxing}
326         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
327         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
328 %endif
329         %{!?debug:-Dwerror=} \
330         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
331         %{?with_shared_libs:-Dlibrary=shared_library} \
332         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
333         -Dffmpeg_branding=Chrome \
334         -Dproprietary_codecs=1 \
335 %if %{with nacl}
336         -Ddisable_glibc=1 \
337         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
338         -Ddisable_glibc_untar=1 \
339         -Ddisable_newlib_untar=1 \
340         -Ddisable_pnacl_untar=1 \
341 %else
342         -Ddisable_nacl=1 \
343 %endif
344         -Ddisable_pnacl=1 \
345         %{!?with_sse2:-Ddisable_sse2=1} \
346         %{?with_selinux:-Dselinux=1} \
347         %{gyp_with cups} \
348         %{gyp_with gconf} \
349         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
350         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
351         %{gyp_with pulseaudio} \
352         %{gyp_with system_flac} \
353         %{gyp_with system_libusb} \
354         %{gyp_with system_libwebp} \
355         %{gyp_with system_speex} \
356         %{gyp_with system_sqlite} \
357         %{gyp_with system_v8} \
358         %{gyp_with system_vpx} \
359         %{gyp_with system_yasm} \
360         %{gyp_with system_zlib} \
361         -Duse_system_bzip2=1 \
362         -Duse_system_icu=1 \
363         -Duse_system_libevent=1 \
364         -Duse_system_libjpeg=1 \
365         -Duse_system_libpng=1 \
366         -Duse_system_libxml=1 \
367         -Duse_system_libxslt=1 \
368         -Duse_system_xdg_utils=1 \
369         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
370         -Dlinux_use_gold_binary=0 \
371         -Dlinux_use_gold_flags=0
372
373 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
374         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
375         %{?with_verbose:V=1} \
376         CC="%{__cc}" \
377         CXX="%{__cxx}" \
378         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
379         CC.host="%{__cc}" \
380         CXX.host="%{__cxx}" \
381         LDFLAGS.host="%{rpmldflags}" \
382         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
383         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
388         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
389
390 cd src/out/%{!?debug:Release}%{?debug:Debug}
391 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
392 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
393 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
394 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
395 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
396 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
397 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
398 %if %{with ffmpegsumo}
399 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
400 %endif
401 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
402
403 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
404
405 %if %{with nacl}
406 # Install Native Client files on platforms that support it.
407 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
408 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
409 %ifarch %{x8664}
410 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
411 %endif
412 %ifarch %{ix86}
413 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
414 %endif
415 %endif
416
417 cd -
418
419 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
420         size=${icon##*/product_logo_}
421         size=${size%.png}
422
423         # this will skip non-numeric (22_mono_invert, 22_mono)
424         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
425         test -d "$dir" || continue
426
427         install -d $RPM_BUILD_ROOT$dir
428         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
429 done
430
431 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
432 # http://code.google.com/p/chromium/issues/detail?id=24507
433 gecko-mediaplayer*.so
434 EOF
435
436 # find locales
437 %find_lang %{name}.lang
438 # always package en-US
439 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %post
445 %update_icon_cache hicolor
446 %update_desktop_database
447 %update_browser_plugins
448
449 %postun
450 if [ "$1" = 0 ]; then
451         %update_icon_cache hicolor
452         %update_browser_plugins
453 fi
454
455 %files
456 %defattr(644,root,root,755)
457 %{_browserpluginsconfdir}/browsers.d/%{name}.*
458 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
459 %dir %{_sysconfdir}/%{name}
460 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
461 %attr(755,root,root) %{_bindir}/%{name}
462 %{_mandir}/man1/%{name}.1*
463 %{_desktopdir}/*.desktop
464 %{_iconsdir}/hicolor/*/apps/%{name}.png
465 %dir %{_libdir}/%{name}
466 %{_libdir}/%{name}/chrome*.pak
467 %{_libdir}/%{name}/content_resources.pak
468 %{_libdir}/%{name}/resources.pak
469 %dir %{_libdir}/%{name}/locales
470 %{_libdir}/%{name}/locales/en-US.pak
471 %dir %{_libdir}/%{name}/resources
472 %{_libdir}/%{name}/resources/inspector
473 %dir %{_libdir}/%{name}/themes
474 %dir %{_libdir}/%{name}/extensions
475 %dir %{_libdir}/%{name}/plugins
476 %attr(755,root,root) %{_libdir}/%{name}/%{name}
477 # These unique permissions are intentional and necessary for the sandboxing
478 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
479
480 # ffmpeg libs
481 %if %{with ffmpegsumo}
482 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
483 %endif
484
485 %if %{with nacl}
486 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
487 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
488 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
489 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
490 %endif
491
492 %files l10n -f %{name}.lang
493 %defattr(644,root,root,755)
This page took 0.0832000000000001 seconds and 3 git commands to generate.