]> git.pld-linux.org Git - packages/cfitsio.git/blob - cfitsio.spec
- new
[packages/cfitsio.git] / cfitsio.spec
1 Summary:        CFITSIO Interface Library
2 Summary(pl):    Biblioteka interfejsu CFITSIO
3 Name:           cfitsio
4 Version:        2.410
5 %define sver    %(echo %{version} | tr -d .)
6 Release:        1
7 License:        GPL (forced only by gzip code, basically BSD-like)
8 Group:          Libraries
9 Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/%{name}%{sver}.tar.gz
10 URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
11 BuildRequires:  gcc-g77
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 CFITSIO is a library of ANSI C routines for reading and writing FITS
16 format data files.  A set of Fortran-callable wrapper routines are
17 also included for the convenience of Fortran programmers.
18
19 %description -l pl
20 CFITSIO to biblioteka funkcji w C do odczytu i zapisu plików z danymi
21 w formacie FITS. Zawiera tak¿e zestaw wrapperów pozwalaj±cych na
22 wywo³ywanie tych funkcji z programów w Fortranie.
23
24 %package devel
25 Summary:        Header files and documentation for CFITSIO
26 Summary(pl):    Pliki nag³ówkowe i dokumentacja do CFITSIO
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}
29
30 %description devel
31 Header files and development documentation for CFITSIO.
32
33 %description devel -l pl
34 Pliki nag³ówkowe i dokumentacja programisty do CFITSIO.
35
36 %package static
37 Summary:        Static CFITSIO library
38 Summary(pl):    Statyczna biblioteka CFITSIO
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}
41
42 %description static
43 Static version of CFITSIO library.
44
45 %description static -l pl
46 Statyczna wersja biblioteki CFITSIO.
47
48 %prep
49 %setup -q -n %{name}
50
51 %build
52 %configure2_13
53
54 %{__make} shared all
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
59
60 %{__make} install \
61         FTOOLS_LIB=$RPM_BUILD_ROOT%{_libdir} \
62         FTOOLS_INCLUDE=$RPM_BUILD_ROOT%{_includedir}
63
64 install libcfitsio.so $RPM_BUILD_ROOT%{_libdir}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Licence.txt README changes.txt
75 %attr(755,root,root) %{_libdir}/lib*.so
76
77 %files devel
78 %defattr(644,root,root,755)
79 %doc cfitsio.doc cfitsio.ps fitsio.doc fitsio.ps quick.ps
80 %{_includedir}/*.h
81
82 %files static
83 %defattr(644,root,root,755)
84 %{_libdir}/lib*.a
This page took 0.027209 seconds and 3 git commands to generate.