]> git.pld-linux.org Git - packages/certbot.git/blob - certbot.spec
Version: 0.24.0 and other improvements
[packages/certbot.git] / certbot.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # build doc
4 %bcond_with     tests           # do perform tests (pulls extra dependencies from network)
5 %bcond_without  python3         # build CPython 3.x ACME module
6
7 Summary:        Certbot -  EFF's tool to obtain certs from Let's Encrypt
8 Name:           certbot
9 Version:        0.24.0
10 Release:        1
11 License:        Apache v2.0
12 Group:          Applications/Networking
13 Source0:        https://github.com/certbot/certbot/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  62717533ca2def2577a7b64954d775fd
15 URL:            https://certbot.eff.org/
16 BuildRequires:  python-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.713
19 %if %{with doc}
20 BuildRequires:  python-repoze.sphinx.autointerface
21 BuildRequires:  sphinx-pdg
22 %endif
23 %if %{with tests}
24 BuildRequires:  Zope-Interface
25 BuildRequires:  python-mock
26 BuildRequires:  python-six
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-setuptools
30 Requires:       python3-zope.component >= 4.4.1
31 %else:
32 Requires:       python-zope.component >= 4.4.1
33 %endif
34 Obsoletes:      letsencrypt
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Certbot is part of EFF's effort to encrypt the entire Internet. Secure
40 communication over the Web relies on HTTPS, which requires the use of
41 a digital certificate that lets browsers verify the identify of web
42 servers (e.g., is that really google.com?). Web servers obtain their
43 certificates from trusted third parties called certificate authorities
44 (CAs). Certbot is an easy-to-use client that fetches a certificate
45 from Let's Encrypt - an open certificate authority launched by the
46 EFF, Mozilla, and others - and deploys it to a web server.
47
48 %package -n python-acme
49 Summary:        Python library for the ACME protocol
50 Group:          Libraries/Python
51 Obsoletes:      python-acme-doc < 0.9.3
52
53 %description -n python-acme
54 Python 2 library for use of the Automatic Certificate Management
55 Environment protocol as defined by the IETF. It's used by the Let's
56 Encrypt project.
57
58 %package -n python3-acme
59 Summary:        Python library for the ACME protocol
60 Group:          Libraries/Python
61
62 %description -n python3-acme
63 Python 3 library for use of the Automatic Certificate Management
64 Environment protocol as defined by the IETF. It's used by the Let's
65 Encrypt project.
66
67 %prep
68 %setup -q
69
70 %build
71 %py_build %{?with_tests:test}
72
73 %if %{with doc}
74 cd docs
75 %{__make} -j1 html
76 rm -r _build/html/_sources
77 %endif
78
79 cd acme
80 %py_build %{?with_tests:test}
81
82 %if %{with python3}
83 %py3_build %{?with_tests:test}
84 %endif
85
86 %if %{with doc}
87 cd docs
88 %{__make} -j1 html
89 rm -rf _build/html/_sources
90 %endif
91 cd ..
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var/log,/var/lib}/letsencrypt
96
97 %if %{with python3}
98 %py3_install
99 %else
100 %py_install
101 %endif
102
103 cd acme
104
105 %py_install
106
107 %if %{with python3}
108 %py3_install
109 %endif
110 cd ..
111
112 %py_postclean
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc {CHANGES,README}.rst CONTRIBUTING.md docs/*.txt docs/*.rst
120 %if %{with doc}
121 %doc docs/_build/html/*
122 %else
123 %doc docs/*.rst docs/api docs/man
124 %endif
125 %dir %{_sysconfdir}/letsencrypt
126 %dir /var/log/letsencrypt
127 %dir /var/lib/letsencrypt
128 %attr(755,root,root) %{_bindir}/certbot
129 %if %{with python3}
130 %{py3_sitescriptdir}/certbot
131 %{py3_sitescriptdir}/certbot-%{version}*-py*.egg-info
132 %else
133 %{py_sitescriptdir}/certbot
134 %{py_sitescriptdir}/certbot-%{version}*-py*.egg-info
135 %endif
136
137 %files -n python-acme
138 %defattr(644,root,root,755)
139 %doc acme/README.rst
140 %if %{with doc}
141 %doc acme/docs/_build/html/*
142 %else
143 %doc acme/docs/*.rst acme/docs/api acme/docs/man
144 %endif
145 %{py_sitescriptdir}/acme
146 %{py_sitescriptdir}/acme-%{version}*-py*.egg-info
147
148 %files -n python3-acme
149 %defattr(644,root,root,755)
150 %doc acme/README.rst
151 %if %{with doc}
152 %doc acme/docs/_build/html/*
153 %else
154 %doc acme/docs/*.rst acme/docs/api acme/docs/man
155 %endif
156 %{py3_sitescriptdir}/acme
157 %{py3_sitescriptdir}/acme-%{version}*-py*.egg-info
This page took 0.075876 seconds and 3 git commands to generate.