]> git.pld-linux.org Git - packages/certbot.git/blob - certbot.spec
1daf6a79bcb6a6ddfa62f511fab1247babf9f461
[packages/certbot.git] / certbot.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # build doc
4 %bcond_with     tests           # do perform tests (pulls extra dependencies from network)
5
6 Summary:        Certbot -  EFF's tool to obtain certs from Let's Encrypt
7 Name:           certbot
8 Version:        1.27.0
9 Release:        1
10 License:        Apache v2.0
11 Group:          Applications/Networking
12 Source0:        https://github.com/certbot/certbot/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  09aaa677ed9d47699c2d575b5a4a147e
14 URL:            https://certbot.eff.org/
15 BuildRequires:  python3-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.713
18 %if %{with doc}
19 BuildRequires:  python3-sphinx_rtd_theme
20 BuildRequires:  sphinx-pdg >= 4.5.0
21 %endif
22 %if %{with tests}
23 BuildRequires:  Zope-Interface
24 BuildRequires:  python3-mock
25 BuildRequires:  python3-six
26 %endif
27 BuildRequires:  python3-setuptools
28 Requires:       python3-acme >= %{version}
29 Requires:       python3-zope.component >= 4.4.1
30 Requires:       python3-ndg-httpsclient
31 Obsoletes:      letsencrypt
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Certbot is part of EFF's effort to encrypt the entire Internet. Secure
37 communication over the Web relies on HTTPS, which requires the use of
38 a digital certificate that lets browsers verify the identify of web
39 servers (e.g., is that really google.com?). Web servers obtain their
40 certificates from trusted third parties called certificate authorities
41 (CAs). Certbot is an easy-to-use client that fetches a certificate
42 from Let's Encrypt - an open certificate authority launched by the
43 EFF, Mozilla, and others - and deploys it to a web server.
44
45 %prep
46 %setup -q
47
48 %build
49 cd certbot
50 %py3_build %{?with_tests:test}
51
52 %if %{with doc}
53 %{__make} -C docs html
54 %{__rm} -r docs/_build/html/_sources
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var/log,/var/lib}/letsencrypt
60
61 cd certbot
62 %py3_install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README.rst CHANGELOG.md CONTRIBUTING.md certbot/docs/*.txt
70 %if %{with doc}
71 %doc certbot/docs/_build/html/*
72 %else
73 %doc certbot/docs/*.rst certbot/docs/api certbot/docs/man
74 %endif
75 %dir %{_sysconfdir}/letsencrypt
76 %dir /var/log/letsencrypt
77 %dir /var/lib/letsencrypt
78 %attr(755,root,root) %{_bindir}/certbot
79 %{py3_sitescriptdir}/certbot
80 %{py3_sitescriptdir}/certbot-%{version}*-py*.egg-info
This page took 0.038675 seconds and 2 git commands to generate.