]> git.pld-linux.org Git - packages/catfish.git/blob - catfish.spec
b1509f60d7289ad09970ad94e657b81ca9b977d4
[packages/catfish.git] / catfish.spec
1 Summary:        Versatile file search utility for the Xfce desktop
2 Name:           catfish
3 Version:        1.4.9
4 Release:        1
5 License:        GPL v2
6 Group:          X11/Applications/Graphics
7 Source0:        http://archive.xfce.org/src/apps/catfish/1.4/%{name}-%{version}.tar.bz2
8 # Source0-md5:  829824fba33e86d03345bbc718e7b2d9
9 URL:            https://docs.xfce.org/apps/catfish/
10 BuildRequires:  python3-distutils-extra
11 BuildRequires:  python3-modules
12 BuildRequires:  python3-pexpect
13 BuildRequires:  python3-pygobject3
14 BuildRequires:  python3-setuptools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.714
17 Requires:       gtk-update-icon-cache
18 Requires:       hicolor-icon-theme
19 Requires:       mlocate
20 Requires:       python3-dbus
21 Requires:       python3-pexpect
22 Requires:       python3-pygobject3
23 Suggests:       python3-zeitgeist
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Catfish is a versatile file search utility for the Xfce desktop.
28 Powered by Python and GTK, it is fast, flexible, and exceptional at
29 finding files.
30
31 %prep
32 %setup -q
33
34 # fix #!/usr/bin/env python -> #!/usr/bin/python3:
35 find -name '*.py' | xargs %{__sed} -i -e '1s,^#!.*python$,#!%{__python3},'
36
37 %build
38 %{__python3} setup.py build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_localedir}}
43
44 cp -a build/share/applications/org.xfce.Catfish.desktop $RPM_BUILD_ROOT%{_desktopdir}/
45
46 %{__python3} setup.py install \
47         --skip-build \
48         --prefix=%{_prefix} \
49         --root=$RPM_BUILD_ROOT
50
51 cp -a build/mo/* $RPM_BUILD_ROOT%{_localedir}/
52
53 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
54 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hy_AM,hy}
55
56 %find_lang %{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %update_desktop_database_post
63 %update_icon_cache hicolor
64
65 %postun
66 %update_desktop_database_postun
67 %update_icon_cache hicolor
68
69 %files -f %{name}.lang
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog README
72 %attr(755,root,root) %{_bindir}/%{name}
73 %{_desktopdir}/org.xfce.Catfish.desktop
74 %{_datadir}/metainfo/catfish.appdata.xml
75 %{_iconsdir}/hicolor/*/*/*
76 %{py3_sitedir}/catfish-1.4.9-py3.7.egg-info
77 %{py3_sitedir}/catfish
78 %{py3_sitedir}/catfish_lib
79 %{_datadir}/catfish
80 %{_mandir}/man1/catfish.1*
This page took 0.028142 seconds and 2 git commands to generate.