]> git.pld-linux.org Git - packages/calibre.git/blob - calibre.spec
756d8df968eaf9e87c464dd7b5b199880b8b4151
[packages/calibre.git] / calibre.spec
1 #
2 # TODO: - rewrite generate-tarball.sh script to provide locales.zip handling (if needed)
3 #       - make separate server package with init-scripts, etc...
4 #
5 # NOTE:
6 # Upstream packages some unfree fonts which we cannot redistribute,
7 # so when upgrading calibre we should download upstream tarball by hand from
8 # http://downloads.sourceforge.net/calibre and run generate-tarball.sh script
9 # included as SourceX.
10 #
11 Summary:        E-book converter and library management
12 Summary(pl.UTF-8):      Konwerter oraz biblioteka dla e-booków
13 Name:           calibre
14 Version:        2.28.0
15 Release:        1
16 License:        GPL v3+
17 Group:          Applications/Multimedia
18 Source0:        %{name}-%{version}-nofonts.tar.xz
19 # Source0-md5:  554b35d56adffbed6b0a7a939568d427
20 Source1:        generate-tarball.sh
21 Source2:        %{name}-mount-helper
22 Patch0:         %{name}-prefix.patch
23 Patch1:         %{name}-no-update.patch
24 Patch2:         %{name}-env_module.patch
25 Patch3:         %{name}-locales.patch
26 Patch4:         shebang-python-fix.patch
27 URL:            http://www.calibre-ebook.com/
28 %define         baeutifulsoup_ver 3.0.5
29 %define         pil_ver 1.1.6
30 %define         pyqt5_ver 5.3.1
31 %define         apsw_ver 3.8.0.1
32 %define         cssselect_ver 0.7.1
33 %define         cssutils_ver 1:0.9.9
34 %define         dateutil_ver 1.4.1
35 %define         dns_ver 1.6.0
36 %define         lxml_ver 2.2.1
37 %define         mechanize_ver 0.1.11
38 %define         netifaces_ver 0.8
39 %define         psutil_ver 0.6.1
40 BuildRequires:  ImageMagick-devel >= 6.6.4.7
41 BuildRequires:  Qt5Core-devel
42 BuildRequires:  Qt5DBus-devel
43 BuildRequires:  Qt5Gui-devel
44 BuildRequires:  Qt5PlatformSupport-devel
45 BuildRequires:  Qt5Widgets-devel
46 BuildRequires:  chmlib-devel >= 0.40
47 BuildRequires:  libicu-devel
48 BuildRequires:  libmtp-devel >= 1.1.5
49 BuildRequires:  libwmf-devel >= 0.2.8
50 BuildRequires:  mtdev-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  podofo-devel >= 0.8.2
53 BuildRequires:  poppler-qt5-devel >= 0.28.1
54 BuildRequires:  poppler-glib-devel >= 0.28.1
55 BuildRequires:  python-BeautifulSoup >= %{baeutifulsoup_ver}
56 BuildRequires:  python-PIL >= %{pil_ver}
57 BuildRequires:  python-PyQt5 >= %{pyqt5_ver}
58 BuildRequires:  python-PyQt5-devel-tools >= %{pyqt5_ver}
59 BuildRequires:  python-PyQt5-uic >= %{pyqt5_ver}
60 BuildRequires:  python-apsw >= %{apsw_ver}
61 BuildRequires:  python-cssselect >= %{cssselect_ver}
62 BuildRequires:  python-cssutils >= %{cssutils_ver}
63 BuildRequires:  python-dateutil >= %{dateutil_ver}
64 BuildRequires:  python-devel >= 1:2.7.1
65 BuildRequires:  python-dns >= %{dns_ver}
66 BuildRequires:  python-genshi
67 BuildRequires:  python-lxml >= %{lxml_ver}
68 BuildRequires:  python-mechanize >= %{mechanize_ver}
69 BuildRequires:  python-modules-sqlite
70 BuildRequires:  python-netifaces >= %{netifaces_ver}
71 BuildRequires:  python-psutil >= %{psutil_ver}
72 BuildRequires:  python-sip-devel
73 BuildRequires:  qt5-qmake
74 BuildRequires:  rpm-pythonprov
75 BuildRequires:  rpmbuild(macros) >= 1.586
76 BuildRequires:  sed >= 4.0
77 BuildRequires:  sqlite3-devel
78 BuildRequires:  sip-PyQt5
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  unzip
81 BuildRequires:  xdg-utils
82 BuildRequires:  xz >= 1:4.999.7
83 Requires:       python-BeautifulSoup >= %{baeutifulsoup_ver}
84 Requires:       python-PIL >= %{pil_ver}
85 Requires:       python-PyQt5 >= %{pyqt5_ver}
86 Requires:       python-apsw >= %{apsw_ver}
87 Requires:       python-cssselect >= %{cssselect_ver}
88 Requires:       python-cssutils >= %{cssutils_ver}
89 Requires:       python-dateutil >= %{dateutil_ver}
90 Requires:       python-dns >= %{dns_ver}
91 Requires:       python-genshi
92 Requires:       python-lxml >= %{lxml_ver}
93 Requires:       python-mechanize >= %{mechanize_ver}
94 Requires:       python-modules-sqlite
95 Requires:       python-netifaces >= %{netifaces_ver}
96 Requires:       python-psutil >= %{psutil_ver}
97 Suggests:       ImageMagick-coder-jpeg
98 Suggests:       ImageMagick-coder-png
99 ### FIXME: libunrar.so is needed for rar-packed files
100 Suggests:       libunrar-devel
101 Suggests:       poppler-progs
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105 Calibre is meant to be a complete e-library solution. It includes
106 library management, format conversion, news feeds to ebook conversion
107 as well as e-book reader sync features.
108
109 Calibre is primarily a ebook cataloging program. It manages your ebook
110 collection for you. It is designed around the concept of the logical
111 book, i.e. a single entry in the database that may correspond to
112 ebooks in several formats. It also supports conversion to and from a
113 dozen different ebook formats.
114
115 Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
116 CBR, CBZ, RTF, TXT, PDF and LRS.
117
118 %description -l pl.UTF-8
119 Calibre to bardzo dobry i darmowy program do czytania e-książek.
120
121 Calibre umożliwia zarówno czytanie e-książek jak i konwersję wielu
122 formatów do ich postaci. Program obsługuje następujące typy plików:
123 import: LRF, PDF, LIT, RTF, OPF, MOBI, PRC, EPUB, FB2, IMP, RB i HTML
124 eksport: Mobi, LRF i EPUB oraz do aplikacji iPhone-reader i Stanza.
125
126 Ten czytnik e-książek oferuje również pobieranie okładek, komiksów i
127 najnowszych wiadomości z serwisów poświęconym e-książkom. Twórcy
128 dołączyli również aplikację, którą użytkownik może wykorzystać jako
129 swój własny serwer darmowych książek.
130
131 %package -n bash-completion-calibre
132 Summary:        bash-completion for calibre
133 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla calibre
134 Group:          Applications/Shells
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       bash-completion
137 %if "%{_rpmversion}" >= "5"
138 BuildArch:      noarch
139 %endif
140
141 %description -n bash-completion-calibre
142 bash-completion for calibre.
143
144 %description -n bash-completion-calibre -l pl.UTF-8
145 Pakiet ten dostarcza bashowe uzupełnianie nazw dla calibre.
146
147 %package -n zsh-completion-calibre
148 Summary:        zsh-completion for calibre
149 Summary(pl.UTF-8):      uzupełnianie nazw dla calibre w powłoce zsh
150 Group:          Applications/Shells
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       bash-completion
153
154 %description -n zsh-completion-calibre
155 zsh-completion for calibre.
156
157 %description -n zsh-completion-calibre -l pl.UTF-8
158 Pakiet ten dostarcza uzupełnianie nazw dla calibre w powłoce zsh.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 #%patch1 -p1 Patch does not apply, not removed completly since spec update is in progress
164 %patch2 -p1
165 %patch3 -p1
166 %patch4 -p1
167
168 # 64bit target build fix
169 %{__sed} -i -e "s!'/usr/lib'!'%{_libdir}'!g" setup/build_environment.py
170
171 # upstream decides to store locale files in a single zip file but we prefer separate .mo
172 mkdir resources/localization/locales
173 unzip resources/localization/locales.zip -d resources/localization/locales
174 chmod 755 resources/localization/locales/*
175 rm -f resources/localization/locales.zip
176
177 %build
178 CC="%{__cc}" \
179 CXX=%{__cxx} \
180 OVERRIDE_CFLAGS="%{rpmcflags}" \
181 OVERRIDE_LDFLAGS="%{rpmldflags}" \
182 QMAKE="%{_bindir}/qmake-qt5" \
183 %{__python} setup.py build
184
185 %install
186 rm -rf $RPM_BUILD_ROOT
187 # create directories for xdg-utils
188 install -d $RPM_BUILD_ROOT%{_datadir}/{icons/hicolor,packages,mime/packages,desktop-directories} \
189         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/usr/share/zsh/site-functions}
190
191 XDG_DATA_DIRS="$RPM_BUILD_ROOT%{_datadir}" \
192 XDG_UTILS_INSTALL_MODE="system" \
193 LIBPATH="%{_libdir}" \
194 %{__python} setup.py install \
195         --root=$RPM_BUILD_ROOT \
196         --libdir="%{_libdir}"
197
198 cp -p resources/images/library.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}-gui.png
199 cp -p resources/images/viewer.png $RPM_BUILD_ROOT%{_pixmapsdir}/calibre-viewer.png
200
201 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}
202 %py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}
203 %py_postclean %{_libdir}/%{name}
204
205 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/localization/locales $RPM_BUILD_ROOT%{_localedir}
206
207 # set proper filenames for locales (TODO: switch to patch if possible)
208 for file in $RPM_BUILD_ROOT%{_localedir}/*; do
209         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\).*:\1:')
210         mkdir $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
211         mv $RPM_BUILD_ROOT%{_localedir}/$lang/*.mo \
212                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
213 done;
214 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/messages.mo; do
215         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
216         mv $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/messages.mo \
217                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}.mo
218 done;
219 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/iso639.mo; do
220         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
221         mv $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/iso639.mo \
222                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}_iso639.mo
223 done;
224 for file in $RPM_BUILD_ROOT%{_localedir}/*/lcdata.pickle; do
225         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/lcdata.pickle:\1:')
226         mv $RPM_BUILD_ROOT%{_localedir}/$lang/lcdata.pickle \
227                 $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES/%{name}_lcdata.pickle
228 done;
229
230 %{__rm} $RPM_BUILD_ROOT%{_bindir}/%{name}-uninstall
231
232 # unsupported
233 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bn_BD
234 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/jv
235 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ltg
236 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sl_SI
237
238 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
239
240 %find_lang %{name} --all-name
241 for file in $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/%{name}_lcdata.pickle; do
242         lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
243         echo $file | %{__sed} "s:$RPM_BUILD_ROOT\(.*\):%lang($lang) \1:" >>%{name}.lang
244 done;
245
246 %clean
247 rm -rf $RPM_BUILD_ROOT
248
249 %post
250 %update_desktop_database
251 %update_mime_database
252 %update_icon_cache hicolor
253
254 %postun
255 if [ $1 -eq 0 ] ; then
256         %update_desktop_database
257         %update_mime_database
258         %update_icon_cache hicolor
259 fi
260
261 %files -f %{name}.lang
262 %defattr(644,root,root,755)
263 %doc Changelog.yaml COPYRIGHT README.md
264 %attr(755,root,root) %{_bindir}/calibre
265 %attr(755,root,root) %{_bindir}/calibre-complete
266 %attr(755,root,root) %{_bindir}/calibre-customize
267 %attr(755,root,root) %{_bindir}/calibre-debug
268 %attr(755,root,root) %{_bindir}/calibre-mount-helper
269 %attr(755,root,root) %{_bindir}/calibre-parallel
270 %attr(755,root,root) %{_bindir}/calibre-server
271 %attr(755,root,root) %{_bindir}/calibre-smtp
272 %attr(755,root,root) %{_bindir}/calibredb
273 %attr(755,root,root) %{_bindir}/ebook-convert
274 %attr(755,root,root) %{_bindir}/ebook-device
275 %attr(755,root,root) %{_bindir}/ebook-edit
276 %attr(755,root,root) %{_bindir}/ebook-meta
277 %attr(755,root,root) %{_bindir}/ebook-polish
278 %attr(755,root,root) %{_bindir}/ebook-viewer
279 %attr(755,root,root) %{_bindir}/fetch-ebook-metadata
280 %attr(755,root,root) %{_bindir}/lrf2lrs
281 %attr(755,root,root) %{_bindir}/lrfviewer
282 %attr(755,root,root) %{_bindir}/lrs2lrf
283 %attr(755,root,root) %{_bindir}/markdown-calibre
284 %attr(755,root,root) %{_bindir}/web2disk
285 %{_datadir}/%{name}
286 %{_datadir}/appdata/calibre-ebook-edit.appdata.xml
287 %{_datadir}/appdata/calibre-ebook-viewer.appdata.xml
288 %{_datadir}/appdata/calibre-gui.appdata.xml
289 %{_libdir}/%{name}
290 %{_desktopdir}/calibre-ebook-edit.desktop
291 %{_desktopdir}/calibre-ebook-viewer.desktop
292 %{_desktopdir}/calibre-gui.desktop
293 %{_desktopdir}/calibre-lrfviewer.desktop
294 %{_iconsdir}/hicolor/*/*/*.png
295 %{_datadir}/mime/application/*.xml
296 %{_datadir}/mime/text/*.xml
297 %{_datadir}/mime/packages/calibre-mimetypes.xml
298 %{_pixmapsdir}/%{name}-gui.png
299 %{_pixmapsdir}/calibre-viewer.png
300
301 %files -n bash-completion-calibre
302 %defattr(644,root,root,755)
303 %{bash_compdir}/calibre
304
305 %files -n zsh-completion-calibre
306 %defattr(644,root,root,755)
307 %{_datadir}/zsh/site-functions/*
This page took 0.118621 seconds and 2 git commands to generate.