]> git.pld-linux.org Git - packages/cacti-plugin-configmanager.git/blob - cacti-plugin-configmanager.spec
- use virtual names for php deps
[packages/cacti-plugin-configmanager.git] / cacti-plugin-configmanager.spec
1 %define         plugin configmanager
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Plugin for Cacti - download/upload routers and switches configuration
5 Summary(pl.UTF-8):      Wtyczka do Cacti - ściąganie/wysyłanie konfiguracji routerów/switchy
6 Name:           cacti-plugin-%{plugin}
7 Version:        0.826
8 Release:        2
9 License:        GPL v2
10 Group:          Applications/WWW
11 # http://forums.cacti.net/download.php?id=6449
12 Source0:        http://forums.cacti.net/download/file.php?id=21891#/%{plugin}-%{version}.zip
13 # Source0-md5:  d3cdb035a4d47ff464916774dd953457
14 # http://forums.cacti.net/download.php?id=10980
15 Source1:        sharednetworkclass0.40.zip
16 # Source1-md5:  b438751d7b696a10a8958ea6e0f407f3
17 URL:            http://docs.cacti.net/userplugin:configmanager
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
19 BuildRequires:  rpmbuild(macros) >= 1.553
20 BuildRequires:  unzip
21 Requires:       cacti
22 Requires:       cacti(pia) >= 2.0
23 Requires:       php(core) >= %{php_min_version}
24 Requires:       php(date)
25 Requires:       php(mysql)
26 Requires:       php(pcre)
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         cactidir                /usr/share/cacti
31 %define         plugindir               %{cactidir}/plugins/%{plugin}
32
33 # bad depsolver
34 %define         _noautopear     pear(include/config.php)
35
36 # put it together for rpmbuild
37 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
38
39 %description
40 With Cacti configmanager plugin you can easily schedule the
41 download/upload of the configuration of your routers, switches and any
42 devices (or change in one click some parameters of a hundred of
43 switches... dangerous but possible now). It should function for all
44 type of router or switches.
45
46 There are two methods:
47 - "TFTP" (based of "pancho" <http://www.pancho.org/>); with "pure PHP"
48   option there is no need of pancho installation (depreciated after
49   v0.9)
50 - "multi" can use any scripts or SCP, FTP, SFTP or what you want.
51
52 %description -l pl.UTF-8
53 Przy użyciu wtyczki Cacti configmanager można łatwo zaszeregować
54 ściąganie lub wysyłanie konfiguracji routerów, switchy i innych
55 urządzeń (lub zmieniać jednym kliknięciem pewne parametry w setce
56 switchy... co jest niebezpieczne, ale teraz wykonalne). Wtyczka
57 powinna działać z dowolnymi routerami i switchami.
58
59 Istnieją dwie metody:
60 - "TFTP" (oparta na "pancho" <http://www.pancho.org/>); z opcją "pure
61   PHP" nie ma potrzeby instalacji pancho
62 - "multi", potrafiąca używać dowolne skrypty lub SCP, FTP, SFTP
63
64 %prep
65 %setup -qc -a1
66 %undos -f php,inc,txt
67
68 mv %{plugin}/{Manual.txt,template.txt,configmanager_trap_list.txt} .
69
70 # bad os
71 %{__rm} %{plugin}/scripts/*.cmd
72
73 # unwanted junk
74 mv %{plugin}/OLD .
75
76 # deprecated since 0.9, but package for now (see Manual.txt)
77 mv sharednetworkclass{0.40,}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{plugindir}
82 cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
83 cp -a sharednetworkclass $RPM_BUILD_ROOT%{cactidir}/plugins
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc Manual.txt template.txt configmanager_trap_list.txt
91 %{plugindir}
92 %{cactidir}/plugins/sharednetworkclass
This page took 0.07922 seconds and 3 git commands to generate.