]> git.pld-linux.org Git - packages/btparser.git/blob - btparser.spec
- updated to 0.25
[packages/btparser.git] / btparser.spec
1 Summary:        Parser and analyzer for backtraces produced by GDB
2 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
3 Name:           btparser
4 Version:        0.25
5 Release:        1
6 License:        GPL v2+
7 Group:          Development/Tools
8 Source0:        https://fedorahosted.org/released/btparser/%{name}-%{version}.tar.xz
9 # Source0-md5:  7fcf3f97dd6df827151638a41855c5bb
10 URL:            http://fedorahosted.org/btparser/
11 %ifarch %{x8664}
12 BuildRequires:  binutils-static
13 %endif
14 BuildRequires:  glib2-devel >= 1:2.21
15 BuildRequires:  pkgconfig
16 BuildRequires:  python-devel
17 BuildRequires:  python-distribute
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  xmlto
21 Requires:       %{name}-libs = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Btparser is a backtrace parser and analyzer, which works with
26 backtraces produced by the GNU Project Debugger. It can parse a text
27 file with a backtrace to a tree of C structures, allowing to analyze
28 the threads and frames of the backtrace and work with them.
29
30 Btparser also contains some backtrace manipulation and extraction
31 routines:
32 - it can find a frame in the crash-time backtrace where the program
33   most likely crashed (a chance is that the function described in that
34   frame is buggy)
35 - it can produce a duplication hash of the backtrace, which helps to
36   discover that two crash-time backtraces are duplicates, triggered by
37   the same flaw of the code
38 - it can "rate" the backtrace quality, which depends on the number of
39   frames with and without the function name known (missing function
40   name is caused by missing debugging symbols)
41
42 %description -l pl.UTF-8
43 Btparser to analizator śladów wywołań (backtrace'ów), działający ze
44 śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
45 przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
46 na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
47
48 Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
49 wywołań:
50 - potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
51   najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to
52   funkcja w tej ramce zawiera błąd)
53 - potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
54   zadane ślady pośmiertne są duplikatami spowodowanymi tym samym
55   błędem w kodzie
56 - potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
57   bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
58   diagnostycznych)
59
60 %package libs
61 Summary:        Btparser library
62 Summary(pl.UTF-8):      Biblioteka btparser
63 Group:          Libraries
64 Requires:       glib2 >= 1:2.21
65
66 %description libs
67 Btparser library.
68
69 %description libs -l pl.UTF-8
70 Biblioteka btparser.
71
72 %package devel
73 Summary:        Header files for %{name} library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       glib2-devel >= 1:2.21
78
79 %description devel
80 Header files for %{name} library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki %{name}.
84
85 %package -n python-btparser
86 Summary:        Python bindings for %{name}
87 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki btparser
88 Group:          Libraries/Python
89 Requires:       %{name}-libs = %{version}-%{release}
90 Requires:       python-modules
91
92 %description -n python-btparser
93 Python bindings for %{name}.
94
95 %description -n python-btparser -l pl.UTF-8
96 Wiązania Pythona do biblioteki btparser.
97
98 %prep
99 %setup -q
100
101 %build
102 %configure \
103 %ifarch %{x8664}
104         --enable-fingerprints
105 %endif
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
116
117 %py_postclean
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   libs -p /sbin/ldconfig
123 %postun libs -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc ChangeLog NEWS README RELEASE TODO
128 %attr(755,root,root) %{_bindir}/btparser
129 %{_mandir}/man1/btparser.1*
130
131 %files libs
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libbtparser.so.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libbtparser.so
139 %{_includedir}/btparser
140 %{_pkgconfigdir}/btparser.pc
141
142 %files -n python-btparser
143 %defattr(644,root,root,755)
144 %dir %{py_sitedir}/btparser
145 %{py_sitedir}/btparser/__init__.py[co]
146 %attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.081737 seconds and 3 git commands to generate.