]> git.pld-linux.org Git - packages/btparser.git/blob - btparser.spec
c55f47bbc7069103ca4be47b0f28b6a24d39fb53
[packages/btparser.git] / btparser.spec
1 Summary:        Parser and analyzer for backtraces produced by GDB
2 Name:           btparser
3 Version:        0.20
4 Release:        1
5 License:        GPL v2
6 Group:          Applications
7 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.xz
8 # Source0-md5:  dac50574a3015d6ca6eb588a2efb4686
9 URL:            http://fedorahosted.org/btparser
10 %ifarch %{x8664}
11 BuildRequires:  binutils-static
12 %endif
13 BuildRequires:  python-devel
14 BuildRequires:  python-distribute
15 BuildRequires:  rpm-pythonprov
16 Requires:       %{name}-libs = %{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Btparser is a backtrace parser and analyzer, which works with
21 backtraces produced by the GNU Project Debugger. It can parse a text
22 file with a backtrace to a tree of C structures, allowing to analyze
23 the threads and frames of the backtrace and work with them.
24
25 Btparser also contains some backtrace manipulation and extraction
26 routines:
27 - it can find a frame in the crash-time backtrace where the program
28   most likely crashed (a chance is that the function described in that
29   frame is buggy)
30 - it can produce a duplication hash of the backtrace, which helps to
31   discover that two crash-time backtraces are duplicates, triggered by
32   the same flaw of the code
33 - it can "rate" the backtrace quality, which depends on the number of
34   frames with and without the function name known (missing function
35   name is caused by missing debugging symbols)
36
37 %package libs
38 Summary:        Btparser library
39 Summary(pl.UTF-8):      Biblioteka btparser
40 Group:          Libraries
41 Requires:       python-libs
42 Requires:       python-modules
43
44 %description libs
45 Btparser libraries
46
47 %description libs -l pl.UTF-8
48 Biblioteka btparser.
49
50 %package devel
51 Summary:        Header files for %{name} library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
53 Group:          Development/Libraries
54 Requires:       %{name}-libs = %{version}-%{release}
55
56 %description devel
57 Header files for %{name} library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki %{name}.
61
62 %package -n python-btparser
63 Summary:        Python bindings for %{name}
64 Group:          Development/Libraries
65 Requires:       %{name}-libs = %{version}-%{release}
66
67 %description -n python-btparser
68 Python bindings for %{name}.
69
70 %prep
71 %setup -q
72
73 %build
74 %ifarch %{x8664}
75 %configure \
76         --enable-fingerprints
77 %else
78 %configure
79 %endif
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   libs -p /sbin/ldconfig
94 %postun libs -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc ChangeLog NEWS README RELEASE TODO
99 %attr(755,root,root) %{_bindir}/btparser
100 %{_mandir}/man1/btparser.1*
101
102 %files libs
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libbtparser.so.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_pkgconfigdir}/btparser.pc
110 %{_includedir}/btparser
111 %{_libdir}/libbtparser.so
112
113 %files -n python-btparser
114 %{py_sitedir}/btparser/*.py*
115 %attr(755,root,root) %{py_sitedir}/btparser/*.so
This page took 0.046457 seconds and 2 git commands to generate.